projects
/
openwrt
/
staging
/
wigyori.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
44f694b
)
build: select procd-seccomp if kernel support is present
author
Daniel Golle
<daniel@makrotopia.org>
Fri, 6 Nov 2020 02:10:28 +0000
(
02:10
+0000)
committer
Paul Spooren
<mail@aparcar.org>
Fri, 8 Oct 2021 09:22:18 +0000
(23:22 -1000)
Install ld-preload hooks allowing to add seccomp filters for arbitrary
services if kernel support for seccomp is present.
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
include/target.mk
patch
|
blob
|
history
diff --git
a/include/target.mk
b/include/target.mk
index eac2d164c3badf2e5a55691808465ab397b86fb8..03192d3ebef4904851f8b798aa1bffa279a6036e 100644
(file)
--- a/
include/target.mk
+++ b/
include/target.mk
@@
-38,6
+38,11
@@
ifeq ($(CONFIG_SMALL_FLASH),)
DEFAULT_PACKAGES+=procd-ujail
endif
+# include seccomp ld-preload hooks if kernel supports it
+ifneq ($(CONFIG_KERNEL_SECCOMP),)
+DEFAULT_PACKAGES+=procd-seccomp
+endif
+
# For the basic set
DEFAULT_PACKAGES.basic:=
# For nas targets