add flashrom, an utility for identifying, reading, writing, verifying and erasing...
authorNicolas Thill <nico@openwrt.org>
Mon, 19 Apr 2010 06:55:37 +0000 (06:55 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 19 Apr 2010 06:55:37 +0000 (06:55 +0000)
SVN-Revision: 21019

utils/flashrom/Makefile [new file with mode: 0644]

diff --git a/utils/flashrom/Makefile b/utils/flashrom/Makefile
new file mode 100644 (file)
index 0000000..698dc43
--- /dev/null
@@ -0,0 +1,41 @@
+# 
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=flashrom
+PKG_VERSION:=0.9.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://qa.coreboot.org/releases/
+PKG_MD5SUM:=2b7cc0e45a0ac4c6d43c0f7cd05b041a
+
+include $(INCLUDE_DIR)/package.mk
+
+
+define Package/flashrom
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=FlashROM Utility
+  URL:=http://www.flashrom.org/
+# XXX: needs <sys/io.h>, only available on theese arch right now
+  DEPENDS:=+zlib +pciutils @(arm||armeb||i386||i686||x86_64)
+endef
+
+define Package/flashrom/description
+ flashrom is a utility for identifying, reading, writing, verifying
+ and erasing flash chips. It's often used to flash BIOS/EFI/coreboot
+ /firmware images. 
+endef
+
+define Package/flashrom/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/flashrom $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,flashrom))