projects
/
openwrt
/
staging
/
rmilecki.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
4f3876f
)
add prereq check for extended getopt (#3944)
author
Felix Fietkau
<nbd@openwrt.org>
Tue, 2 Sep 2008 10:57:14 +0000
(10:57 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Tue, 2 Sep 2008 10:57:14 +0000
(10:57 +0000)
SVN-Revision: 12491
include/prereq-build.mk
patch
|
blob
|
history
diff --git
a/include/prereq-build.mk
b/include/prereq-build.mk
index fbe7d69f4483f1bcffe636c3adeb999e33cbec8d..d6d2d73a63c39549936e19f5e2e4c2920f2fbd55 100644
(file)
--- a/
include/prereq-build.mk
+++ b/
include/prereq-build.mk
@@
-134,3
+134,11
@@
endef
$(eval $(call Require,gnu-find, \
Please install GNU find \
))
+
+define Require/getopt-extended
+ getopt --long - - >/dev/null
+endef
+
+$(eval $(call Require,getopt-extended, \
+ Please install an extended getopt version that supports --long \
+))