compat-drivers: build driver/video/hdmi.ko
authorHauke Mehrtens <hauke@hauke-m.de>
Wed, 27 Feb 2013 23:53:39 +0000 (00:53 +0100)
committerLuis R. Rodriguez <mcgrof@do-not-panic.com>
Thu, 28 Feb 2013 00:12:44 +0000 (16:12 -0800)
This module is needed by the drm driver now.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Signed-off-by: Luis R. Rodriguez <mcgrof@do-not-panic.com>
Makefile
config.mk
scripts/admin-update.sh

index e986a0915153af4821c36305050d8432fb855ea5..89bc9916aad534290319c6cbfaecdf0db9323641 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -42,6 +42,7 @@ obj-y := compat/
 
 obj-$(CONFIG_COMPAT_RFKILL) += net/rfkill/
 obj-$(CONFIG_COMPAT_VIDEO_MODULES) += drivers/gpu/drm/
+obj-$(CONFIG_COMPAT_VIDEO_MODULES) += drivers/video/
 
 ifeq ($(BT),)
 obj-$(CONFIG_COMPAT_WIRELESS) += net/wireless/ net/mac80211/
index add66c7b7eab0a566ad1381d67a748ec29c08bae..13b44d4321a0ca9a4ae72c639bc69583519da020 100644 (file)
--- a/config.mk
+++ b/config.mk
@@ -723,6 +723,7 @@ endif #CONFIG_COMPAT_KERNEL_2_6_31
 # tests have only started on 3.2.
 ifndef CONFIG_COMPAT_KERNEL_3_2
 # Basic DRM support
+export CONFIG_COMPAT_HDMI=m
 export CONFIG_COMPAT_VIDEO_MODULES=y
 export CONFIG_COMPAT_DRM=m
 export CONFIG_COMPAT_DRM_TTM=m
index 48055a92cfa26687a53819dc3732521ba33e99f4..e1e5f0d3c252d0a98992b480518b894498a61146 100755 (executable)
@@ -444,7 +444,8 @@ mkdir -p include/net/bluetooth \
         $DRIVERS_WLAN \
         $DRIVERS_ETH \
         $DRIVERS_BT \
-        $DRIVERS_DRM
+        $DRIVERS_DRM \
+        drivers/video
 
 
 
@@ -677,8 +678,14 @@ if [[ "$ENABLE_DRM" == "1" ]]; then
 
        # Finally get the DRM top-level makefile
        cp $GIT_TREE/drivers/gpu/drm/Makefile drivers/gpu/drm
+
+       DIR="drivers/video"
+       cp $GIT_TREE/$DIR/hdmi.c $DIR
+       echo "obj-\$(CONFIG_COMPAT_HDMI) += hdmi.o" > $DIR/Makefile
+       cp $GIT_TREE/include/linux/hdmi.h include/linux/hdmi.h
 else
        touch drivers/gpu/drm/Makefile
+       touch drivers/video/Makefile
 fi
 
 # Staging drivers in their own directory