ltq-vdsl-vr11-app: fix error handling during disconnection
authorJan Hoffmann <jan@3e8.eu>
Fri, 12 Jul 2024 13:49:50 +0000 (15:49 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 31 Aug 2024 17:40:21 +0000 (19:40 +0200)
Use the correct return value in error message.

Fixes: 6e4c9738bed0 ("ltq-vdsl-vr11-app: add version 4.23.1 for vr11 targets")
Signed-off-by: Jan Hoffmann <jan@3e8.eu>
package/network/config/ltq-vdsl-vr11-app/Makefile
package/network/config/ltq-vdsl-vr11-app/patches/200-autoboot.patch

index bcbf41e65a153d5c7e7255513426b60349bd5e7b..4e26ee459a1e3f7e168f9988a09fb6e546d9ceff 100644 (file)
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ltq-vdsl-vr11-app
 PKG_VERSION:=4.23.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_BASE_NAME:=dsl_cpe_control
 
 UGW_VERSION=8.5.2.10
index c3e9b96620488022ff5af43972140dd1a28c79c9..3397c7f024e394d23b32372b96c7b66665d1fc62 100644 (file)
@@ -51,7 +51,7 @@ start it again later, short of unloading and reloading the module.
 +      {
 +         DSL_CCA_DEBUG(DSL_CCA_DBG_ERR, (DSL_CPE_PREFIX
 +            "Autoboot configuration for device (%d) failed!, nRet = %d!"
-+            DSL_CPE_CRLF, nDevice, sAutobootCtl.accessCtl.nReturn));
++            DSL_CPE_CRLF, nDevice, sAutobootCfg.accessCtl.nReturn));
 +      }
 +
        memset(&sAutobootCtl, 0, sizeof(DSL_AutobootControl_t));