apk: add a customfeeds.list configuration file
authorJonas Gorski <jonas.gorski@gmail.com>
Wed, 13 Nov 2024 13:27:16 +0000 (14:27 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Sat, 16 Nov 2024 16:26:27 +0000 (17:26 +0100)
Analog to how we handle custom feeds in opkg, add a customfeeds.list for
custom package feeds and mark it as a configuration file.

Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/16940
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
package/system/apk/Makefile
package/system/apk/files/customfeeds.list [new file with mode: 0644]

index 4dbd0f854f37b43e7a74e0bce65f45215a28f39d..fbb9ef85ee301ebc02ac35bee6e457fe4c76cf32 100644 (file)
@@ -14,7 +14,7 @@ PKG_VERSION=3.0.0_pre$(subst -,,$(PKG_SOURCE_DATE))
 PKG_MAINTAINER:=Paul Spooren <mail@aparcar.org>
 PKG_LICENSE:=GPL-2.0-only
 PKG_LICENSE_FILES:=LICENSE
-PKG_INSTALL:=1
+PKG_INSTALL:=2
 
 HOST_BUILD_PREFIX:=$(STAGING_DIR_HOST)
 HOST_BUILD_DEPENDS:=lua/host
@@ -68,6 +68,13 @@ MESON_ARGS += \
        $(MESON_COMMON_ARGS) \
        -Dcrypto_backend=$(BUILD_VARIANT)
 
+define Package/apk/conffiles
+/etc/apk/repositories.d/customfeeds.list
+endef
+
+Package/apk-mbedtls/conffiles = $(Package/apk/conffiles)
+Package/apk-openssl/conffiles = $(Package/apk/conffiles)
+
 define Package/apk/default/install
        $(INSTALL_DIR) $(1)/lib/apk/db
 
@@ -76,6 +83,9 @@ define Package/apk/default/install
 
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libapk.so.* $(1)/usr/lib/
+
+       $(INSTALL_DIR) $(1)/etc/apk/repositories.d
+       $(INSTALL_DATA) ./files/customfeeds.list $(1)/etc/apk/repositories.d/customfeeds.list
 endef
 
 Package/apk-mbedtls/install = $(Package/apk/default/install)
diff --git a/package/system/apk/files/customfeeds.list b/package/system/apk/files/customfeeds.list
new file mode 100644 (file)
index 0000000..c75016b
--- /dev/null
@@ -0,0 +1,3 @@
+# add your custom package feeds here
+#
+# http://www.example.com/path/to/files/packages.adb