iw: update to version 6.9
authorFelix Fietkau <nbd@nbd.name>
Mon, 10 Jun 2024 18:50:38 +0000 (20:50 +0200)
committerFelix Fietkau <nbd@nbd.name>
Fri, 21 Jun 2024 09:52:25 +0000 (11:52 +0200)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/network/utils/iw/Makefile
package/network/utils/iw/patches/010-Revert-iw-allow-specifying-CFLAGS-LIBS-externally.patch
package/network/utils/iw/patches/200-reduce_size.patch

index 528f6868b232e8e94a28e4143ea3311adadf4cb1..1237c106a92c9f59b933ec750c80c5c5126e0a7d 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iw
-PKG_VERSION:=5.19
+PKG_VERSION:=6.9
 PKG_RELEASE:=1
  
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/software/network/iw
-PKG_HASH:=f167bbe947dd53bb9ebc0c1dcef5db6ad73ac1d6084f2c6f9376c5c360cc4d4e
+PKG_HASH:=3f2db22ad41c675242b98ae3942dbf3112548c60a42ff739210f2de4e98e4894
 
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 PKG_LICENSE:=GPL-2.0
index 1254efa9c70503bbf7801c7ca13e4a38fed4222b..1c93f00900f1548fc11f5ea187f9886f1abb5ebe 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
 
 --- a/Makefile
 +++ b/Makefile
-@@ -45,30 +45,30 @@ NLLIBNAME = libnl-1
+@@ -46,30 +46,30 @@ NLLIBNAME = libnl-1
  endif
  
  ifeq ($(NL2FOUND),Y)
@@ -55,7 +55,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
  NLLIBNAME = libnl-3.1
  endif
  
-@@ -76,8 +76,8 @@ ifeq ($(NLLIBNAME),)
+@@ -77,8 +77,8 @@ ifeq ($(NLLIBNAME),)
  $(error Cannot find development files for any supported version of libnl)
  endif
  
index 862199452425bd5f68ba7d115036c42de9a795a4..9924ffa0774552ee0af59538b78bf1f03441617a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/event.c
 +++ b/event.c
-@@ -971,6 +971,7 @@ static int print_event(struct nl_msg *ms
+@@ -973,6 +973,7 @@ static int print_event(struct nl_msg *ms
        }
  
        switch (gnlh->cmd) {
@@ -8,7 +8,7 @@
        case NL80211_CMD_NEW_WIPHY:
                printf("renamed to %s\n", nla_get_string(tb[NL80211_ATTR_WIPHY_NAME]));
                break;
-@@ -1006,6 +1007,7 @@ static int print_event(struct nl_msg *ms
+@@ -1008,6 +1009,7 @@ static int print_event(struct nl_msg *ms
        case NL80211_CMD_SCHED_SCAN_RESULTS:
                printf("got scheduled scan results\n");
                break;
@@ -16,7 +16,7 @@
        case NL80211_CMD_WIPHY_REG_CHANGE:
        case NL80211_CMD_REG_CHANGE:
                if (gnlh->cmd == NL80211_CMD_WIPHY_REG_CHANGE)
-@@ -1088,6 +1090,7 @@ static int print_event(struct nl_msg *ms
+@@ -1090,6 +1092,7 @@ static int print_event(struct nl_msg *ms
                mac_addr_n2a(macbuf, nla_data(tb[NL80211_ATTR_MAC]));
                printf("del station %s\n", macbuf);
                break;
@@ -24,7 +24,7 @@
        case NL80211_CMD_JOIN_IBSS:
                mac_addr_n2a(macbuf, nla_data(tb[NL80211_ATTR_MAC]));
                printf("IBSS %s joined\n", macbuf);
-@@ -1295,9 +1298,9 @@ static int print_event(struct nl_msg *ms
+@@ -1297,9 +1300,9 @@ static int print_event(struct nl_msg *ms
        case NL80211_CMD_ASSOC_COMEBACK: /* 147 */
                parse_assoc_comeback(tb, gnlh->cmd);
                break;
@@ -38,7 +38,7 @@
  
 --- a/info.c
 +++ b/info.c
-@@ -309,6 +309,7 @@ next:
+@@ -446,6 +446,7 @@ next:
                                }
                        }
  
@@ -46,7 +46,7 @@
                        if (tb_band[NL80211_BAND_ATTR_RATES]) {
                        printf("\t\tBitrates (non-HT):\n");
                        nla_for_each_nested(nl_rate, tb_band[NL80211_BAND_ATTR_RATES], rem_rate) {
-@@ -325,6 +326,7 @@ next:
+@@ -462,6 +463,7 @@ next:
                                printf("\n");
                        }
                        }
@@ -54,7 +54,7 @@
                }
        }
  
-@@ -390,6 +392,7 @@ next:
+@@ -527,6 +529,7 @@ next:
                printf("\tCoverage class: %d (up to %dm)\n", coverage, 450 * coverage);
        }
  
@@ -62,7 +62,7 @@
        if (tb_msg[NL80211_ATTR_CIPHER_SUITES]) {
                int num = nla_len(tb_msg[NL80211_ATTR_CIPHER_SUITES]) / sizeof(__u32);
                int i;
-@@ -401,6 +404,7 @@ next:
+@@ -538,6 +541,7 @@ next:
                                        cipher_name(ciphers[i]));
                }
        }
@@ -70,7 +70,7 @@
  
        if (tb_msg[NL80211_ATTR_WIPHY_ANTENNA_AVAIL_TX] &&
            tb_msg[NL80211_ATTR_WIPHY_ANTENNA_AVAIL_RX])
-@@ -418,9 +422,11 @@ next:
+@@ -555,9 +559,11 @@ next:
                print_iftype_list("\tSupported interface modes", "\t\t",
                                  tb_msg[NL80211_ATTR_SUPPORTED_IFTYPES]);
  
@@ -82,7 +82,7 @@
  
        if (tb_msg[NL80211_ATTR_INTERFACE_COMBINATIONS]) {
                struct nlattr *nl_combi;
-@@ -510,6 +516,7 @@ broken_combination:
+@@ -647,6 +653,7 @@ broken_combination:
                        printf("\tinterface combinations are not supported\n");
        }
  
@@ -90,7 +90,7 @@
        if (tb_msg[NL80211_ATTR_SUPPORTED_COMMANDS]) {
                printf("\tSupported commands:\n");
                nla_for_each_nested(nl_cmd, tb_msg[NL80211_ATTR_SUPPORTED_COMMANDS], rem_cmd)
-@@ -607,6 +614,7 @@ broken_combination:
+@@ -744,6 +751,7 @@ broken_combination:
                                printf("\t\t * wake up on TCP connection\n");
                }
        }
@@ -98,7 +98,7 @@
  
        if (tb_msg[NL80211_ATTR_ROAM_SUPPORT])
                printf("\tDevice supports roaming.\n");
-@@ -645,6 +653,7 @@ broken_combination:
+@@ -782,6 +790,7 @@ broken_combination:
                }
        }
  
        if (tb_msg[NL80211_ATTR_FEATURE_FLAGS]) {
                unsigned int features = nla_get_u32(tb_msg[NL80211_ATTR_FEATURE_FLAGS]);
  
-@@ -709,6 +718,7 @@ broken_combination:
+@@ -846,6 +855,7 @@ broken_combination:
                if (features & NL80211_FEATURE_ND_RANDOM_MAC_ADDR)
                        printf("\tDevice supports randomizing MAC-addr in net-detect scans.\n");
        }
  
        if (tb_msg[NL80211_ATTR_TDLS_SUPPORT])
                printf("\tDevice supports T-DLS.\n");
-@@ -774,6 +784,7 @@ TOPLEVEL(list, NULL, NL80211_CMD_GET_WIP
+@@ -914,6 +924,7 @@ TOPLEVEL(list, NULL, NL80211_CMD_GET_WIP
         "List all wireless devices and their capabilities.");
  TOPLEVEL(phy, NULL, NL80211_CMD_GET_WIPHY, NLM_F_DUMP, CIB_NONE, handle_info, NULL);
  
  static int handle_commands(struct nl80211_state *state, struct nl_msg *msg,
                           int argc, char **argv, enum id_input id)
  {
-@@ -785,6 +796,7 @@ static int handle_commands(struct nl8021
+@@ -925,6 +936,7 @@ static int handle_commands(struct nl8021
  }
  TOPLEVEL(commands, NULL, NL80211_CMD_GET_WIPHY, 0, CIB_NONE, handle_commands,
         "list all known commands and their decimal & hex value");
  {
 --- a/scan.c
 +++ b/scan.c
-@@ -1306,6 +1306,9 @@ static void print_ht_op(const uint8_t ty
+@@ -1308,6 +1308,9 @@ static void print_ht_op(const uint8_t ty
        printf("\t\t * secondary channel offset: %s\n",
                ht_secondary_offset[data[1] & 0x3]);
        printf("\t\t * STA channel width: %s\n", sta_chan_width[(data[1] & 0x4)>>2]);
        printf("\t\t * RIFS: %d\n", (data[1] & 0x8)>>3);
        printf("\t\t * HT protection: %s\n", protection[data[2] & 0x3]);
        printf("\t\t * non-GF present: %d\n", (data[2] & 0x4) >> 2);
-@@ -1716,6 +1719,14 @@ static void print_ie(const struct ie_pri
+@@ -1818,30 +1821,31 @@ static void print_ie(const struct ie_pri
  static const struct ie_print ieprinters[] = {
-       [0] = { "SSID", print_ssid, 0, 32, BIT(PRINT_SCAN) | BIT(PRINT_LINK), },
+       [0] = { "SSID", print_ssid, 0, 32,
+                BIT(PRINT_SCAN) | BIT(PRINT_LINK) | BIT(PRINT_LINK_MLO_MLD), },
++      [11] = { "BSS Load", print_bss_load, 5, 5, BIT(PRINT_SCAN), },
 +      [45] = { "HT capabilities", print_ht_capa, 26, 26, BIT(PRINT_SCAN), },
 +      [48] = { "RSN", print_rsn, 2, 255, BIT(PRINT_SCAN), },
 +      [61] = { "HT operation", print_ht_op, 22, 22, BIT(PRINT_SCAN), },
        [1] = { "Supported rates", print_supprates, 0, 255, BIT(PRINT_SCAN), },
        [3] = { "DS Parameter set", print_ds, 1, 1, BIT(PRINT_SCAN), },
        [5] = { "TIM", print_tim, 4, 255, BIT(PRINT_SCAN), },
-@@ -1725,26 +1736,20 @@ static const struct ie_print ieprinters[
+       [6] = { "IBSS ATIM window", print_ibssatim, 2, 2, BIT(PRINT_SCAN), },
+       [7] = { "Country", print_country, 3, 255, BIT(PRINT_SCAN), },
+-      [11] = { "BSS Load", print_bss_load, 5, 5, BIT(PRINT_SCAN), },
        [32] = { "Power constraint", print_powerconstraint, 1, 1, BIT(PRINT_SCAN), },
        [35] = { "TPC report", print_tpcreport, 2, 2, BIT(PRINT_SCAN), },
        [42] = { "ERP", print_erp, 1, 255, BIT(PRINT_SCAN), },
        [127] = { "Extended capabilities", print_capabilities, 0, 255, BIT(PRINT_SCAN), },
        [107] = { "802.11u Interworking", print_interworking, 0, 255, BIT(PRINT_SCAN), },
        [108] = { "802.11u Advertisement", print_11u_advert, 0, 255, BIT(PRINT_SCAN), },
-       [111] = { "802.11u Roaming Consortium", print_11u_rcon, 2, 255, BIT(PRINT_SCAN), },
-       [195] = { "Transmit Power Envelope", print_tx_power_envelope, 2, 5, BIT(PRINT_SCAN), },
+@@ -1850,6 +1854,7 @@ static const struct ie_print ieprinters[
+       [214] = { "Short beacon interval", print_short_beacon_int, 2, 2, BIT(PRINT_SCAN), },
+       [217] = { "S1G capabilities", print_s1g_capa, 15, 15, BIT(PRINT_SCAN), },
+       [232] = { "S1G operation", print_s1g_oper, 6, 6, BIT(PRINT_SCAN), },
 +#endif
  };
  
  static void print_wifi_wpa(const uint8_t type, uint8_t len, const uint8_t *data,
-@@ -2080,8 +2085,10 @@ static void print_wifi_wps(const uint8_t
+@@ -2185,8 +2190,10 @@ static void print_wifi_wps(const uint8_t
  
  static const struct ie_print wifiprinters[] = {
        [1] = { "WPA", print_wifi_wpa, 2, 255, BIT(PRINT_SCAN), },
  };
  
  static inline void print_p2p(const uint8_t type, uint8_t len,
-@@ -2244,6 +2251,10 @@ static void print_vendor(unsigned char l
+@@ -2349,6 +2356,10 @@ static void print_vendor(unsigned char l
                return;
        }
  
        if (len >= 4 && memcmp(data, wfa_oui, 3) == 0) {
                if (data[3] < ARRAY_SIZE(wfa_printers) &&
                    wfa_printers[data[3]].name &&
-@@ -2377,6 +2388,7 @@ static void print_capa_non_dmg(__u16 cap
+@@ -2483,6 +2494,7 @@ static void print_capa_non_dmg(__u16 cap
                printf(" ESS");
        if (capa & WLAN_CAPABILITY_IBSS)
                printf(" IBSS");
        if (capa & WLAN_CAPABILITY_CF_POLLABLE)
                printf(" CfPollable");
        if (capa & WLAN_CAPABILITY_CF_POLL_REQUEST)
-@@ -2405,6 +2417,7 @@ static void print_capa_non_dmg(__u16 cap
+@@ -2511,6 +2523,7 @@ static void print_capa_non_dmg(__u16 cap
                printf(" DelayedBACK");
        if (capa & WLAN_CAPABILITY_IMM_BACK)
                printf(" ImmediateBACK");
  }
  
  static int print_bss_handler(struct nl_msg *msg, void *arg)
-@@ -2489,8 +2502,10 @@ static int print_bss_handler(struct nl_m
-       if (bss[NL80211_BSS_FREQUENCY]) {
-               int freq = nla_get_u32(bss[NL80211_BSS_FREQUENCY]);
-               printf("\tfreq: %d\n", freq);
+@@ -2601,8 +2614,10 @@ static int print_bss_handler(struct nl_m
+               else
+                       printf("\tfreq: %d\n", freq);
 +#ifdef IW_FULL
                if (freq > 45000)
                        is_dmg = true;
        }
        if (bss[NL80211_BSS_BEACON_INTERVAL])
                printf("\tbeacon interval: %d TUs\n",
-@@ -2684,6 +2699,7 @@ static int handle_stop_sched_scan(struct
+@@ -2796,6 +2811,7 @@ static int handle_stop_sched_scan(struct
        return 0;
  }
  
  COMMAND(scan, sched_start,
        SCHED_SCAN_OPTIONS,
        NL80211_CMD_START_SCHED_SCAN, 0, CIB_NETDEV, handle_start_sched_scan,
-@@ -2694,3 +2710,4 @@ COMMAND(scan, sched_start,
+@@ -2806,3 +2822,4 @@ COMMAND(scan, sched_start,
  COMMAND(scan, sched_stop, "",
        NL80211_CMD_STOP_SCHED_SCAN, 0, CIB_NETDEV, handle_stop_sched_scan,
        "Stop an ongoing scheduled scan.");
  
  int ieee80211_channel_to_frequency(int chan, enum nl80211_band band)
  {
-@@ -311,6 +313,9 @@ int parse_keys(struct nl_msg *msg, char
+@@ -313,6 +315,9 @@ int parse_keys(struct nl_msg *msg, char
        char keybuf[13];
        int pos = 0;
  
  
 --- a/Makefile
 +++ b/Makefile
-@@ -23,6 +23,12 @@ _OBJS := $(sort $(patsubst %.c,%.o,$(wil
+@@ -24,6 +24,12 @@ _OBJS := $(sort $(patsubst %.c,%.o,$(wil
  VERSION_OBJS := $(filter-out version.o, $(_OBJS))
  OBJS := $(VERSION_OBJS) version.o
  
  ifeq ($(NO_PKG_CONFIG),)
 --- a/station.c
 +++ b/station.c
-@@ -791,10 +791,12 @@ static int handle_station_set_plink(stru
+@@ -801,10 +801,12 @@ static int handle_station_set_plink(stru
   nla_put_failure:
        return -ENOBUFS;
  }
  
  static int handle_station_set_vlan(struct nl80211_state *state,
                                   struct nl_msg *msg,
-@@ -889,11 +891,13 @@ static int handle_station_set_mesh_power
+@@ -899,11 +901,13 @@ static int handle_station_set_mesh_power
  nla_put_failure:
        return -ENOBUFS;
  }
                                             struct nl_msg *msg,
 --- a/interface.c
 +++ b/interface.c
-@@ -629,9 +629,11 @@ static int handle_interface_wds_peer(str
+@@ -668,9 +668,11 @@ static int handle_interface_wds_peer(str
   nla_put_failure:
        return -ENOBUFS;
  }
  
  static int set_mcast_rate(struct nl80211_state *state,
                          struct nl_msg *msg,
-@@ -721,6 +723,7 @@ static int handle_chan(struct nl80211_st
+@@ -760,6 +762,7 @@ static int handle_chan(struct nl80211_st
        return handle_chanfreq(state, msg, true, argc, argv, id);
  }
  
  SECTION(switch);
  COMMAND(switch, freq,
        "<freq> [NOHT|HT20|HT40+|HT40-|5MHz|10MHz|80MHz] [beacons <count>] [block-tx]\n"
-@@ -992,3 +995,4 @@ COMMAND(set, tidconf, "[peer <MAC addres
+@@ -1031,3 +1034,4 @@ COMMAND(set, tidconf, "[peer <MAC addres
        "  $ iw dev wlan0 set tidconf peer xx:xx:xx:xx:xx:xx tids 0x2 bitrates auto\n"
        "  $ iw dev wlan0 set tidconf peer xx:xx:xx:xx:xx:xx tids 0x2 bitrates limit vht-mcs-5 4:9\n"
        );
 +#endif
 --- a/phy.c
 +++ b/phy.c
-@@ -369,6 +369,7 @@ err_out:
+@@ -403,6 +403,7 @@ err_out:
                free(cac_trigger_argv);
        return err;
  }
  TOPLEVEL(cac, "channel <channel> [NOHT|HT20|HT40+|HT40-|5MHz|10MHz|80MHz]\n"
              "freq <freq> [NOHT|HT20|HT40+|HT40-|5MHz|10MHz|80MHz]\n"
              "freq <control freq> [5|10|20|40|80|80+80|160] [<center1_freq> [<center2_freq>]]",
-@@ -380,6 +381,7 @@ COMMAND(cac, trigger,
-       NL80211_CMD_RADAR_DETECT, 0, CIB_NETDEV, handle_cac_trigger,
-       "Start or trigger a channel availability check (CAC) looking to look for\n"
+@@ -422,6 +423,7 @@ COMMAND(cac, background,
+       NL80211_CMD_RADAR_DETECT, 0, CIB_NETDEV, handle_cac_background,
+       "Start background channel availability check (CAC) looking to look for\n"
        "radars on the given channel.");
 +#endif