flow-tools: do not hardcode CFLAGS
authorFlorian Fainelli <florian@openwrt.org>
Sat, 8 Mar 2014 00:56:39 +0000 (00:56 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 8 Mar 2014 00:56:39 +0000 (00:56 +0000)
configure script hardcodes CFLAGS, fix that so we can get ours to be used.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 39801

net/flow-tools/Makefile
net/flow-tools/patches/090-configure_cflags_override.patch [new file with mode: 0644]

index 1874f5b86617bc0d0344f10fc89433146816f961..611b2b23ef42a993e924000d26ee9e897311a21d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=flow-tools
 PKG_VERSION:=0.68
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.eng.oar.net/pub/flow-tools/
diff --git a/net/flow-tools/patches/090-configure_cflags_override.patch b/net/flow-tools/patches/090-configure_cflags_override.patch
new file mode 100644 (file)
index 0000000..695d8b7
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/configure
++++ b/configure
+@@ -1662,7 +1662,7 @@ INSTALL_STRIP_PROGRAM="\${SHELL} \$(inst
+-CFLAGS="-g -Wall"
++CFLAGS="${CFLAGS} -g -Wall"
+ ac_ext=c
+ ac_cpp='$CPP $CPPFLAGS'