frickin: remove scan_interface calls, the values are never used
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 28 May 2012 23:30:12 +0000 (23:30 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 28 May 2012 23:30:12 +0000 (23:30 +0000)
SVN-Revision: 31959

net/frickin/Makefile
net/frickin/files/frickin.init

index c934cdf163c9731e26749993a967d0a6400c1bbf..b5220fd7f588b30dc7acc04877f0506c70a5c193 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=frickin
 PKG_VERSION:=1.3
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/frickin
index c002513cab0d011ad9b4ae90143966a305673fd1..7f96acf0b5f43ce92a85f3a10167f7eec9b3e086 100644 (file)
@@ -1,5 +1,5 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 
 START=50
 
@@ -48,15 +48,11 @@ stop_instance() {
 }
 
 start() {
-       include /lib/network
-       scan_interfaces
        config_load 'frickin'
        config_foreach start_instance 'frickin'
 }
 
 stop() {
-       include /lib/network
-       scan_interfaces
        config_load 'frickin'
        config_foreach stop_instance 'frickin'
 }