compat-wireless: build if kernel does not have mac80211
authorHauke Mehrtens <hauke@hauke-m.de>
Sat, 11 Sep 2010 16:18:29 +0000 (09:18 -0700)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Mon, 13 Sep 2010 18:25:04 +0000 (11:25 -0700)
In kernel 2.6.31 the attributes do_not_encrypt and requeue were removed
from struct sk_buff so we do not need mac80211 to be build while the
kernel was build for nwer kernels.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
config.mk

index 1498573c0b65f7cc4e14f3cd1d7d3581c8358df0..8b0038c5a4b2bd7f4fab681420a6ba4b6001a0c3 100644 (file)
--- a/config.mk
+++ b/config.mk
@@ -52,9 +52,11 @@ endif
 #
 # skb->requeue
 #
-ifeq ($(shell test $(KERNEL_SUBLEVEL) -ge 27 && echo yes),yes)
+# In kernel 2.6.32 both attributes were removed.
+#
+ifeq ($(shell test $(KERNEL_SUBLEVEL) -ge 27 -a $(KERNEL_SUBLEVEL) -le 31 && echo yes),yes)
 ifeq ($(CONFIG_MAC80211),)
-$(error "ERROR: Your >=2.6.27 kernel has CONFIG_MAC80211 disabled, you should have it CONFIG_MAC80211=m if you want to use this thing.")
+$(error "ERROR: Your >=2.6.27 and <= 2.6.31 kernel has CONFIG_MAC80211 disabled, you should have it CONFIG_MAC80211=m if you want to use this thing.")
 endif
 endif