projects
/
openwrt
/
staging
/
thess.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
37d2c06
)
fix openssl with zlib-dynamic (closes: #1182), bump release number
author
Nicolas Thill
<nico@openwrt.org>
Wed, 1 Aug 2007 12:32:53 +0000
(12:32 +0000)
committer
Nicolas Thill
<nico@openwrt.org>
Wed, 1 Aug 2007 12:32:53 +0000
(12:32 +0000)
SVN-Revision: 8299
package/zlib/Makefile
patch
|
blob
|
history
diff --git
a/package/zlib/Makefile
b/package/zlib/Makefile
index 066a3997890a969acb4df38381560b01fd315c0a..15407d5a3f8227d914f00b85aad061485862473f 100644
(file)
--- a/
package/zlib/Makefile
+++ b/
package/zlib/Makefile
@@
-10,7
+10,7
@@
include $(TOPDIR)/rules.mk
PKG_NAME:=zlib
PKG_VERSION:=1.2.3
-PKG_RELEASE:=
3
+PKG_RELEASE:=
4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.zlib.net @SF/zlib
@@
-62,8
+62,10
@@
define Build/UninstallDev
$(STAGING_DIR)/usr/lib/libz.{a,so*}
endef
+# libz.so is needed for openssl (zlib-dynamic)
define Package/zlib/install
$(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libz.so $(1)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libz.so.* $(1)/usr/lib/
endef