packages: vsc73x5-ucode: re-enable AP83-specific microcode install
authorZoltan HERPAI <wigyori@uid0.hu>
Tue, 5 May 2020 15:08:28 +0000 (17:08 +0200)
committerZoltan HERPAI <wigyori@uid0.hu>
Thu, 7 May 2020 10:24:38 +0000 (12:24 +0200)
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
package/firmware/vsc73x5-ucode/Makefile

index 4eb9e40c1552b5dabd64a01403fa53e2318ef7ec..30abd6aad2c3299bbe1aab33cc36d1f053b4f877 100644 (file)
@@ -34,6 +34,32 @@ define Package/vsc73x5/install
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/$(2) $(1)/lib/firmware/$(3)
 endef
 
+define Package/vsc7385-ucode-ap83
+  $(call Package/vsc73x5-defaults,Vitesse VSC7385 microcode for the Atheros AP83 boards)
+endef
+
+define Package/vsc7385-ucode-ap83/description
+  This package contains the Atheros AP83 board specific microcode for
+  the Vitesse VSC7385 ethernet switch.
+endef
+
+define Package/vsc7385-ucode-ap83/install
+  $(call Package/vsc73x5/install,$(1),g5_Plus1_2_31_unmanaged_Atheros_v3.bin,vsc7385_ucode_ap83.bin)
+endef
+
+define Package/vsc7395-ucode-ap83
+  $(call Package/vsc73x5-defaults, Vitesse VSC7395 microcode for the Atheros AP83 boards)
+endef
+
+define Package/vsc7395-ucode-ap83/description
+  This package contains the Atheros AP83 board specific microcode for
+  the Vitesse VSC7395 ethernet switch.
+endef
+
+define Package/vsc7395-ucode-ap83/install
+  $(call Package/vsc73x5/install,$(1),g5_Plus1_2_31_unmanaged_Atheros_v4.bin,vsc7395_ucode_ap83.bin)
+endef
+
 define Package/vsc7385-ucode-pb44
   $(call Package/vsc73x5-defaults, Vitesse VSC7395 microcode for the Atheros PB44 boards)
 endef
@@ -52,7 +78,7 @@ define Package/vsc7395-ucode-pb44
 endef
 
 define Package/vsc7395-ucode-pb44/description
-  This package contains the Atheros PB44 board specific microcode for
+  This package contains the Atheros AP83 board specific microcode for
   the Vitesse VSC7395 ethernet switch.
 endef
 
@@ -64,5 +90,7 @@ define Build/Compile
 
 endef
 
+$(eval $(call BuildPackage,vsc7385-ucode-ap83))
+$(eval $(call BuildPackage,vsc7395-ucode-ap83))
 $(eval $(call BuildPackage,vsc7385-ucode-pb44))
 $(eval $(call BuildPackage,vsc7395-ucode-pb44))