projects
/
openwrt
/
staging
/
kaloz.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
102522e
)
hostapd: enable 802.11w only for the full variants
author
Felix Fietkau
<nbd@openwrt.org>
Wed, 6 May 2015 00:59:36 +0000
(
00:59
+0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Wed, 6 May 2015 00:59:36 +0000
(
00:59
+0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 45616
package/network/services/hostapd/Makefile
patch
|
blob
|
history
diff --git
a/package/network/services/hostapd/Makefile
b/package/network/services/hostapd/Makefile
index b8acee0632d3dcd10256bc7cecbf73026540d4e8..3dff7b4852f8e428ebe3b0accf1107872677af11 100644
(file)
--- a/
package/network/services/hostapd/Makefile
+++ b/
package/network/services/hostapd/Makefile
@@
-68,9
+68,12
@@
DRIVER_MAKEOPTS= \
CONFIG_DRIVER_NL80211=$(CONFIG_PACKAGE_kmod-cfg80211) \
CONFIG_DRIVER_HOSTAP=$(CONFIG_PACKAGE_kmod-hostap) \
CONFIG_IEEE80211N=$(HOSTAPD_IEEE80211N) \
- CONFIG_IEEE80211W=$(CONFIG_PACKAGE_kmod-ath9k) \
CONFIG_DRIVER_WEXT=$(CONFIG_DRIVER_WEXT_SUPPORT) \
+ifeq ($(LOCAL_VARIANT),full)
+ CONFIG_IEEE80211W=$(CONFIG_PACKAGE_kmod-ath9k)
+endif
+
ifneq ($(LOCAL_TYPE),hostapd)
ifdef CONFIG_WPA_SUPPLICANT_OPENSSL
ifeq ($(LOCAL_VARIANT),full)