bluez-utils: Fix ability to automatically ifup the transitory ppp connection for...
authorRod Whitby <rod@whitby.id.au>
Sat, 13 Dec 2008 13:25:31 +0000 (13:25 +0000)
committerRod Whitby <rod@whitby.id.au>
Sat, 13 Dec 2008 13:25:31 +0000 (13:25 +0000)
SVN-Revision: 13620

utils/bluez-utils/Makefile
utils/bluez-utils/files/bluetooth.conf
utils/bluez-utils/files/bluez-utils.init

index 3c002dcb901dc772755e47d59dd2916ff2ea0662..f2d999cf90619b2c4d4942832437a7af03360316 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bluez-utils
 PKG_VERSION:=3.36
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://bluez.sourceforge.net/download
index 54dcec008650dfc3caa798ebe92d1fa1dcbf83bb..dad576e9d49f4ab2a2feae0c9e115b8387a4e2ee 100644 (file)
@@ -10,7 +10,9 @@ config dund
        option listen   true
        option persist  true
        option msdun    true
-#      option pppdopts "ktune proxyarp 192.168.1.1:192.168.1.2 ms-dns 192.168.1.1"
+       option interface dund
+       option unit     1
+       option pppdopts "ktune proxyarp 192.168.1.1:192.168.1.2 ms-dns 192.168.1.1"
        option enabled  0
 
 config pand
index afd2294e7ac09cca8b1c08ce35d763b76057a83f..13dadeee97d65263ff2f8dbf049d7db9851eb1cc 100644 (file)
@@ -63,7 +63,7 @@ dund_config() {
        append_string "$cfg" pppdopts ""
        config_get ifn "$cfg" interface
        if [ -n "$ifn" ]; then
-               config_get unit "$ifn" unit
+               config_get unit "$cfg" unit
                [ -z "$unit" ] || append args "unit $unit ipparam $ifn linkname $ifn"
        fi