config: rename SECCOMP to USE_SECCOMP
authorRobert Marko <robimarko@gmail.com>
Sat, 23 Nov 2024 13:29:49 +0000 (14:29 +0100)
committerRobert Marko <robimarko@gmail.com>
Sun, 24 Nov 2024 11:18:21 +0000 (12:18 +0100)
It seems that we have some kind of a symbol name conflict which causes
CONFIG_SECCOMP to always be read as y.

Unfortunatelly, I could not figure out what is causing this, but simply
renaming SECCOMP to USE_SECCOMP seems to properly work and leaves the
symbol unset unless arch dependencies are satisfied.

This fixes qoriq and others that dont support seccomp from failing due
to procd-seccomp package being selected to get included but it cannot be
built for them:
ERROR: unable to select packages:
  procd-seccomp (no such package):
    required by: base-files-1637~52b6c92479[procd-seccomp]

Fixes: 4c65359af49b ("build: fix including busybox, procd and apk/opkg in imagebuilder")
Link: https://github.com/openwrt/openwrt/pull/17048
Signed-off-by: Robert Marko <robimarko@gmail.com>
config/Config-build.in
include/toplevel.mk
package/base-files/Makefile
package/system/procd/Makefile

index 6db2354e88c54fc04a759b4a64d3257c0e0f33bb..2a95891ecf554273c5086dab20683fa03f94534d 100644 (file)
@@ -423,7 +423,7 @@ menu "Global build settings"
 
        endchoice
 
-       config SECCOMP
+       config USE_SECCOMP
                bool "Enable SECCOMP"
                select KERNEL_SECCOMP
                select PACKAGE_procd-seccomp
index e5f5e0fecd8de4266cc7e1e88a44082f68df49c2..a52c56832eca034afed39a68f811542b82074f41 100644 (file)
@@ -78,7 +78,7 @@ _ignore = $(foreach p,$(IGNORE_PACKAGES),--ignore $(p))
 # Config that will invalidate the .targetinfo as they will affect
 # DEFAULT_PACKAGES.
 # Keep DYNAMIC_DEF_PKG_CONF in sync with target.mk to reflect the same configs
-DYNAMIC_DEF_PKG_CONF := CONFIG_USE_APK CONFIG_SELINUX CONFIG_SMALL_FLASH CONFIG_SECCOMP
+DYNAMIC_DEF_PKG_CONF := CONFIG_USE_APK CONFIG_SELINUX CONFIG_SMALL_FLASH CONFIG_USE_SECCOMP
 check-dynamic-def-pkg: FORCE
        @+DEF_PKG_CONFS=""; \
        if [ -f $(TOPDIR)/.config ]; then \
index a2ea3c5d00847e00ce675cb40109e009dcfbe0c0..ff7891f18cb0c714df5b443f3200b44a8f34f97a 100644 (file)
@@ -42,7 +42,7 @@ define Package/base-files
   DEPENDS:= \
        +netifd +libc +jsonfilter +SIGNED_PACKAGES:usign +SIGNED_PACKAGES:openwrt-keyring \
        +NAND_SUPPORT:ubi-utils +fstools +fwtool \
-       +SELINUX:procd-selinux +!SELINUX:procd +SECCOMP:procd-seccomp \
+       +SELINUX:procd-selinux +!SELINUX:procd +USE_SECCOMP:procd-seccomp \
        +SELINUX:busybox-selinux +!SELINUX:busybox +!SMALL_FLASH:procd-ujail
   TITLE:=Base filesystem for OpenWrt
   URL:=http://openwrt.org/
index 81e133f55bc48222ad9f067cec62730fc0054e1a..b9099a5ba52433d48db45f8a010753e8f45aa593 100644 (file)
@@ -71,7 +71,7 @@ endef
 define Package/procd-seccomp
   SECTION:=base
   CATEGORY:=Base system
-  DEPENDS:=@SECCOMP +libubox +libblobmsg-json
+  DEPENDS:=@USE_SECCOMP +libubox +libblobmsg-json
   TITLE:=OpenWrt process seccomp helper + utrace
 endef