ifeq ($(LINUX_VERSION),2.6.28.10)
LINUX_KERNEL_MD5SUM:=c4efb2c494d749cb5de274f8ae41c3fa
endif
-ifeq ($(LINUX_VERSION),2.6.30.9)
- LINUX_KERNEL_MD5SUM:=5a4cd5543a9d7c1a819700b21be31ef1
+ifeq ($(LINUX_VERSION),2.6.30.10)
+ LINUX_KERNEL_MD5SUM:=eb6be465f914275967a5602cb33662f5
endif
ifeq ($(LINUX_VERSION),2.6.31.6)
LINUX_KERNEL_MD5SUM:=485472df88af84becdcf47f45de3ba46
BOARD:=adm5120
BOARDNAME:=Infineon/ADMtek ADM5120
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
SUBTARGETS:=router_le router_be
INITRAMFS_EXTRA_FILES:=
BOARD:=amazon
BOARDNAME:=Infineon Amazon
FEATURES:=squashfs jffs2 broken
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
include $(INCLUDE_DIR)/target.mk
BOARDNAME:=TI AR7
FEATURES:=squashfs jffs2 atm
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
include $(INCLUDE_DIR)/target.mk
FEATURES:=squashfs jffs2 tgz
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
include $(INCLUDE_DIR)/target.mk
BOARDNAME:=Atheros AR231x/AR5312
FEATURES:=squashfs jffs2
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
include $(INCLUDE_DIR)/target.mk
FEATURES:=jffs2 usb pci
SUBTARGETS=au1500 au1550
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += hostapd-mini yamonenv
BOARD:=avr32
BOARDNAME:=Atmel AVR32
FEATURES:=squashfs
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
include $(INCLUDE_DIR)/target.mk
BOARDNAME:=Broadcom BCM947xx/953xx
FEATURES:=squashfs usb
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += hostapd-mini kmod-switch kmod-diag nvram
BOARD:=brcm63xx
BOARDNAME:=Broadcom BCM63xx
FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
include $(INCLUDE_DIR)/target.mk
FEATURES:=tgz pci ext2
CFLAGS:=-O2 -pipe -mtune=r5000 -funit-at-a-time
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
include $(INCLUDE_DIR)/target.mk
-diff -urN linux-2.6.30.7/arch/mips/Makefile linux-2.6.30.7.new/arch/mips/Makefile
---- linux-2.6.30.7/arch/mips/Makefile 2009-09-27 13:17:16.000000000 +0200
-+++ linux-2.6.30.7.new/arch/mips/Makefile 2009-09-15 19:46:05.000000000 +0200
-@@ -83,7 +83,7 @@
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -83,7 +83,7 @@ all-$(CONFIG_BOOT_ELF64) := $(vmlinux-64
cflags-y += -G 0 -mno-abicalls -fno-pic -pipe
cflags-y += -msoft-float
LDFLAGS_vmlinux += -G 0 -static -n -nostdlib
cflags-y += -ffreestanding
-diff -urN linux-2.6.30.7/arch/mips/include/asm/module.h linux-2.6.30.7.new/arch/mips/include/asm/module.h
---- linux-2.6.30.7/arch/mips/include/asm/module.h 2009-09-27 13:17:16.000000000 +0200
-+++ linux-2.6.30.7.new/arch/mips/include/asm/module.h 2009-09-15 19:46:05.000000000 +0200
-@@ -9,11 +9,6 @@
+--- a/arch/mips/include/asm/module.h
++++ b/arch/mips/include/asm/module.h
+@@ -9,11 +9,6 @@ struct mod_arch_specific {
struct list_head dbe_list;
const struct exception_table_entry *dbe_start;
const struct exception_table_entry *dbe_end;
};
typedef uint8_t Elf64_Byte; /* Type for a 8-bit quantity. */
-diff -urN linux-2.6.30.7/arch/mips/kernel/module.c linux-2.6.30.7.new/arch/mips/kernel/module.c
---- linux-2.6.30.7/arch/mips/kernel/module.c 2009-09-27 13:17:16.000000000 +0200
-+++ linux-2.6.30.7.new/arch/mips/kernel/module.c 2009-09-15 19:46:05.000000000 +0200
-@@ -43,116 +43,6 @@
+--- a/arch/mips/kernel/module.c
++++ b/arch/mips/kernel/module.c
+@@ -43,116 +43,6 @@ static struct mips_hi16 *mips_hi16_list;
static LIST_HEAD(dbe_list);
static DEFINE_SPINLOCK(dbe_lock);
void *module_alloc(unsigned long size)
{
#ifdef MODULE_START
-@@ -168,45 +58,16 @@
+@@ -168,45 +58,16 @@ void *module_alloc(unsigned long size)
return __vmalloc_area(area, GFP_KERNEL, PAGE_KERNEL);
#else
/* FIXME: If module_region == mod->init_region, trim exception
table entries. */
}
-@@ -214,24 +75,6 @@
+@@ -214,24 +75,6 @@ void module_free(struct module *mod, voi
int module_frob_arch_sections(Elf_Ehdr *hdr, Elf_Shdr *sechdrs,
char *secstrings, struct module *mod)
{
return 0;
}
-@@ -254,41 +97,27 @@
+@@ -254,41 +97,27 @@ static int apply_r_mips_32_rela(struct m
return 0;
}
{
if (v % 4) {
printk(KERN_ERR "module %s: dangerous relocation\n", me->name);
-@@ -296,31 +125,17 @@
+@@ -296,31 +125,17 @@ static int set_r_mips_26(struct module *
}
if ((v & 0xf0000000) != (((unsigned long)location + 4) & 0xf0000000)) {
static int apply_r_mips_hi16_rel(struct module *me, u32 *location, Elf_Addr v)
{
struct mips_hi16 *n;
-@@ -585,23 +400,11 @@
+@@ -585,23 +400,11 @@ int module_finalize(const Elf_Ehdr *hdr,
list_add(&me->arch.dbe_list, &dbe_list);
spin_unlock_irq(&dbe_lock);
}
FEATURES:=squashfs jffs2 ext2 tgz usb
CFLAGS:=-Os -pipe -march=armv4t -funit-at-a-time
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
include $(INCLUDE_DIR)/target.mk
BOARD:=etrax
BOARDNAME:=Foxboard (ETRAX 100LX)
FEATURES:=squashfs jffs2
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
DEVICE_TYPE=
include $(INCLUDE_DIR)/target.mk
FEATURES:=squashfs
CFLAGS:=-Os -pipe -march=armv4 -mtune=arm9tdmi -funit-at-a-time
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
include $(INCLUDE_DIR)/target.mk
arch/arm/mm/proc-syms.c | 1 +
1 files changed, 1 insertions(+), 0 deletions(-)
-diff --git a/arch/arm/mm/proc-syms.c b/arch/arm/mm/proc-syms.c
-index 195e48e..ac5c800 100644
--- a/arch/arm/mm/proc-syms.c
+++ b/arch/arm/mm/proc-syms.c
@@ -27,6 +27,7 @@ EXPORT_SYMBOL(__cpuc_flush_kern_all);
EXPORT_SYMBOL(dmac_inv_range); /* because of flush_ioremap_region() */
#else
EXPORT_SYMBOL(cpu_cache);
---
-1.6.5.1
-
FEATURES:=
CFLAGS:=-O2 -pipe -march=armv5te -mtune=xscale -funit-at-a-time
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
DEVICE_TYPE=phone
BOARDNAME:=Infineon Mips
FEATURES:=squashfs jffs2 atm
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
BOARDNAME:=Intel IOP32x
FEATURES:=squashfs jffs2
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
include $(INCLUDE_DIR)/target.mk
BOARDNAME:=Marvell Kirkwood
FEATURES:=tgz usb
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
include $(INCLUDE_DIR)/target.mk
BOARDNAME:=Freescale MPC52xx
FEATURES:=tgz ext2
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
LINUX_KARCH:=powerpc
include $(INCLUDE_DIR)/target.mk
BOARDNAME:=Freescale MPC83xx
FEATURES:=tgz broken
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
LINUX_KARCH:=powerpc
include $(INCLUDE_DIR)/target.mk
FEATURES:=squashfs jffs2 pci usb
CFLAGS:=-Os -pipe -mtune=octeon -funit-at-a-time
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
include $(INCLUDE_DIR)/target.mk
BOARDNAME:=OLPC XO-1
FEATURES:=squashfs ext2
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci kmod-libertas
FEATURES:=squashfs
SUBTARGETS=generic harddisk
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
include $(INCLUDE_DIR)/target.mk
FEATURES:=squashfs
CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=405
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
LINUX_KARCH:=powerpc
include $(INCLUDE_DIR)/target.mk
FEATURES:=squashfs
CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=440
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
LINUX_KARCH:=powerpc
include $(INCLUDE_DIR)/target.mk
SUBTARGETS=petitboot
FEATURES+=powerpc64
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
KERNEL_CC:=
BOARDNAME:=PowerXCell Accelerator Board
FEATURES+=powerpc64 fpu ramdisk
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
KERNEL_CC:=
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
FEATURES:=squashfs broken
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES+=kmod-leds-gpio
BOARDNAME:=Mikrotik RouterBoard 532
FEATURES:=jffs2 pci tgz
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += hostapd-mini kmod-madwifi kmod-input-rb532
CFLAGS:=-Os -pipe -march=i486 -funit-at-a-time
SUBTARGETS:=amit ar525w r8610 dir-450 sitecom
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
include $(INCLUDE_DIR)/target.mk
FEATURES:=jffs2
CFLAGS:=-O2 -pipe -march=armv4t -mtune=arm920t -funit-at-a-time
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
DEVICE_TYPE=phone
FEATURES:=fpu
CFLAGS:=-Os -pipe -march=sb1 -funit-at-a-time
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
include $(INCLUDE_DIR)/target.mk
FEATURES:=ext2
LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
include $(INCLUDE_DIR)/target.mk