projects
/
openwrt
/
staging
/
lynxis.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
b20a2b4
)
image.mk: add Build step combined-image
author
Felix Fietkau
<nbd@openwrt.org>
Mon, 15 Jun 2015 07:45:27 +0000
(07:45 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Mon, 15 Jun 2015 07:45:27 +0000
(07:45 +0000)
Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
SVN-Revision: 45979
include/image.mk
patch
|
blob
|
history
diff --git
a/include/image.mk
b/include/image.mk
index 020418d54d42945bd69b7c398b799a81f82c56a0..287c679cfd12d8cfdae0ddb46cfcdea6f7577f5b 100644
(file)
--- a/
include/image.mk
+++ b/
include/image.mk
@@
-326,6
+326,13
@@
define Build/check-size
}
endef
+define Build/combined-image
+ -sh $(TOPDIR)/scripts/combined-image.sh \
+ "$(word 1,$^)" \
+ "$@" \
+ "$@.new"
+ @mv $@.new $@
+endef
define Device/Init
PROFILES := $(PROFILE)