projects
/
openwrt
/
staging
/
wigyori.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
02c5019
)
toolchain: glibc: Define minimum support kernel version as 4.14
author
Hauke Mehrtens
<hauke@hauke-m.de>
Sat, 18 Apr 2020 18:00:35 +0000
(20:00 +0200)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Sat, 18 Apr 2020 19:06:45 +0000
(21:06 +0200)
This will compile glibc in a way that it will only support kernel 4.14
and later. Compatibility code for older kernel versions will be removed.
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
toolchain/glibc/common.mk
patch
|
blob
|
history
diff --git
a/toolchain/glibc/common.mk
b/toolchain/glibc/common.mk
index 99be398d3f9ab837cc6c73b7fbdce13c236ca434..060fb2849e7cbfc2c2417ba84616ddd6560fd666 100644
(file)
--- a/
toolchain/glibc/common.mk
+++ b/
toolchain/glibc/common.mk
@@
-60,7
+60,8
@@
GLIBC_CONFIGURE:= \
--without-gd \
--without-cvs \
--enable-add-ons \
- --$(if $(CONFIG_SOFT_FLOAT),without,with)-fp
+ --$(if $(CONFIG_SOFT_FLOAT),without,with)-fp \
+ --enable-kernel=4.14.0
export libc_cv_ssp=no
export libc_cv_ssp_strong=no