projects
/
openwrt
/
staging
/
stintel.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
175aad6
)
netfilter: unbreak kmod-ipt-nat for <3.7
author
Steven Barth
<cyrus@openwrt.org>
Mon, 29 Sep 2014 05:24:32 +0000
(
05:24
+0000)
committer
Steven Barth
<cyrus@openwrt.org>
Mon, 29 Sep 2014 05:24:32 +0000
(
05:24
+0000)
SVN-Revision: 42696
include/netfilter.mk
patch
|
blob
|
history
diff --git
a/include/netfilter.mk
b/include/netfilter.mk
index 927e8a8e49218c23cc4b6f45dfc23ac26c57741a..fd119c5f8581d851e066cd612d9571261b810ce0 100644
(file)
--- a/
include/netfilter.mk
+++ b/
include/netfilter.mk
@@
-164,6
+164,7
@@
$(eval $(call nf_add,IPT_IPV6_EXTRA,CONFIG_IP6_NF_MATCH_RT, $(P_V6)ip6t_rt))
# nat
# kernel only
+$(eval $(if $(NF_KMOD),$(call nf_add,NF_NAT,CONFIG_NF_NAT, $(P_V4)nf_nat, lt 3.7.0),))
$(eval $(if $(NF_KMOD),$(call nf_add,NF_NAT,CONFIG_NF_NAT, $(P_XT)nf_nat, ge 3.7.0),))
$(eval $(if $(NF_KMOD),$(call nf_add,NF_NAT,CONFIG_NF_NAT_IPV4, $(P_V4)nf_nat_ipv4, ge 3.7.0),))
$(eval $(if $(NF_KMOD),$(call nf_add,NF_NAT6,CONFIG_NF_NAT_IPV6, $(P_V6)nf_nat_ipv6, ge 3.7.0),))