compat-wireless: use PWD for file definition
authorLuis R. Rodriguez <mcgrof@frijolero.org>
Fri, 9 Mar 2012 01:25:37 +0000 (17:25 -0800)
committerLuis R. Rodriguez <mcgrof@frijolero.org>
Fri, 9 Mar 2012 02:10:28 +0000 (18:10 -0800)
Instead of using PWD in random places just use it
to defint he direct file once. This will allow us
to later move variables that use PWD to another
place.

Signed-off-by: Luis R. Rodriguez <mcgrof@frijolero.org>
Makefile

index 1fedf97ac431316a4e12265fb991edb42f885a08..e0947986be4fb1df4193ddd3a90de6f2a142cb69 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -59,19 +59,19 @@ CFLAGS += \
 
 # These exported as they are used by the scripts
 # to check config and compat autoconf
-export COMPAT_CONFIG_CW=config.mk
-export COMPAT_CONFIG=.config
-export CONFIG_CHECK=.$(COMPAT_CONFIG_CW)_md5sum.txt
+export COMPAT_CONFIG_CW=$(PWD)/config.mk
+export COMPAT_CONFIG=$(PWD)/.config
+export CONFIG_CHECK=$(PWD)/.config.mk_md5sum.txt
 export COMPAT_AUTOCONF=include/linux/compat_autoconf.h
 export CREL=$(shell cat $(PWD)/compat_version)
 export CREL_PRE:=.compat_autoconf_
-export CREL_CHECK:=$(CREL_PRE)$(CREL)
+export CREL_CHECK:=$(PWD)/$(CREL_PRE)$(CREL)
 
-include $(PWD)/$(COMPAT_CONFIG_CW)
+include $(COMPAT_CONFIG_CW)
 
 # Recursion lets us ensure we get this file included.
 # Trick is to run make -C $(PWD) modules later.
--include $(PWD)/$(COMPAT_CONFIG)
+-include $(COMPAT_CONFIG)
 
 all: $(CREL_CHECK)
 
@@ -92,7 +92,7 @@ bt: $(CREL_CHECK)
 # $(COMPAT_CONFIG) file
 $(CREL_CHECK):
        @# Force to regenerate compat autoconf
-       @./compat/scripts/gen-compat-config.sh > $(PWD)/$(COMPAT_CONFIG)
+       @./compat/scripts/gen-compat-config.sh > $(COMPAT_CONFIG)
        @rm -f $(CONFIG_CHECK)
        @./scripts/check_config.sh
        @touch $@