update haserl to 0.9.24
authorTravis Kemen <thepeople@openwrt.org>
Wed, 16 Jul 2008 23:05:47 +0000 (23:05 +0000)
committerTravis Kemen <thepeople@openwrt.org>
Wed, 16 Jul 2008 23:05:47 +0000 (23:05 +0000)
SVN-Revision: 11849

utils/haserl/Makefile
utils/haserl/patches/100-cookie_prefix.patch [deleted file]
utils/haserl/patches/101-ignore_content_disposition.patch [deleted file]

index 35eff9ff08f147f4de448e596e6f6b6b8f592a5d..d5add3b91e0c0de5d0d7c654d333f2e536756b47 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=haserl
-PKG_VERSION:=0.8.0
-PKG_RELEASE:=2
+PKG_VERSION:=0.9.24
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/haserl
-PKG_MD5SUM:=bd9195d086566f56634c0bcbbbcbebea
+PKG_MD5SUM:=f0cdb34f5ea50482fb6b7961bb158332
 
 include $(INCLUDE_DIR)/package.mk
 
diff --git a/utils/haserl/patches/100-cookie_prefix.patch b/utils/haserl/patches/100-cookie_prefix.patch
deleted file mode 100644 (file)
index ba91fe6..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-Index: haserl-0.8.0/src/haserl.c
-===================================================================
---- haserl-0.8.0.orig/src/haserl.c     2007-06-04 13:22:30.973146648 +0200
-+++ haserl-0.8.0/src/haserl.c  2007-06-04 13:22:31.039136616 +0200
-@@ -74,6 +74,7 @@
- token_t       /*@null@*/ *token_list = NULL;
- char  global_variable_prefix[] = HASERL_VAR_PREFIX;
-+char  cookie_variable_prefix[] = "COOKIE_";
- int   global_subshell_pipe[4];
- int   global_subshell_pid;
- int   global_subshell_died = 0;
-@@ -221,7 +222,7 @@
-       while (token) {
-               // skip leading spaces 
-               while ( token[0] == ' ' ) { token++; }
--              myputenv(token, global_variable_prefix);
-+              myputenv(token, cookie_variable_prefix);
-               token=strtok(NULL, ";");
-               }
-       free (qs);
diff --git a/utils/haserl/patches/101-ignore_content_disposition.patch b/utils/haserl/patches/101-ignore_content_disposition.patch
deleted file mode 100644 (file)
index 46ac9a4..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-Index: haserl-0.8.0/src/haserl.c
-===================================================================
---- haserl-0.8.0.orig/src/haserl.c     2007-06-04 13:22:30.973146648 +0200
-+++ haserl-0.8.0/src/haserl.c  2007-06-04 13:22:31.039136616 +0200
-@@ -479,9 +479,12 @@
-               line=LineToStr(&qs[offset], cl-offset);
-               if (strncasecmp(&qs[offset], "Content-Disposition", 19) != 0) {
-                       /* hmm... content disposition was not where we expected it */
-+                      /* Be kind to Opera 9.10 and just ignore this block     */
-+                              /*
-                       PrintParseError ("Content-Disposition Missing", 0);
-                       free(ct);
--                      return(-1);
-+                              */
-+                      continue;
-                       }
-               /* Found it, so let's go find "name="                           */
-               if (!(envname=strstr(&qs[offset], "name="))) {