projects
/
openwrt
/
staging
/
jogo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
53332ba
)
lua: Remove -fPIC for non-powerpc platforms
author
Steven Barth
<cyrus@openwrt.org>
Tue, 29 Jul 2008 10:14:11 +0000
(10:14 +0000)
committer
Steven Barth
<cyrus@openwrt.org>
Tue, 29 Jul 2008 10:14:11 +0000
(10:14 +0000)
SVN-Revision: 11985
package/lua/Makefile
patch
|
blob
|
history
diff --git
a/package/lua/Makefile
b/package/lua/Makefile
index c7706376dd159173ce51fc1505d750e00a659462..96dda822ce991da55af6d38154f0022fc462a47a 100644
(file)
--- a/
package/lua/Makefile
+++ b/
package/lua/Makefile
@@
-24,6
+24,11
@@
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk
+ifeq ($(ARCH),powerpc)
+ FPIC:=-fPIC
+endif
+
+
define Package/lua/Default
SUBMENU:=LUA
SECTION:=lang
@@
-96,7
+101,7
@@
define Build/Compile
AR="$(TARGET_CROSS)ar rcu" \
RANLIB="$(TARGET_CROSS)ranlib" \
INSTALL_ROOT=/usr \
- CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)
-fPIC
" \
+ CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)
$(FPIC)
" \
MYLDFLAGS="$(TARGET_LDFLAGS)" \
PKG_VERSION=$(PKG_VERSION) \
all linux