some minor cleanups...
authorMirko Vogt <mirko@openwrt.org>
Fri, 6 Mar 2009 20:43:49 +0000 (20:43 +0000)
committerMirko Vogt <mirko@openwrt.org>
Fri, 6 Mar 2009 20:43:49 +0000 (20:43 +0000)
SVN-Revision: 14761

phone/gsm0710muxd/Makefile

index b9af1d4e533da22287fddbc79e7930fe5e5e0b62..5707c62052f7f97800dd252a3b1d7fd7b89fb699 100644 (file)
@@ -24,20 +24,18 @@ EXTRA_CFLAGS+=-I$(STAGING_DIR)/usr/lib/libintl/include -I$(STAGING_DIR)/usr/lib/
 EXTRA_LDFLAGS+=-lintl -L$(STAGING_DIR)/usr/lib/libintl/lib -liconv -L$(STAGING_DIR)/usr/lib/libiconv/lib
 
 define Package/gsm0710muxd
-  SECTION:=phone
-  CATEGORY:=Phone
-  TITLE:=GSM multiplexing daemon
-  DEPENDS:=python-core +dbus-python +python-gobject +pyserial +pyyaml +gst-python
-  URL:=http://www.freesmartphone.org
+       SECTION:=phone
+       CATEGORY:=Phone
+       TITLE:=GSM multiplexing daemon
+       URL:=http://www.freesmartphone.org
+       DEPENDS:=+glib2 +dbus +libdbus-glib
 endef
 
 define Package/gsm0710muxd/description
-  gsm0710muxd is a user space multiplexer for GSM according to the GSM 07.10 specification.
+       gsm0710muxd is a user space multiplexer for GSM according to the GSM 07.10 specification.
 endef
 
 define Build/Configure
-       mkdir -p $(STAGING_DIR_HOST)/usr/bin
-       ln -sf `which dbus-binding-tool` $(STAGING_DIR_HOST)/usr/bin/
        (cd $(PKG_BUILD_DIR) && \
                $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/ && \
                $(CONFIGURE_VARS) \