packages: ntfsprogs_ntfs-3g: add missing dependency - libuuid
authorJonas Gorski <jogo@openwrt.org>
Sun, 4 Aug 2013 12:03:14 +0000 (12:03 +0000)
committerJonas Gorski <jogo@openwrt.org>
Sun, 4 Aug 2013 12:03:14 +0000 (12:03 +0000)
This patch adds missing libuuid dependency for ntfsprogs_ntfs-3g.
Without it the package fails to install because of missing
dependency to libuuid.

Signed-off-by: Jiri Slachta <slachta@cesnet.cz>
[jogo@openwrt.org: also enable libuuid explicitly in configure]
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 37676

utils/ntfs-3g/Makefile

index 465034439221b95a5335c7c670e38a30ac768c26..30e763319f3f40dfd5cdc27e2bba66d1abb333d8 100644 (file)
@@ -126,12 +126,13 @@ endef
 define Package/ntfsprogs_ntfs-3g
   $(call Package/ntfs-3g/common)
   TITLE:=ntfsprogs (ntfs-3g)
-  DEPENDS+= +ntfs-3g +libgcrypt
+  DEPENDS+= +ntfs-3g +libgcrypt +libuuid
 endef
 
 CONFIGURE_ARGS += \
        --enable-shared \
-       --enable-static
+       --enable-static \
+       --with-uuid
 
 # configure/make according selection
 ifdef CONFIG_PACKAGE_NTFS-3G_USE_LIBFUSE