kernel: bump 4.9 to 4.9.156
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 13 Feb 2019 10:28:09 +0000 (11:28 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 15 Feb 2019 09:53:16 +0000 (10:53 +0100)
Refreshed all patches.

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/brcm2708/patches-4.9/950-0019-dmaengine-bcm2835-Load-driver-early-and-support-lega.patch
target/linux/brcm2708/patches-4.9/950-0031-Add-dwc_otg-driver.patch
target/linux/brcm2708/patches-4.9/950-0056-fbdev-add-FBIOCOPYAREA-ioctl.patch
target/linux/generic/hack-4.9/204-module_strip.patch
target/linux/ixp4xx/patches-4.9/160-delayed_uart_io.patch
target/linux/layerscape/patches-4.9/810-iommu-support-layerscape.patch
target/linux/layerscape/patches-4.9/816-tty-serial-support-layerscape.patch
target/linux/layerscape/patches-4.9/817-usb-support-layerscape.patch

index 1523dee64264e9b9904b6015f6be6990ba476036..f1cb1fdab80a84fcdb2eebd4273868edfd22a5c8 100644 (file)
@@ -2,10 +2,10 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.9 = .155
+LINUX_VERSION-4.9 = .156
 LINUX_VERSION-4.14 = .98
 
-LINUX_KERNEL_HASH-4.9.155 = a52ac60be33c0fe312d99361f8e30211599956e958ba415d93194c6c9d073c9d
+LINUX_KERNEL_HASH-4.9.156 = 5eb1b9ba43370512ab637452089bb93f8c0fdd7d5399e99561d382f74517a816
 LINUX_KERNEL_HASH-4.14.98 = 8f021171b1b1efb41326e603116a45126fc030d06aaa9b0784ae612323010c5f
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index c402fe283bd6ab148f9fda9a7ad8a3151491e7b1..d162bfa1b44a8f1db71557746893c9e03848c7e2 100644 (file)
@@ -46,7 +46,7 @@ Signed-off-by: Noralf Trønnes <noralf@tronnes.org>
  
  struct bcm2835_dmadev {
        struct dma_device ddev;
-@@ -925,6 +927,9 @@ static int bcm2835_dma_probe(struct plat
+@@ -905,6 +907,9 @@ static int bcm2835_dma_probe(struct plat
        base = devm_ioremap_resource(&pdev->dev, res);
        if (IS_ERR(base))
                return PTR_ERR(base);
@@ -56,7 +56,7 @@ Signed-off-by: Noralf Trønnes <noralf@tronnes.org>
  
        od->base = base;
  
-@@ -962,6 +967,9 @@ static int bcm2835_dma_probe(struct plat
+@@ -942,6 +947,9 @@ static int bcm2835_dma_probe(struct plat
                goto err_no_dma;
        }
  
@@ -66,7 +66,7 @@ Signed-off-by: Noralf Trønnes <noralf@tronnes.org>
        /* get irqs for each channel that we support */
        for (i = 0; i <= BCM2835_DMA_MAX_DMA_CHAN_SUPPORTED; i++) {
                /* skip masked out channels */
-@@ -1036,6 +1044,7 @@ static int bcm2835_dma_remove(struct pla
+@@ -1016,6 +1024,7 @@ static int bcm2835_dma_remove(struct pla
  {
        struct bcm2835_dmadev *od = platform_get_drvdata(pdev);
  
@@ -74,7 +74,7 @@ Signed-off-by: Noralf Trønnes <noralf@tronnes.org>
        dma_async_device_unregister(&od->ddev);
        bcm2835_dma_free(od);
  
-@@ -1051,7 +1060,22 @@ static struct platform_driver bcm2835_dm
+@@ -1031,7 +1040,22 @@ static struct platform_driver bcm2835_dm
        },
  };
  
index 707e1a34a1ef9973b287d0045bcfb98641024460..6e6a9c34ec344920e8c54d1d4906981a92f28cd2 100644 (file)
@@ -696,7 +696,7 @@ Signed-off-by: Noralf Trønnes <noralf@tronnes.org>
  }
 --- a/drivers/usb/core/hub.c
 +++ b/drivers/usb/core/hub.c
-@@ -5074,7 +5074,7 @@ static void port_event(struct usb_hub *h
+@@ -5084,7 +5084,7 @@ static void port_event(struct usb_hub *h
        if (portchange & USB_PORT_STAT_C_OVERCURRENT) {
                u16 status = 0, unused;
  
index 34346903da6f3ad70deec35bc6a88f77cd83ae2e..c7160c7b2e027482242b38878aa1dc7eccb156de 100644 (file)
@@ -154,7 +154,7 @@ bcm2708_fb: Add ioctl for reading gpu memory through dma
                return -ENOTTY;
 --- a/drivers/video/fbdev/core/fbmem.c
 +++ b/drivers/video/fbdev/core/fbmem.c
-@@ -1084,6 +1084,31 @@ fb_blank(struct fb_info *info, int blank
+@@ -1088,6 +1088,31 @@ fb_blank(struct fb_info *info, int blank
  }
  EXPORT_SYMBOL(fb_blank);
  
@@ -186,7 +186,7 @@ bcm2708_fb: Add ioctl for reading gpu memory through dma
  static long do_fb_ioctl(struct fb_info *info, unsigned int cmd,
                        unsigned long arg)
  {
-@@ -1094,6 +1119,7 @@ static long do_fb_ioctl(struct fb_info *
+@@ -1098,6 +1123,7 @@ static long do_fb_ioctl(struct fb_info *
        struct fb_cmap cmap_from;
        struct fb_cmap_user cmap;
        struct fb_event event;
@@ -194,7 +194,7 @@ bcm2708_fb: Add ioctl for reading gpu memory through dma
        void __user *argp = (void __user *)arg;
        long ret = 0;
  
-@@ -1211,6 +1237,15 @@ static long do_fb_ioctl(struct fb_info *
+@@ -1215,6 +1241,15 @@ static long do_fb_ioctl(struct fb_info *
                unlock_fb_info(info);
                console_unlock();
                break;
@@ -210,7 +210,7 @@ bcm2708_fb: Add ioctl for reading gpu memory through dma
        default:
                if (!lock_fb_info(info))
                        return -ENODEV;
-@@ -1365,6 +1400,7 @@ static long fb_compat_ioctl(struct file
+@@ -1369,6 +1404,7 @@ static long fb_compat_ioctl(struct file
        case FBIOPAN_DISPLAY:
        case FBIOGET_CON2FBMAP:
        case FBIOPUT_CON2FBMAP:
index c6484a8f92ced74863b17f76a1f332edd10bc63e..fcca6bd02c6114747e06d72cb8914a8fdff49bd0 100644 (file)
@@ -137,7 +137,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
 --- a/scripts/mod/modpost.c
 +++ b/scripts/mod/modpost.c
-@@ -1965,7 +1965,9 @@ static void read_symbols(char *modname)
+@@ -1967,7 +1967,9 @@ static void read_symbols(char *modname)
                symname = remove_dot(info.strtab + sym->st_name);
  
                handle_modversions(mod, &info, sym, symname);
@@ -147,7 +147,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        }
        if (!is_vmlinux(modname) ||
             (is_vmlinux(modname) && vmlinux_section_warnings))
-@@ -2109,7 +2111,9 @@ static void add_header(struct buffer *b,
+@@ -2111,7 +2113,9 @@ static void add_header(struct buffer *b,
        buf_printf(b, "#include <linux/vermagic.h>\n");
        buf_printf(b, "#include <linux/compiler.h>\n");
        buf_printf(b, "\n");
@@ -157,7 +157,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        buf_printf(b, "\n");
        buf_printf(b, "__visible struct module __this_module\n");
        buf_printf(b, "__attribute__((section(\".gnu.linkonce.this_module\"))) = {\n");
-@@ -2126,24 +2130,30 @@ static void add_header(struct buffer *b,
+@@ -2128,24 +2132,30 @@ static void add_header(struct buffer *b,
  
  static void add_intree_flag(struct buffer *b, int is_intree)
  {
@@ -188,7 +188,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  }
  
  /* In kernel, this size is defined in linux/module.h;
-@@ -2247,11 +2257,13 @@ static void add_depends(struct buffer *b
+@@ -2249,11 +2259,13 @@ static void add_depends(struct buffer *b
  
  static void add_srcversion(struct buffer *b, struct module *mod)
  {
@@ -202,7 +202,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  }
  
  static void write_if_changed(struct buffer *b, const char *fname)
-@@ -2486,7 +2498,9 @@ int main(int argc, char **argv)
+@@ -2488,7 +2500,9 @@ int main(int argc, char **argv)
                add_staging_flag(&buf, mod->name);
                err |= add_versions(&buf, mod);
                add_depends(&buf, mod, modules);
index 4e13ec950c251d72dfa233bf3120f181eebefee0..00a5309dcf7fcae8d6d21c266329d2892ef96004 100644 (file)
@@ -18,7 +18,7 @@
                uart->capabilities      = up->capabilities;
 --- a/drivers/tty/serial/serial_core.c
 +++ b/drivers/tty/serial/serial_core.c
-@@ -2254,6 +2254,7 @@ uart_report_port(struct uart_driver *drv
+@@ -2260,6 +2260,7 @@ uart_report_port(struct uart_driver *drv
                snprintf(address, sizeof(address),
                         "I/O 0x%lx offset 0x%x", port->iobase, port->hub6);
                break;
@@ -26,7 +26,7 @@
        case UPIO_MEM:
        case UPIO_MEM16:
        case UPIO_MEM32:
-@@ -2918,6 +2919,7 @@ int uart_match_port(struct uart_port *po
+@@ -2924,6 +2925,7 @@ int uart_match_port(struct uart_port *po
        case UPIO_HUB6:
                return (port1->iobase == port2->iobase) &&
                       (port1->hub6   == port2->hub6);
index b072ccca11c4502cddca3a685a6413e2c6249bb0..deaca743dd48224f974423c9be2833c27c1246e0 100644 (file)
@@ -34,7 +34,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  
        return entry->group;
  }
-@@ -3166,9 +3168,10 @@ static bool amd_iommu_capable(enum iommu
+@@ -3173,9 +3175,10 @@ static bool amd_iommu_capable(enum iommu
        return false;
  }
  
@@ -47,7 +47,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        struct unity_map_entry *entry;
        int devid;
  
-@@ -3177,41 +3180,56 @@ static void amd_iommu_get_dm_regions(str
+@@ -3184,41 +3187,56 @@ static void amd_iommu_get_dm_regions(str
                return;
  
        list_for_each_entry(entry, &amd_iommu_unity_map, list) {
@@ -118,7 +118,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  {
        struct dma_ops_domain *dma_dom = to_dma_ops_domain(to_pdomain(domain));
        unsigned long start, end;
-@@ -3235,9 +3253,9 @@ static const struct iommu_ops amd_iommu_
+@@ -3242,9 +3260,9 @@ static const struct iommu_ops amd_iommu_
        .add_device = amd_iommu_add_device,
        .remove_device = amd_iommu_remove_device,
        .device_group = amd_iommu_device_group,
@@ -169,7 +169,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  };
  
  struct arm_smmu_domain {
-@@ -1000,9 +1009,9 @@ static void arm_smmu_write_strtab_ent(st
+@@ -1006,9 +1015,9 @@ static void arm_smmu_write_strtab_ent(st
         * This is hideously complicated, but we only really care about
         * three cases at the moment:
         *
@@ -182,7 +182,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
         *
         * Given that we can't update the STE atomically and the SMMU
         * doesn't read the thing in a defined order, that leaves us
-@@ -1041,11 +1050,15 @@ static void arm_smmu_write_strtab_ent(st
+@@ -1047,11 +1056,15 @@ static void arm_smmu_write_strtab_ent(st
        }
  
        /* Nuke the existing STE_0 value, as we're going to rewrite it */
@@ -202,7 +202,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                dst[0] = cpu_to_le64(val);
                dst[1] = cpu_to_le64(STRTAB_STE_1_SHCFG_INCOMING
                         << STRTAB_STE_1_SHCFG_SHIFT);
-@@ -1108,10 +1121,7 @@ static void arm_smmu_write_strtab_ent(st
+@@ -1114,10 +1127,7 @@ static void arm_smmu_write_strtab_ent(st
  static void arm_smmu_init_bypass_stes(u64 *strtab, unsigned int nent)
  {
        unsigned int i;
@@ -214,7 +214,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  
        for (i = 0; i < nent; ++i) {
                arm_smmu_write_strtab_ent(NULL, -1, strtab, &ste);
-@@ -1365,8 +1375,6 @@ static bool arm_smmu_capable(enum iommu_
+@@ -1371,8 +1381,6 @@ static bool arm_smmu_capable(enum iommu_
        switch (cap) {
        case IOMMU_CAP_CACHE_COHERENCY:
                return true;
@@ -223,7 +223,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        case IOMMU_CAP_NOEXEC:
                return true;
        default:
-@@ -1378,7 +1386,9 @@ static struct iommu_domain *arm_smmu_dom
+@@ -1384,7 +1392,9 @@ static struct iommu_domain *arm_smmu_dom
  {
        struct arm_smmu_domain *smmu_domain;
  
@@ -234,7 +234,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                return NULL;
  
        /*
-@@ -1509,6 +1519,11 @@ static int arm_smmu_domain_finalise(stru
+@@ -1515,6 +1525,11 @@ static int arm_smmu_domain_finalise(stru
        struct arm_smmu_domain *smmu_domain = to_smmu_domain(domain);
        struct arm_smmu_device *smmu = smmu_domain->smmu;
  
@@ -246,7 +246,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        /* Restrict the stage to what we can actually support */
        if (!(smmu->features & ARM_SMMU_FEAT_TRANS_S1))
                smmu_domain->stage = ARM_SMMU_DOMAIN_S2;
-@@ -1581,7 +1596,7 @@ static __le64 *arm_smmu_get_step_for_sid
+@@ -1587,7 +1602,7 @@ static __le64 *arm_smmu_get_step_for_sid
        return step;
  }
  
@@ -255,7 +255,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  {
        int i, j;
        struct arm_smmu_master_data *master = fwspec->iommu_priv;
-@@ -1600,17 +1615,14 @@ static int arm_smmu_install_ste_for_dev(
+@@ -1606,17 +1621,14 @@ static int arm_smmu_install_ste_for_dev(
  
                arm_smmu_write_strtab_ent(smmu, sid, step, &master->ste);
        }
@@ -275,7 +275,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  }
  
  static int arm_smmu_attach_dev(struct iommu_domain *domain, struct device *dev)
-@@ -1629,7 +1641,7 @@ static int arm_smmu_attach_dev(struct io
+@@ -1635,7 +1647,7 @@ static int arm_smmu_attach_dev(struct io
        ste = &master->ste;
  
        /* Already attached to a different domain? */
@@ -284,7 +284,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                arm_smmu_detach_dev(dev);
  
        mutex_lock(&smmu_domain->init_mutex);
-@@ -1650,10 +1662,12 @@ static int arm_smmu_attach_dev(struct io
+@@ -1656,10 +1668,12 @@ static int arm_smmu_attach_dev(struct io
                goto out_unlock;
        }
  
@@ -300,7 +300,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                ste->s1_cfg = &smmu_domain->s1_cfg;
                ste->s2_cfg = NULL;
                arm_smmu_write_ctx_desc(smmu, ste->s1_cfg);
-@@ -1662,10 +1676,7 @@ static int arm_smmu_attach_dev(struct io
+@@ -1668,10 +1682,7 @@ static int arm_smmu_attach_dev(struct io
                ste->s2_cfg = &smmu_domain->s2_cfg;
        }
  
@@ -312,7 +312,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  out_unlock:
        mutex_unlock(&smmu_domain->init_mutex);
        return ret;
-@@ -1713,6 +1724,9 @@ arm_smmu_iova_to_phys(struct iommu_domai
+@@ -1719,6 +1730,9 @@ arm_smmu_iova_to_phys(struct iommu_domai
        struct arm_smmu_domain *smmu_domain = to_smmu_domain(domain);
        struct io_pgtable_ops *ops = smmu_domain->pgtbl_ops;
  
@@ -322,7 +322,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        if (!ops)
                return 0;
  
-@@ -1811,7 +1825,7 @@ static void arm_smmu_remove_device(struc
+@@ -1817,7 +1831,7 @@ static void arm_smmu_remove_device(struc
                return;
  
        master = fwspec->iommu_priv;
@@ -331,7 +331,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                arm_smmu_detach_dev(dev);
        iommu_group_remove_device(dev);
        kfree(master);
-@@ -1840,6 +1854,9 @@ static int arm_smmu_domain_get_attr(stru
+@@ -1846,6 +1860,9 @@ static int arm_smmu_domain_get_attr(stru
  {
        struct arm_smmu_domain *smmu_domain = to_smmu_domain(domain);
  
@@ -341,7 +341,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        switch (attr) {
        case DOMAIN_ATTR_NESTING:
                *(int *)data = (smmu_domain->stage == ARM_SMMU_DOMAIN_NESTED);
-@@ -1855,6 +1872,9 @@ static int arm_smmu_domain_set_attr(stru
+@@ -1861,6 +1878,9 @@ static int arm_smmu_domain_set_attr(stru
        int ret = 0;
        struct arm_smmu_domain *smmu_domain = to_smmu_domain(domain);
  
@@ -351,7 +351,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        mutex_lock(&smmu_domain->init_mutex);
  
        switch (attr) {
-@@ -1884,6 +1904,31 @@ static int arm_smmu_of_xlate(struct devi
+@@ -1890,6 +1910,31 @@ static int arm_smmu_of_xlate(struct devi
        return iommu_fwspec_add_ids(dev, args->args, 1);
  }
  
@@ -383,7 +383,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  static struct iommu_ops arm_smmu_ops = {
        .capable                = arm_smmu_capable,
        .domain_alloc           = arm_smmu_domain_alloc,
-@@ -1899,6 +1944,8 @@ static struct iommu_ops arm_smmu_ops = {
+@@ -1905,6 +1950,8 @@ static struct iommu_ops arm_smmu_ops = {
        .domain_get_attr        = arm_smmu_domain_get_attr,
        .domain_set_attr        = arm_smmu_domain_set_attr,
        .of_xlate               = arm_smmu_of_xlate,
@@ -420,7 +420,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  static int force_stage;
  module_param(force_stage, int, S_IRUGO);
  MODULE_PARM_DESC(force_stage,
-@@ -401,6 +406,7 @@ enum arm_smmu_domain_stage {
+@@ -402,6 +407,7 @@ enum arm_smmu_domain_stage {
        ARM_SMMU_DOMAIN_S1 = 0,
        ARM_SMMU_DOMAIN_S2,
        ARM_SMMU_DOMAIN_NESTED,
@@ -428,7 +428,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  };
  
  struct arm_smmu_domain {
-@@ -821,6 +827,12 @@ static int arm_smmu_init_domain_context(
+@@ -822,6 +828,12 @@ static int arm_smmu_init_domain_context(
        if (smmu_domain->smmu)
                goto out_unlock;
  
@@ -441,7 +441,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        /*
         * Mapping the requested stage onto what we support is surprisingly
         * complicated, mainly because the spec allows S1+S2 SMMUs without
-@@ -981,7 +993,7 @@ static void arm_smmu_destroy_domain_cont
+@@ -982,7 +994,7 @@ static void arm_smmu_destroy_domain_cont
        void __iomem *cb_base;
        int irq;
  
@@ -450,7 +450,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                return;
  
        /*
-@@ -1004,7 +1016,9 @@ static struct iommu_domain *arm_smmu_dom
+@@ -1005,7 +1017,9 @@ static struct iommu_domain *arm_smmu_dom
  {
        struct arm_smmu_domain *smmu_domain;
  
@@ -461,7 +461,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                return NULL;
        /*
         * Allocate the domain and initialise some of its data structures.
-@@ -1202,10 +1216,15 @@ static int arm_smmu_domain_add_master(st
+@@ -1203,10 +1217,15 @@ static int arm_smmu_domain_add_master(st
  {
        struct arm_smmu_device *smmu = smmu_domain->smmu;
        struct arm_smmu_s2cr *s2cr = smmu->s2crs;
@@ -478,7 +478,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        for_each_cfg_sme(fwspec, i, idx) {
                if (type == s2cr[idx].type && cbndx == s2cr[idx].cbndx)
                        continue;
-@@ -1343,6 +1362,9 @@ static phys_addr_t arm_smmu_iova_to_phys
+@@ -1344,6 +1363,9 @@ static phys_addr_t arm_smmu_iova_to_phys
        struct arm_smmu_domain *smmu_domain = to_smmu_domain(domain);
        struct io_pgtable_ops *ops= smmu_domain->pgtbl_ops;
  
@@ -488,7 +488,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        if (!ops)
                return 0;
  
-@@ -1368,8 +1390,6 @@ static bool arm_smmu_capable(enum iommu_
+@@ -1369,8 +1391,6 @@ static bool arm_smmu_capable(enum iommu_
                 * requests.
                 */
                return true;
@@ -497,7 +497,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        case IOMMU_CAP_NOEXEC:
                return true;
        default:
-@@ -1478,10 +1498,12 @@ static struct iommu_group *arm_smmu_devi
+@@ -1479,10 +1499,12 @@ static struct iommu_group *arm_smmu_devi
        }
  
        if (group)
@@ -511,7 +511,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        else
                group = generic_device_group(dev);
  
-@@ -1493,6 +1515,9 @@ static int arm_smmu_domain_get_attr(stru
+@@ -1494,6 +1516,9 @@ static int arm_smmu_domain_get_attr(stru
  {
        struct arm_smmu_domain *smmu_domain = to_smmu_domain(domain);
  
@@ -521,7 +521,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        switch (attr) {
        case DOMAIN_ATTR_NESTING:
                *(int *)data = (smmu_domain->stage == ARM_SMMU_DOMAIN_NESTED);
-@@ -1508,6 +1533,9 @@ static int arm_smmu_domain_set_attr(stru
+@@ -1509,6 +1534,9 @@ static int arm_smmu_domain_set_attr(stru
        int ret = 0;
        struct arm_smmu_domain *smmu_domain = to_smmu_domain(domain);
  
@@ -531,7 +531,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        mutex_lock(&smmu_domain->init_mutex);
  
        switch (attr) {
-@@ -1534,17 +1562,44 @@ out_unlock:
+@@ -1535,17 +1563,44 @@ out_unlock:
  
  static int arm_smmu_of_xlate(struct device *dev, struct of_phandle_args *args)
  {
@@ -577,7 +577,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  static struct iommu_ops arm_smmu_ops = {
        .capable                = arm_smmu_capable,
        .domain_alloc           = arm_smmu_domain_alloc,
-@@ -1560,6 +1615,8 @@ static struct iommu_ops arm_smmu_ops = {
+@@ -1561,6 +1616,8 @@ static struct iommu_ops arm_smmu_ops = {
        .domain_get_attr        = arm_smmu_domain_get_attr,
        .domain_set_attr        = arm_smmu_domain_set_attr,
        .of_xlate               = arm_smmu_of_xlate,
@@ -586,7 +586,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        .pgsize_bitmap          = -1UL, /* Restricted during device attach */
  };
  
-@@ -1581,16 +1638,22 @@ static void arm_smmu_device_reset(struct
+@@ -1582,16 +1639,22 @@ static void arm_smmu_device_reset(struct
        for (i = 0; i < smmu->num_mapping_groups; ++i)
                arm_smmu_write_sme(smmu, i);
  
@@ -618,7 +618,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                writel_relaxed(reg, gr0_base + ARM_SMMU_GR0_sACR);
        }
  
-@@ -2024,6 +2087,11 @@ static int arm_smmu_device_dt_probe(stru
+@@ -2027,6 +2090,11 @@ static int arm_smmu_device_dt_probe(stru
                bus_set_iommu(&pci_bus_type, &arm_smmu_ops);
        }
  #endif
index 3271563f7f4f1310662111c0e02de36fc4afdc60..95e7cccd90191b9281f313f110110dfe94fb83d2 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  struct lpuart_port {
        struct uart_port        port;
        struct clk              *clk;
-@@ -1349,6 +1351,18 @@ lpuart_set_termios(struct uart_port *por
+@@ -1351,6 +1353,18 @@ lpuart_set_termios(struct uart_port *por
        /* ask the core to calculate the divisor */
        baud = uart_get_baud_rate(port, termios, old, 50, port->uartclk / 16);
  
@@ -43,7 +43,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        spin_lock_irqsave(&sport->port.lock, flags);
  
        sport->port.read_status_mask = 0;
-@@ -1398,22 +1412,11 @@ lpuart_set_termios(struct uart_port *por
+@@ -1400,22 +1414,11 @@ lpuart_set_termios(struct uart_port *por
        /* restore control register */
        writeb(old_cr2, sport->port.membase + UARTCR2);
  
@@ -69,7 +69,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        }
  
        spin_unlock_irqrestore(&sport->port.lock, flags);
-@@ -1641,6 +1644,13 @@ lpuart_console_write(struct console *co,
+@@ -1645,6 +1648,13 @@ lpuart_console_write(struct console *co,
  {
        struct lpuart_port *sport = lpuart_ports[co->index];
        unsigned char  old_cr2, cr2;
@@ -83,7 +83,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  
        /* first save CR2 and then disable interrupts */
        cr2 = old_cr2 = readb(sport->port.membase + UARTCR2);
-@@ -1655,6 +1665,9 @@ lpuart_console_write(struct console *co,
+@@ -1659,6 +1669,9 @@ lpuart_console_write(struct console *co,
                barrier();
  
        writeb(old_cr2, sport->port.membase + UARTCR2);
@@ -93,7 +93,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  }
  
  static void
-@@ -1662,6 +1675,13 @@ lpuart32_console_write(struct console *c
+@@ -1666,6 +1679,13 @@ lpuart32_console_write(struct console *c
  {
        struct lpuart_port *sport = lpuart_ports[co->index];
        unsigned long  old_cr, cr;
@@ -107,7 +107,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  
        /* first save CR2 and then disable interrupts */
        cr = old_cr = lpuart32_read(sport->port.membase + UARTCTRL);
-@@ -1676,6 +1696,9 @@ lpuart32_console_write(struct console *c
+@@ -1680,6 +1700,9 @@ lpuart32_console_write(struct console *c
                barrier();
  
        lpuart32_write(old_cr, sport->port.membase + UARTCTRL);
@@ -117,7 +117,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  }
  
  /*
-@@ -1900,13 +1923,13 @@ static int lpuart_probe(struct platform_
+@@ -1904,13 +1927,13 @@ static int lpuart_probe(struct platform_
  
        ret = of_alias_get_id(np, "serial");
        if (ret < 0) {
@@ -137,7 +137,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        sport->port.line = ret;
        sport->lpuart32 = of_device_is_compatible(np, "fsl,ls1021a-lpuart");
  
-@@ -1988,6 +2011,7 @@ static int lpuart_remove(struct platform
+@@ -1992,6 +2015,7 @@ static int lpuart_remove(struct platform
        struct lpuart_port *sport = platform_get_drvdata(pdev);
  
        uart_remove_one_port(&lpuart_reg, &sport->port);
@@ -145,7 +145,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  
        clk_disable_unprepare(sport->clk);
  
-@@ -2072,12 +2096,10 @@ static int lpuart_resume(struct device *
+@@ -2076,12 +2100,10 @@ static int lpuart_resume(struct device *
  
        if (sport->lpuart_dma_rx_use) {
                if (sport->port.irq_wake) {
index af4cd2fe16aca1793bd93118fdf739c670e41280..b93a3993e637ba58828efabfb9879543110212c7 100644 (file)
@@ -156,7 +156,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        int ret;
 --- a/drivers/usb/core/hub.c
 +++ b/drivers/usb/core/hub.c
-@@ -4433,6 +4433,14 @@ hub_port_init(struct usb_hub *hub, struc
+@@ -4443,6 +4443,14 @@ hub_port_init(struct usb_hub *hub, struc
        else
                speed = usb_speed_string(udev->speed);