projects
/
openwrt
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
890293c
)
sunxi: enable usbgadget feature
author
Chukun Pan
<amadeus@jmu.edu.cn>
Fri, 21 Feb 2025 14:01:05 +0000
(22:01 +0800)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Sat, 22 Feb 2025 17:43:23 +0000
(18:43 +0100)
The USB of most sunxi devices works in otg or peripheral mode.
Enable this feature to use usbgadget. Tested on OrangePi Zero3.
Signed-off-by: Chukun Pan <amadeus@jmu.edu.cn>
Link:
https://patchwork.ozlabs.org/project/openwrt/patch/20250221140105.250920-1-amadeus@jmu.edu.cn/
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/sunxi/Makefile
patch
|
blob
|
history
diff --git
a/target/linux/sunxi/Makefile
b/target/linux/sunxi/Makefile
index d91e5c5a3e6756de9b28f2d7432392b6790703b0..193383e940c178483f69b0e12f078444df6195b1 100644
(file)
--- a/
target/linux/sunxi/Makefile
+++ b/
target/linux/sunxi/Makefile
@@
-7,7
+7,7
@@
include $(TOPDIR)/rules.mk
ARCH:=arm
BOARD:=sunxi
BOARDNAME:=Allwinner ARM SoCs
-FEATURES:=
usb ext4 display rootfs-part rtc squashfs
+FEATURES:=
ext4 display rootfs-part rtc squashfs usb usbgadget
SUBTARGETS:=cortexa8 cortexa7 cortexa53
KERNEL_PATCHVER:=6.6