fix Intel driver-select, make it iwlagn only for now
authorJohannes Berg <johannes@sipsolutions.net>
Thu, 3 Mar 2011 16:25:45 +0000 (17:25 +0100)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Thu, 3 Mar 2011 17:08:26 +0000 (09:08 -0800)
Signed-off-by: Johannes Berg <johannes@sipsolutions.net>
scripts/driver-select

index ef66e6ae1af1741de2f993f81d96eae3eb000cb1..69531f08f7fcd8d562f1b878f3446cbeff65e2f1 100755 (executable)
@@ -57,8 +57,7 @@ function usage {
        echo -e "\nSupported group drivers:"
        echo -e "\t${CYAN}atheros${NORMAL} < ${PURPLE} ath5k ath9k carl9170 zd1211rw ${NORMAL}>"
        echo -e "\t${CYAN}ath${NORMAL} < ${PURPLE} ath5k ath9k carl9170 ${NORMAL}>"
-       echo -e "\t${CYAN}intel${NORMAL} < ${PURPLE} iwl3945 iwlagn ipw2100 ipw2200 ${NORMAL}>"
-       echo -e "\t${CYAN}iwlwifi${NORMAL} < ${PURPLE} iwl3945 iwlagn ${NORMAL}>"
+       echo -e "\t${CYAN}iwlagn${NORMAL} < ${PURPLE} iwlagn ${NORMAL}>"
        echo -e "\t${CYAN}rtl818x${NORMAL} < ${PURPLE} rtl8180 rtl8187 ${NORMAL}>"
        echo -e "\t${CYAN}rtlwifi${NORMAL} < ${PURPLE} rtl8192ce ${NORMAL}>"
        echo -e "\t${CYAN}wl12xx${NORMAL} < ${PURPLE} wl1251 wl12xx (SPI and SDIO)${NORMAL}>"
@@ -245,13 +244,6 @@ function select_ath9k_driver
        # In the future here we'll add stuff to disable ath9k_htc
 }
 
-# iwlwifi stuff needs more work
-function select_iwl_driver 
-{
-       perl -i -ne 'print if /'$1'/ || /CONFIG_BLEH/ ' drivers/net/wireless/iwlwifi/Makefile
-       disable_var_01
-}
-
 function restore_file {
        #ORIG=$(shell ${1%%.${BACKUP_EXT}})
        ORIG=${1%%.bk}
@@ -327,8 +319,8 @@ case $1 in
                disable_ethernet
                disable_usbnet
                ;;
-       iwlwifi)
-               select_driver           CONFIG_COMPAT_IWLWIFI
+       iwlagn)
+               select_driver           CONFIG_IWLAGN
                disable_staging
                disable_var_01
                disable_bt