linux-firmware: qualcomm: add WCN7850 firmware
authorJanusz Dziedzic <janusz.dziedzic@gmail.com>
Sat, 24 Feb 2024 10:25:15 +0000 (10:25 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 22 Sep 2024 22:34:08 +0000 (00:34 +0200)
Add option to add WCN7850 ath12k firmware.

Signed-off-by: Janusz Dziedzic <janusz.dziedzic@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/15945
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/firmware/linux-firmware/qca_ath12k.mk [new file with mode: 0644]

diff --git a/package/firmware/linux-firmware/qca_ath12k.mk b/package/firmware/linux-firmware/qca_ath12k.mk
new file mode 100644 (file)
index 0000000..dc719c6
--- /dev/null
@@ -0,0 +1,7 @@
+Package/ath12k-firmware-wcn7850 = $(call Package/firmware-default,WCN7850 ath12k firmware)
+define Package/ath12k-firmware-wcn7850/install
+       $(INSTALL_DIR) $(1)/lib/firmware/ath12k/WCN7850/hw2.0
+       $(INSTALL_DATA) \
+               $(PKG_BUILD_DIR)/ath12k/WCN7850/hw2.0/* $(1)/lib/firmware/ath12k/WCN7850/hw2.0/
+endef
+$(eval $(call BuildPackage,ath12k-firmware-wcn7850))