projects
/
openwrt
/
staging
/
thess.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
6992efe
)
more fixes for the patching stuff (was testing it on the wrong target)
author
Felix Fietkau
<nbd@openwrt.org>
Sun, 3 Jun 2007 19:52:54 +0000
(19:52 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Sun, 3 Jun 2007 19:52:54 +0000
(19:52 +0000)
SVN-Revision: 7483
include/quilt.mk
patch
|
blob
|
history
diff --git
a/include/quilt.mk
b/include/quilt.mk
index e77e0db77215f910edfe0c7fb01161e8b705261d..e8c3b90a681d67647fb8794cfed2f02ed3dc4374 100644
(file)
--- a/
include/quilt.mk
+++ b/
include/quilt.mk
@@
-49,8
+49,9
@@
define Kernel/Patch/Default
if [ -d $(GENERIC_PLATFORM_DIR)/patches ]; then $(PATCH) $(LINUX_DIR) $(GENERIC_PLATFORM_DIR)/patches; fi \
)
$(if $(strip $(QUILT)),$(call Quilt/Patch,./patches,platform/), \
- if [ -d ./
files ]; then $(CP) ./files/* $(LINUX_DIR)/
; fi \
+ if [ -d ./
patches ]; then $(PATCH) $(LINUX_DIR) ./patches
; fi \
)
+ $(if $(strip $(QUILT)),touch $(PKG_BUILD_DIR)/.quilt_used)
endef
$(STAMP_PATCHED): $(STAMP_PREPARED)