backports: add rndis_wlan usbnet requirements
authorJohannes Berg <johannes.berg@intel.com>
Mon, 15 Apr 2013 08:25:38 +0000 (10:25 +0200)
committerJohannes Berg <johannes.berg@intel.com>
Mon, 15 Apr 2013 08:28:28 +0000 (10:28 +0200)
Apparently I missed this during the conversion to the new
copy-list etc. The rndis_wlan driver requires some usbnet
and rndis code, if that's not present then it is either
not selectable or can be compiled but won't link against
older kernels that don't have the right requirements (or
don't have the symbols exported.)

For now, because the makefile parser is stupid, patch out
the asix driver objects because otherwise it's possible
to select it and fail the build. Improving the parser is
possible but I need to finish other things first.

Signed-off-by: Johannes Berg <johannes.berg@intel.com>
backport/Kconfig
backport/Makefile.kernel
copy-list
patches/collateral-evolutions/network/0010-disable-usb-net-asix.patch [new file with mode: 0644]

index 3103f10639153b1f09b25ab4b3df8360c5f1db4a..2ee5064a06933217bb4520c39e623b0e74cebc24 100644 (file)
@@ -31,6 +31,7 @@ source net/bluetooth/Kconfig
 source net/rfkill/Kconfig
 source drivers/net/wireless/Kconfig
 source drivers/net/ethernet/Kconfig
+source drivers/net/usb/Kconfig
 
 source drivers/ssb/Kconfig
 source drivers/bcma/Kconfig
index 096e80c2cda62e04183a72b840b5c59e42a55689..e2e2f4446a22047fc31dbc6f890f5fe3ea151f51 100644 (file)
@@ -28,6 +28,7 @@ obj-$(CPTCFG_BT) += drivers/bluetooth/
 obj-$(CPTCFG_SSB) += drivers/ssb/
 obj-$(CPTCFG_BCMA) += drivers/bcma/
 obj-$(CPTCFG_ETHERNET) += drivers/net/ethernet/
+obj-m += drivers/net/usb/
 obj-$(CPTCFG_DRM) += drivers/gpu/drm/
 obj-$(CPTCFG_NFC) += net/nfc/
 obj-$(CPTCFG_NFC) += drivers/nfc/
index b49901d6eb9b1fa310d3b6b4b5517a80f05ef725..6db79a34c386f3a4196caaa9e24bea618a9b841c 100644 (file)
--- a/copy-list
+++ b/copy-list
@@ -74,6 +74,12 @@ drivers/net/wireless/mac80211_hwsim.c
 drivers/net/wireless/mac80211_hwsim.h
 drivers/net/wireless/mwl8k.c
 drivers/net/wireless/rndis_wlan.c
+# rndis also requires some of the USB networking
+drivers/net/usb/Makefile
+drivers/net/usb/Kconfig
+drivers/net/usb/rndis_host.c
+drivers/net/usb/cdc_ether.c
+drivers/net/usb/usbnet.c
 
 
 # Bluetooth
diff --git a/patches/collateral-evolutions/network/0010-disable-usb-net-asix.patch b/patches/collateral-evolutions/network/0010-disable-usb-net-asix.patch
new file mode 100644 (file)
index 0000000..d5dd116
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/drivers/net/usb/Makefile
++++ b/drivers/net/usb/Makefile
+@@ -8,7 +8,6 @@ obj-$(CONFIG_USB_PEGASUS)      += pegasus.o
+ obj-$(CONFIG_USB_RTL8150)     += rtl8150.o
+ obj-$(CONFIG_USB_HSO)         += hso.o
+ obj-$(CONFIG_USB_NET_AX8817X) += asix.o
+-asix-y := asix_devices.o asix_common.o ax88172a.o
+ obj-$(CONFIG_USB_NET_AX88179_178A)      += ax88179_178a.o
+ obj-$(CONFIG_USB_NET_CDCETHER)        += cdc_ether.o
+ obj-$(CONFIG_USB_NET_CDC_EEM) += cdc_eem.o