haproxy: update to v1.3.23, fix restart action
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 4 Feb 2010 14:52:04 +0000 (14:52 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 4 Feb 2010 14:52:04 +0000 (14:52 +0000)
SVN-Revision: 19524

net/haproxy/Makefile
net/haproxy/files/haproxy.init

index 8e7b509cce4bf52826678806d0bec5bf0846d174..d5491bfa40194fd1782735dedecbd36c756d2778 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 Thomas Heil <heil@terminal-consulting.de>
+# Copyright (C) 2009-2010 Thomas Heil <heil@terminal-consulting.de> 
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,12 +7,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=haproxy
-PKG_VERSION:=1.3.22
-PKG_RELEASE:=2
+PKG_VERSION:=1.3.23
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://haproxy.1wt.eu/download/1.3/src/
-PKG_MD5SUM:=b84e0935cfea99eda43645d53bb82367
+PKG_MD5SUM:=4ffe926ccf4f4d53f149290eb001fad5
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -40,7 +40,7 @@ define Build/Compile
                CFLAGS="$(TARGET_CFLAGS)" \
                LD="$(TARGET_CC)" \
                LDFLAGS="$(TARGET_LDFLAGS)" \
-               SMALL_OPTS="-DBUFSIZE=8192 -DMAXREWRITE=1024" \
+               SMALL_OPTS="-DBUFSIZE=16060 -DMAXREWRITE=4096" \
                all install
 endef
 
index 5e4ef1578d7390a10aa99216df74b04dbde29663..dd8575ce4e259a046de241ff1fdb68dfa389da66 100644 (file)
@@ -1,5 +1,5 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2010 OpenWrt.org
 
 START=99
 STOP=80
@@ -11,16 +11,17 @@ HAPROXY_PID="/var/run/haproxy.pid"
 start() {
        [ -x "$HAPROXY_BIN" ] || return 1
 
-       start-stop-daemon -S -b -x $HAPROXY_BIN -- \
-               -f "$HAPROXY_CONFIG" -V -D -d -p "$HAPROXY_PID"
+       start-stop-daemon -S -x $HAPROXY_BIN -- \
+               -f "$HAPROXY_CONFIG" -V -D -p "$HAPROXY_PID"
 }
 
 stop() {
-       start-stop-daemon -K -x $HAPROXY_BIN -p $HAPROXY_PID
-       rm -f $HAPROXY_PID
+       start-stop-daemon -q -K -x $HAPROXY_BIN -p $HAPROXY_PID
+       sleep 3
+       kill -0 `cat $HAPROXY_PID` 2>/dev/null && \
+               start-stop-daemon -q -K -s KILL -x $HAPROXY_BIN -p $HAPROXY_PID
 }
 
 reload() {
-       [ ! -f "$HAPROXY_PID" ] && start
        $HAPROXY_BIN -f $HAPROXY_CONFIG -p $HAPROXY_PID -st $(cat $HAPROXY_PID)
 }