projects
/
openwrt
/
staging
/
kaloz.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
a47a5dd
)
toolchain: binutils: enhance build reproducability
author
Steven Barth
<cyrus@openwrt.org>
Mon, 29 Jun 2015 06:47:42 +0000
(06:47 +0000)
committer
Steven Barth
<cyrus@openwrt.org>
Mon, 29 Jun 2015 06:47:42 +0000
(06:47 +0000)
built toolchain utilities will always operate in deterministic mode:
https://sourceware.org/binutils/docs-2.25/binutils/ar-cmdline.html
Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
SVN-Revision: 46137
toolchain/binutils/Makefile
patch
|
blob
|
history
diff --git
a/toolchain/binutils/Makefile
b/toolchain/binutils/Makefile
index 9043db713f4824047d0643cf2fa2fa0d1790d872..02765126e92d056c5637a0edf602d2d63e93ad3b 100644
(file)
--- a/
toolchain/binutils/Makefile
+++ b/
toolchain/binutils/Makefile
@@
-32,6
+32,7
@@
BINUTILS_CONFIGURE:= \
--host=$(GNU_HOST_NAME) \
--target=$(REAL_GNU_TARGET_NAME) \
--with-sysroot=$(TOOLCHAIN_DIR) \
+ --enable-deterministic-archives \
--enable-plugins \
--disable-multilib \
--disable-werror \