staging: fsl-mc: Move DPBP out of staging
authorBogdan Purcareata <bogdan.purcareata@nxp.com>
Fri, 2 Mar 2018 10:23:58 +0000 (04:23 -0600)
committerGreg Kroah-Hartman <gregkh@linuxfoundation.org>
Wed, 14 Mar 2018 12:18:42 +0000 (13:18 +0100)
Move the source files out of staging into their final locations:
- dpbp.c goes to drivers/bus/fsl-mc/, next to the core infrastructure
- dpbp-cmd.h gets merged into drivers/bus/fsl-mc/fsl-mc-private.h, next
  to the other internally used APIs
- dpbp.h gets merged into include/linux/fsl/mc.h, exposing the public
  API

Update references in the dpaa2-eth staging driver.

DPBP stands for Data Path Buffer Pool - you can read more about the
object in Documentation/networking/dpaa2/overview.rst

Signed-off-by: Bogdan Purcareata <bogdan.purcareata@nxp.com>
Reviewed-by: Laurentiu Tudor <laurentiu.tudor@nxp.com>
Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
drivers/bus/fsl-mc/Makefile
drivers/bus/fsl-mc/dpbp.c [new file with mode: 0644]
drivers/bus/fsl-mc/fsl-mc-private.h
drivers/staging/fsl-dpaa2/ethernet/dpaa2-eth.h
drivers/staging/fsl-mc/bus/Makefile
drivers/staging/fsl-mc/bus/dpbp-cmd.h [deleted file]
drivers/staging/fsl-mc/bus/dpbp.c [deleted file]
drivers/staging/fsl-mc/include/dpbp.h [deleted file]
include/linux/fsl/mc.h

index 6a97f2c3a06531c5521d356f3c4db383f0b5bcbb..da26e529baf19b68799cf54228bcd234af2270c2 100644 (file)
@@ -9,6 +9,7 @@ obj-$(CONFIG_FSL_MC_BUS) += mc-bus-driver.o
 mc-bus-driver-objs := fsl-mc-bus.o \
                      mc-sys.o \
                      mc-io.o \
+                     dpbp.o \
                      dprc.o \
                      dprc-driver.o \
                      fsl-mc-allocator.o \
diff --git a/drivers/bus/fsl-mc/dpbp.c b/drivers/bus/fsl-mc/dpbp.c
new file mode 100644 (file)
index 0000000..0aeacc5
--- /dev/null
@@ -0,0 +1,186 @@
+// SPDX-License-Identifier: (GPL-2.0+ OR BSD-3-Clause)
+/*
+ * Copyright 2013-2016 Freescale Semiconductor Inc.
+ *
+ */
+#include <linux/kernel.h>
+#include <linux/fsl/mc.h>
+#include <linux/fsl/mc.h>
+
+#include "fsl-mc-private.h"
+
+/**
+ * dpbp_open() - Open a control session for the specified object.
+ * @mc_io:     Pointer to MC portal's I/O object
+ * @cmd_flags: Command flags; one or more of 'MC_CMD_FLAG_'
+ * @dpbp_id:   DPBP unique ID
+ * @token:     Returned token; use in subsequent API calls
+ *
+ * This function can be used to open a control session for an
+ * already created object; an object may have been declared in
+ * the DPL or by calling the dpbp_create function.
+ * This function returns a unique authentication token,
+ * associated with the specific object ID and the specific MC
+ * portal; this token must be used in all subsequent commands for
+ * this specific object
+ *
+ * Return:     '0' on Success; Error code otherwise.
+ */
+int dpbp_open(struct fsl_mc_io *mc_io,
+             u32 cmd_flags,
+             int dpbp_id,
+             u16 *token)
+{
+       struct mc_command cmd = { 0 };
+       struct dpbp_cmd_open *cmd_params;
+       int err;
+
+       /* prepare command */
+       cmd.header = mc_encode_cmd_header(DPBP_CMDID_OPEN,
+                                         cmd_flags, 0);
+       cmd_params = (struct dpbp_cmd_open *)cmd.params;
+       cmd_params->dpbp_id = cpu_to_le32(dpbp_id);
+
+       /* send command to mc*/
+       err = mc_send_command(mc_io, &cmd);
+       if (err)
+               return err;
+
+       /* retrieve response parameters */
+       *token = mc_cmd_hdr_read_token(&cmd);
+
+       return err;
+}
+EXPORT_SYMBOL_GPL(dpbp_open);
+
+/**
+ * dpbp_close() - Close the control session of the object
+ * @mc_io:     Pointer to MC portal's I/O object
+ * @cmd_flags: Command flags; one or more of 'MC_CMD_FLAG_'
+ * @token:     Token of DPBP object
+ *
+ * After this function is called, no further operations are
+ * allowed on the object without opening a new control session.
+ *
+ * Return:     '0' on Success; Error code otherwise.
+ */
+int dpbp_close(struct fsl_mc_io *mc_io,
+              u32 cmd_flags,
+              u16 token)
+{
+       struct mc_command cmd = { 0 };
+
+       /* prepare command */
+       cmd.header = mc_encode_cmd_header(DPBP_CMDID_CLOSE, cmd_flags,
+                                         token);
+
+       /* send command to mc*/
+       return mc_send_command(mc_io, &cmd);
+}
+EXPORT_SYMBOL_GPL(dpbp_close);
+
+/**
+ * dpbp_enable() - Enable the DPBP.
+ * @mc_io:     Pointer to MC portal's I/O object
+ * @cmd_flags: Command flags; one or more of 'MC_CMD_FLAG_'
+ * @token:     Token of DPBP object
+ *
+ * Return:     '0' on Success; Error code otherwise.
+ */
+int dpbp_enable(struct fsl_mc_io *mc_io,
+               u32 cmd_flags,
+               u16 token)
+{
+       struct mc_command cmd = { 0 };
+
+       /* prepare command */
+       cmd.header = mc_encode_cmd_header(DPBP_CMDID_ENABLE, cmd_flags,
+                                         token);
+
+       /* send command to mc*/
+       return mc_send_command(mc_io, &cmd);
+}
+EXPORT_SYMBOL_GPL(dpbp_enable);
+
+/**
+ * dpbp_disable() - Disable the DPBP.
+ * @mc_io:     Pointer to MC portal's I/O object
+ * @cmd_flags: Command flags; one or more of 'MC_CMD_FLAG_'
+ * @token:     Token of DPBP object
+ *
+ * Return:     '0' on Success; Error code otherwise.
+ */
+int dpbp_disable(struct fsl_mc_io *mc_io,
+                u32 cmd_flags,
+                u16 token)
+{
+       struct mc_command cmd = { 0 };
+
+       /* prepare command */
+       cmd.header = mc_encode_cmd_header(DPBP_CMDID_DISABLE,
+                                         cmd_flags, token);
+
+       /* send command to mc*/
+       return mc_send_command(mc_io, &cmd);
+}
+EXPORT_SYMBOL_GPL(dpbp_disable);
+
+/**
+ * dpbp_reset() - Reset the DPBP, returns the object to initial state.
+ * @mc_io:     Pointer to MC portal's I/O object
+ * @cmd_flags: Command flags; one or more of 'MC_CMD_FLAG_'
+ * @token:     Token of DPBP object
+ *
+ * Return:     '0' on Success; Error code otherwise.
+ */
+int dpbp_reset(struct fsl_mc_io *mc_io,
+              u32 cmd_flags,
+              u16 token)
+{
+       struct mc_command cmd = { 0 };
+
+       /* prepare command */
+       cmd.header = mc_encode_cmd_header(DPBP_CMDID_RESET,
+                                         cmd_flags, token);
+
+       /* send command to mc*/
+       return mc_send_command(mc_io, &cmd);
+}
+EXPORT_SYMBOL_GPL(dpbp_reset);
+
+/**
+ * dpbp_get_attributes - Retrieve DPBP attributes.
+ *
+ * @mc_io:     Pointer to MC portal's I/O object
+ * @cmd_flags: Command flags; one or more of 'MC_CMD_FLAG_'
+ * @token:     Token of DPBP object
+ * @attr:      Returned object's attributes
+ *
+ * Return:     '0' on Success; Error code otherwise.
+ */
+int dpbp_get_attributes(struct fsl_mc_io *mc_io,
+                       u32 cmd_flags,
+                       u16 token,
+                       struct dpbp_attr *attr)
+{
+       struct mc_command cmd = { 0 };
+       struct dpbp_rsp_get_attributes *rsp_params;
+       int err;
+
+       /* prepare command */
+       cmd.header = mc_encode_cmd_header(DPBP_CMDID_GET_ATTR,
+                                         cmd_flags, token);
+
+       /* send command to mc*/
+       err = mc_send_command(mc_io, &cmd);
+       if (err)
+               return err;
+
+       /* retrieve response parameters */
+       rsp_params = (struct dpbp_rsp_get_attributes *)cmd.params;
+       attr->bpid = le16_to_cpu(rsp_params->bpid);
+       attr->id = le32_to_cpu(rsp_params->id);
+
+       return 0;
+}
+EXPORT_SYMBOL_GPL(dpbp_get_attributes);
index bed990c517f383bbfa8ebb192ef20bc0eb133610..4ef8d7e078fb00365e7fb01309459d4be297d9ff 100644 (file)
@@ -379,6 +379,45 @@ int dprc_get_container_id(struct fsl_mc_io *mc_io,
                          u32 cmd_flags,
                          int *container_id);
 
+/*
+ * Data Path Buffer Pool (DPBP) API
+ */
+
+/* DPBP Version */
+#define DPBP_VER_MAJOR                         3
+#define DPBP_VER_MINOR                         2
+
+/* Command versioning */
+#define DPBP_CMD_BASE_VERSION                  1
+#define DPBP_CMD_ID_OFFSET                     4
+
+#define DPBP_CMD(id)   (((id) << DPBP_CMD_ID_OFFSET) | DPBP_CMD_BASE_VERSION)
+
+/* Command IDs */
+#define DPBP_CMDID_CLOSE               DPBP_CMD(0x800)
+#define DPBP_CMDID_OPEN                        DPBP_CMD(0x804)
+
+#define DPBP_CMDID_ENABLE              DPBP_CMD(0x002)
+#define DPBP_CMDID_DISABLE             DPBP_CMD(0x003)
+#define DPBP_CMDID_GET_ATTR            DPBP_CMD(0x004)
+#define DPBP_CMDID_RESET               DPBP_CMD(0x005)
+
+struct dpbp_cmd_open {
+       __le32 dpbp_id;
+};
+
+#define DPBP_ENABLE                    0x1
+
+struct dpbp_rsp_get_attributes {
+       /* response word 0 */
+       __le16 pad;
+       __le16 bpid;
+       __le32 id;
+       /* response word 1 */
+       __le16 version_major;
+       __le16 version_minor;
+};
+
 /**
  * Maximum number of total IRQs that can be pre-allocated for an MC bus'
  * IRQ pool
index e577410fdf4fbcffb3b58b9bc8e1c3803d2dbf7a..ce864eede95ca9621ebcea0b2ab1267bb9109e84 100644 (file)
 
 #include <linux/netdevice.h>
 #include <linux/if_vlan.h>
+#include <linux/fsl/mc.h>
 
 #include "../../fsl-mc/include/dpaa2-io.h"
 #include "../../fsl-mc/include/dpaa2-fd.h"
-#include "../../fsl-mc/include/dpbp.h"
 #include "../../fsl-mc/include/dpcon.h"
 #include "dpni.h"
 #include "dpni-cmd.h"
index b67889ecbe5c82015945888e5dec0e9acd87e26b..ea6479f65410d1fdff6c81117b8acb8d44c38456 100644 (file)
@@ -4,8 +4,7 @@
 #
 # Copyright (C) 2014 Freescale Semiconductor, Inc.
 #
-obj-$(CONFIG_FSL_MC_BUS) += dpbp.o \
-                           dpcon.o
+obj-$(CONFIG_FSL_MC_BUS) += dpcon.o
 
 # MC DPIO driver
 obj-$(CONFIG_FSL_MC_DPIO) += dpio/
diff --git a/drivers/staging/fsl-mc/bus/dpbp-cmd.h b/drivers/staging/fsl-mc/bus/dpbp-cmd.h
deleted file mode 100644 (file)
index 3340021..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-/* SPDX-License-Identifier: (GPL-2.0+ OR BSD-3-Clause) */
-/*
- * Copyright 2013-2016 Freescale Semiconductor Inc.
- *
- */
-#ifndef _FSL_DPBP_CMD_H
-#define _FSL_DPBP_CMD_H
-
-/* DPBP Version */
-#define DPBP_VER_MAJOR                         3
-#define DPBP_VER_MINOR                         2
-
-/* Command versioning */
-#define DPBP_CMD_BASE_VERSION                  1
-#define DPBP_CMD_ID_OFFSET                     4
-
-#define DPBP_CMD(id)   (((id) << DPBP_CMD_ID_OFFSET) | DPBP_CMD_BASE_VERSION)
-
-/* Command IDs */
-#define DPBP_CMDID_CLOSE               DPBP_CMD(0x800)
-#define DPBP_CMDID_OPEN                        DPBP_CMD(0x804)
-
-#define DPBP_CMDID_ENABLE              DPBP_CMD(0x002)
-#define DPBP_CMDID_DISABLE             DPBP_CMD(0x003)
-#define DPBP_CMDID_GET_ATTR            DPBP_CMD(0x004)
-#define DPBP_CMDID_RESET               DPBP_CMD(0x005)
-
-struct dpbp_cmd_open {
-       __le32 dpbp_id;
-};
-
-#define DPBP_ENABLE                    0x1
-
-struct dpbp_rsp_get_attributes {
-       /* response word 0 */
-       __le16 pad;
-       __le16 bpid;
-       __le32 id;
-       /* response word 1 */
-       __le16 version_major;
-       __le16 version_minor;
-};
-
-#endif /* _FSL_DPBP_CMD_H */
diff --git a/drivers/staging/fsl-mc/bus/dpbp.c b/drivers/staging/fsl-mc/bus/dpbp.c
deleted file mode 100644 (file)
index 85735bb..0000000
+++ /dev/null
@@ -1,186 +0,0 @@
-// SPDX-License-Identifier: (GPL-2.0+ OR BSD-3-Clause)
-/*
- * Copyright 2013-2016 Freescale Semiconductor Inc.
- *
- */
-#include <linux/kernel.h>
-#include <linux/fsl/mc.h>
-#include "../include/dpbp.h"
-
-#include "dpbp-cmd.h"
-
-/**
- * dpbp_open() - Open a control session for the specified object.
- * @mc_io:     Pointer to MC portal's I/O object
- * @cmd_flags: Command flags; one or more of 'MC_CMD_FLAG_'
- * @dpbp_id:   DPBP unique ID
- * @token:     Returned token; use in subsequent API calls
- *
- * This function can be used to open a control session for an
- * already created object; an object may have been declared in
- * the DPL or by calling the dpbp_create function.
- * This function returns a unique authentication token,
- * associated with the specific object ID and the specific MC
- * portal; this token must be used in all subsequent commands for
- * this specific object
- *
- * Return:     '0' on Success; Error code otherwise.
- */
-int dpbp_open(struct fsl_mc_io *mc_io,
-             u32 cmd_flags,
-             int dpbp_id,
-             u16 *token)
-{
-       struct mc_command cmd = { 0 };
-       struct dpbp_cmd_open *cmd_params;
-       int err;
-
-       /* prepare command */
-       cmd.header = mc_encode_cmd_header(DPBP_CMDID_OPEN,
-                                         cmd_flags, 0);
-       cmd_params = (struct dpbp_cmd_open *)cmd.params;
-       cmd_params->dpbp_id = cpu_to_le32(dpbp_id);
-
-       /* send command to mc*/
-       err = mc_send_command(mc_io, &cmd);
-       if (err)
-               return err;
-
-       /* retrieve response parameters */
-       *token = mc_cmd_hdr_read_token(&cmd);
-
-       return err;
-}
-EXPORT_SYMBOL_GPL(dpbp_open);
-
-/**
- * dpbp_close() - Close the control session of the object
- * @mc_io:     Pointer to MC portal's I/O object
- * @cmd_flags: Command flags; one or more of 'MC_CMD_FLAG_'
- * @token:     Token of DPBP object
- *
- * After this function is called, no further operations are
- * allowed on the object without opening a new control session.
- *
- * Return:     '0' on Success; Error code otherwise.
- */
-int dpbp_close(struct fsl_mc_io *mc_io,
-              u32 cmd_flags,
-              u16 token)
-{
-       struct mc_command cmd = { 0 };
-
-       /* prepare command */
-       cmd.header = mc_encode_cmd_header(DPBP_CMDID_CLOSE, cmd_flags,
-                                         token);
-
-       /* send command to mc*/
-       return mc_send_command(mc_io, &cmd);
-}
-EXPORT_SYMBOL_GPL(dpbp_close);
-
-/**
- * dpbp_enable() - Enable the DPBP.
- * @mc_io:     Pointer to MC portal's I/O object
- * @cmd_flags: Command flags; one or more of 'MC_CMD_FLAG_'
- * @token:     Token of DPBP object
- *
- * Return:     '0' on Success; Error code otherwise.
- */
-int dpbp_enable(struct fsl_mc_io *mc_io,
-               u32 cmd_flags,
-               u16 token)
-{
-       struct mc_command cmd = { 0 };
-
-       /* prepare command */
-       cmd.header = mc_encode_cmd_header(DPBP_CMDID_ENABLE, cmd_flags,
-                                         token);
-
-       /* send command to mc*/
-       return mc_send_command(mc_io, &cmd);
-}
-EXPORT_SYMBOL_GPL(dpbp_enable);
-
-/**
- * dpbp_disable() - Disable the DPBP.
- * @mc_io:     Pointer to MC portal's I/O object
- * @cmd_flags: Command flags; one or more of 'MC_CMD_FLAG_'
- * @token:     Token of DPBP object
- *
- * Return:     '0' on Success; Error code otherwise.
- */
-int dpbp_disable(struct fsl_mc_io *mc_io,
-                u32 cmd_flags,
-                u16 token)
-{
-       struct mc_command cmd = { 0 };
-
-       /* prepare command */
-       cmd.header = mc_encode_cmd_header(DPBP_CMDID_DISABLE,
-                                         cmd_flags, token);
-
-       /* send command to mc*/
-       return mc_send_command(mc_io, &cmd);
-}
-EXPORT_SYMBOL_GPL(dpbp_disable);
-
-/**
- * dpbp_reset() - Reset the DPBP, returns the object to initial state.
- * @mc_io:     Pointer to MC portal's I/O object
- * @cmd_flags: Command flags; one or more of 'MC_CMD_FLAG_'
- * @token:     Token of DPBP object
- *
- * Return:     '0' on Success; Error code otherwise.
- */
-int dpbp_reset(struct fsl_mc_io *mc_io,
-              u32 cmd_flags,
-              u16 token)
-{
-       struct mc_command cmd = { 0 };
-
-       /* prepare command */
-       cmd.header = mc_encode_cmd_header(DPBP_CMDID_RESET,
-                                         cmd_flags, token);
-
-       /* send command to mc*/
-       return mc_send_command(mc_io, &cmd);
-}
-EXPORT_SYMBOL_GPL(dpbp_reset);
-
-/**
- * dpbp_get_attributes - Retrieve DPBP attributes.
- *
- * @mc_io:     Pointer to MC portal's I/O object
- * @cmd_flags: Command flags; one or more of 'MC_CMD_FLAG_'
- * @token:     Token of DPBP object
- * @attr:      Returned object's attributes
- *
- * Return:     '0' on Success; Error code otherwise.
- */
-int dpbp_get_attributes(struct fsl_mc_io *mc_io,
-                       u32 cmd_flags,
-                       u16 token,
-                       struct dpbp_attr *attr)
-{
-       struct mc_command cmd = { 0 };
-       struct dpbp_rsp_get_attributes *rsp_params;
-       int err;
-
-       /* prepare command */
-       cmd.header = mc_encode_cmd_header(DPBP_CMDID_GET_ATTR,
-                                         cmd_flags, token);
-
-       /* send command to mc*/
-       err = mc_send_command(mc_io, &cmd);
-       if (err)
-               return err;
-
-       /* retrieve response parameters */
-       rsp_params = (struct dpbp_rsp_get_attributes *)cmd.params;
-       attr->bpid = le16_to_cpu(rsp_params->bpid);
-       attr->id = le32_to_cpu(rsp_params->id);
-
-       return 0;
-}
-EXPORT_SYMBOL_GPL(dpbp_get_attributes);
diff --git a/drivers/staging/fsl-mc/include/dpbp.h b/drivers/staging/fsl-mc/include/dpbp.h
deleted file mode 100644 (file)
index 7b9f7ad..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-/* SPDX-License-Identifier: (GPL-2.0+ OR BSD-3-Clause) */
-/*
- * Copyright 2013-2016 Freescale Semiconductor Inc.
- *
- */
-#ifndef __FSL_DPBP_H
-#define __FSL_DPBP_H
-
-/*
- * Data Path Buffer Pool API
- * Contains initialization APIs and runtime control APIs for DPBP
- */
-
-struct fsl_mc_io;
-
-int dpbp_open(struct fsl_mc_io *mc_io,
-             u32 cmd_flags,
-             int dpbp_id,
-             u16 *token);
-
-int dpbp_close(struct fsl_mc_io *mc_io,
-              u32 cmd_flags,
-              u16 token);
-
-int dpbp_enable(struct fsl_mc_io *mc_io,
-               u32 cmd_flags,
-               u16 token);
-
-int dpbp_disable(struct fsl_mc_io *mc_io,
-                u32 cmd_flags,
-                u16 token);
-
-int dpbp_reset(struct fsl_mc_io *mc_io,
-              u32 cmd_flags,
-              u16 token);
-
-/**
- * struct dpbp_attr - Structure representing DPBP attributes
- * @id:                DPBP object ID
- * @bpid:      Hardware buffer pool ID; should be used as an argument in
- *             acquire/release operations on buffers
- */
-struct dpbp_attr {
-       int id;
-       u16 bpid;
-};
-
-int dpbp_get_attributes(struct fsl_mc_io *mc_io,
-                       u32 cmd_flags,
-                       u16 token,
-                       struct dpbp_attr *attr);
-
-#endif /* __FSL_DPBP_H */
index 765ba41f5987fb1303c34fbaaaf72eaed121c8f0..66118e1fb5b9fecbde677dc44d05fa7f722c6e9e 100644 (file)
@@ -451,4 +451,46 @@ static inline bool is_fsl_mc_bus_dprtc(const struct fsl_mc_device *mc_dev)
        return mc_dev->dev.type == &fsl_mc_bus_dprtc_type;
 }
 
+/*
+ * Data Path Buffer Pool (DPBP) API
+ * Contains initialization APIs and runtime control APIs for DPBP
+ */
+
+int dpbp_open(struct fsl_mc_io *mc_io,
+             u32 cmd_flags,
+             int dpbp_id,
+             u16 *token);
+
+int dpbp_close(struct fsl_mc_io *mc_io,
+              u32 cmd_flags,
+              u16 token);
+
+int dpbp_enable(struct fsl_mc_io *mc_io,
+               u32 cmd_flags,
+               u16 token);
+
+int dpbp_disable(struct fsl_mc_io *mc_io,
+                u32 cmd_flags,
+                u16 token);
+
+int dpbp_reset(struct fsl_mc_io *mc_io,
+              u32 cmd_flags,
+              u16 token);
+
+/**
+ * struct dpbp_attr - Structure representing DPBP attributes
+ * @id:                DPBP object ID
+ * @bpid:      Hardware buffer pool ID; should be used as an argument in
+ *             acquire/release operations on buffers
+ */
+struct dpbp_attr {
+       int id;
+       u16 bpid;
+};
+
+int dpbp_get_attributes(struct fsl_mc_io *mc_io,
+                       u32 cmd_flags,
+                       u16 token,
+                       struct dpbp_attr *attr);
+
 #endif /* _FSL_MC_H_ */