net: hsr: fix naming of file and functions
authorMurali Karicheri <m-karicheri2@ti.com>
Mon, 15 Apr 2019 15:36:01 +0000 (11:36 -0400)
committerDavid S. Miller <davem@davemloft.net>
Tue, 16 Apr 2019 00:22:01 +0000 (17:22 -0700)
Fix the file name and functions to match with existing implementation.

Signed-off-by: Murali Karicheri <m-karicheri2@ti.com>
Signed-off-by: David S. Miller <davem@davemloft.net>
net/hsr/Makefile
net/hsr/hsr_debugfs.c [new file with mode: 0644]
net/hsr/hsr_device.c
net/hsr/hsr_main.h
net/hsr/hsr_prp_debugfs.c [deleted file]

index d74d89d013b0421aeb218e1fc7fc795924e3cefa..e45757fc477f0b26092e4bb5fe8f1cccd3ea733a 100644 (file)
@@ -6,4 +6,4 @@ obj-$(CONFIG_HSR)       += hsr.o
 
 hsr-y                  := hsr_main.o hsr_framereg.o hsr_device.o \
                           hsr_netlink.o hsr_slave.o hsr_forward.o
-hsr-$(CONFIG_DEBUG_FS) += hsr_prp_debugfs.o
+hsr-$(CONFIG_DEBUG_FS) += hsr_debugfs.o
diff --git a/net/hsr/hsr_debugfs.c b/net/hsr/hsr_debugfs.c
new file mode 100644 (file)
index 0000000..b5a9550
--- /dev/null
@@ -0,0 +1,120 @@
+/*
+ * hsr_debugfs code
+ * Copyright (C) 2017 Texas Instruments Incorporated
+ *
+ * Author(s):
+ *     Murali Karicheri <m-karicheri2@ti.com?
+ *
+ * This program is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License as
+ * published by the Free Software Foundation version 2.
+ *
+ * This program is distributed "as is" WITHOUT ANY WARRANTY of any
+ * kind, whether express or implied; without even the implied warranty
+ * of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ */
+#include <linux/module.h>
+#include <linux/errno.h>
+#include <linux/debugfs.h>
+#include "hsr_main.h"
+#include "hsr_framereg.h"
+
+static void print_mac_address(struct seq_file *sfp, unsigned char *mac)
+{
+       seq_printf(sfp, "%02x:%02x:%02x:%02x:%02x:%02x:",
+                  mac[0], mac[1], mac[2], mac[3], mac[4], mac[5]);
+}
+
+/* hsr_node_table_show - Formats and prints node_table entries */
+static int
+hsr_node_table_show(struct seq_file *sfp, void *data)
+{
+       struct hsr_priv *priv = (struct hsr_priv *)sfp->private;
+       struct hsr_node *node;
+
+       seq_puts(sfp, "Node Table entries\n");
+       seq_puts(sfp, "MAC-Address-A,   MAC-Address-B, time_in[A], ");
+       seq_puts(sfp, "time_in[B], Address-B port\n");
+       rcu_read_lock();
+       list_for_each_entry_rcu(node, &priv->node_db, mac_list) {
+               /* skip self node */
+               if (hsr_addr_is_self(priv, node->macaddress_A))
+                       continue;
+               print_mac_address(sfp, &node->macaddress_A[0]);
+               seq_puts(sfp, " ");
+               print_mac_address(sfp, &node->macaddress_B[0]);
+               seq_printf(sfp, "0x%lx, ", node->time_in[HSR_PT_SLAVE_A]);
+               seq_printf(sfp, "0x%lx ", node->time_in[HSR_PT_SLAVE_B]);
+               seq_printf(sfp, "0x%x\n", node->addr_B_port);
+       }
+       rcu_read_unlock();
+       return 0;
+}
+
+/* hsr_node_table_open - Open the node_table file
+ *
+ * Description:
+ * This routine opens a debugfs file node_table of specific hsr device
+ */
+static int
+hsr_node_table_open(struct inode *inode, struct file *filp)
+{
+       return single_open(filp, hsr_node_table_show, inode->i_private);
+}
+
+static const struct file_operations hsr_fops = {
+       .owner  = THIS_MODULE,
+       .open   = hsr_node_table_open,
+       .read   = seq_read,
+       .llseek = seq_lseek,
+       .release = single_release,
+};
+
+/* hsr_debugfs_init - create hsr node_table file for dumping
+ * the node table
+ *
+ * Description:
+ * When debugfs is configured this routine sets up the node_table file per
+ * hsr device for dumping the node_table entries
+ */
+int hsr_debugfs_init(struct hsr_priv *priv)
+{
+       int rc = -1;
+       struct dentry *de = NULL;
+
+       de = debugfs_create_dir("hsr", NULL);
+       if (!de) {
+               pr_err("Cannot create hsr debugfs root\n");
+               return rc;
+       }
+
+       priv->node_tbl_root = de;
+
+       de = debugfs_create_file("node_table", S_IFREG | 0444,
+                                priv->node_tbl_root, priv,
+                                &hsr_fops);
+       if (!de) {
+               pr_err("Cannot create hsr node_table directory\n");
+               return rc;
+       }
+       priv->node_tbl_file = de;
+       rc = 0;
+
+       return rc;
+}
+
+/* hsr_debugfs_term - Tear down debugfs intrastructure
+ *
+ * Description:
+ * When Debufs is configured this routine removes debugfs file system
+ * elements that are specific to hsr
+ */
+void
+hsr_debugfs_term(struct hsr_priv *priv)
+{
+       debugfs_remove(priv->node_tbl_file);
+       priv->node_tbl_file = NULL;
+       debugfs_remove(priv->node_tbl_root);
+       priv->node_tbl_root = NULL;
+}
index b47a621e3f4eac36f161f2a73a11c18e9dda302f..58cf500ebf945b66ca6e5e8f822382b914ac58c5 100644 (file)
@@ -354,7 +354,7 @@ static void hsr_dev_destroy(struct net_device *hsr_dev)
 
        hsr = netdev_priv(hsr_dev);
 
-       hsr_prp_debugfs_term(hsr);
+       hsr_debugfs_term(hsr);
 
        rtnl_lock();
        hsr_for_each_port(hsr, port)
@@ -485,7 +485,7 @@ int hsr_dev_finalize(struct net_device *hsr_dev, struct net_device *slave[2],
                goto fail;
 
        mod_timer(&hsr->prune_timer, jiffies + msecs_to_jiffies(PRUNE_PERIOD));
-       res = hsr_prp_debugfs_init(hsr);
+       res = hsr_debugfs_init(hsr);
        if (res)
                goto fail;
 
index 778213f07fe0820e3e55a5dd41cdf51784e7c953..6cd4dff58727aea9ab1d52fd9d213e47fe1b2e1c 100644 (file)
@@ -184,15 +184,15 @@ static inline u16 hsr_get_skb_sequence_nr(struct sk_buff *skb)
 }
 
 #if IS_ENABLED(CONFIG_DEBUG_FS)
-int hsr_prp_debugfs_init(struct hsr_priv *priv);
-void hsr_prp_debugfs_term(struct hsr_priv *priv);
+int hsr_debugfs_init(struct hsr_priv *priv);
+void hsr_debugfs_term(struct hsr_priv *priv);
 #else
-static inline int hsr_prp_debugfs_init(struct hsr_priv *priv)
+static inline int hsr_debugfs_init(struct hsr_priv *priv)
 {
        return 0;
 }
 
-static inline void hsr_prp_debugfs_term(struct hsr_priv *priv)
+static inline void hsr_debugfs_term(struct hsr_priv *priv)
 {}
 #endif
 
diff --git a/net/hsr/hsr_prp_debugfs.c b/net/hsr/hsr_prp_debugfs.c
deleted file mode 100644 (file)
index b30e987..0000000
+++ /dev/null
@@ -1,120 +0,0 @@
-/*
- * hsr_prp_debugfs code
- * Copyright (C) 2017 Texas Instruments Incorporated
- *
- * Author(s):
- *     Murali Karicheri <m-karicheri2@ti.com?
- *
- * This program is free software; you can redistribute it and/or
- * modify it under the terms of the GNU General Public License as
- * published by the Free Software Foundation version 2.
- *
- * This program is distributed "as is" WITHOUT ANY WARRANTY of any
- * kind, whether express or implied; without even the implied warranty
- * of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
- * GNU General Public License for more details.
- */
-#include <linux/module.h>
-#include <linux/errno.h>
-#include <linux/debugfs.h>
-#include "hsr_main.h"
-#include "hsr_framereg.h"
-
-static void print_mac_address(struct seq_file *sfp, unsigned char *mac)
-{
-       seq_printf(sfp, "%02x:%02x:%02x:%02x:%02x:%02x:",
-                  mac[0], mac[1], mac[2], mac[3], mac[4], mac[5]);
-}
-
-/* hsr_prp_node_table_show - Formats and prints node_table entries */
-static int
-hsr_prp_node_table_show(struct seq_file *sfp, void *data)
-{
-       struct hsr_priv *priv = (struct hsr_priv *)sfp->private;
-       struct hsr_node *node;
-
-       seq_puts(sfp, "Node Table entries\n");
-       seq_puts(sfp, "MAC-Address-A,   MAC-Address-B, time_in[A], ");
-       seq_puts(sfp, "time_in[B], Address-B port\n");
-       rcu_read_lock();
-       list_for_each_entry_rcu(node, &priv->node_db, mac_list) {
-               /* skip self node */
-               if (hsr_addr_is_self(priv, node->macaddress_A))
-                       continue;
-               print_mac_address(sfp, &node->macaddress_A[0]);
-               seq_puts(sfp, " ");
-               print_mac_address(sfp, &node->macaddress_B[0]);
-               seq_printf(sfp, "0x%lx, ", node->time_in[HSR_PT_SLAVE_A]);
-               seq_printf(sfp, "0x%lx ", node->time_in[HSR_PT_SLAVE_B]);
-               seq_printf(sfp, "0x%x\n", node->addr_B_port);
-       }
-       rcu_read_unlock();
-       return 0;
-}
-
-/* hsr_prp_node_table_open - Open the node_table file
- *
- * Description:
- * This routine opens a debugfs file node_table of specific hsr device
- */
-static int
-hsr_prp_node_table_open(struct inode *inode, struct file *filp)
-{
-       return single_open(filp, hsr_prp_node_table_show, inode->i_private);
-}
-
-static const struct file_operations hsr_prp_fops = {
-       .owner  = THIS_MODULE,
-       .open   = hsr_prp_node_table_open,
-       .read   = seq_read,
-       .llseek = seq_lseek,
-       .release = single_release,
-};
-
-/* hsr_prp_debugfs_init - create hsr-prp node_table file for dumping
- * the node table
- *
- * Description:
- * When debugfs is configured this routine sets up the node_table file per
- * hsr/prp device for dumping the node_table entries
- */
-int hsr_prp_debugfs_init(struct hsr_priv *priv)
-{
-       int rc = -1;
-       struct dentry *de = NULL;
-
-       de = debugfs_create_dir("hsr", NULL);
-       if (!de) {
-               pr_err("Cannot create hsr-prp debugfs root\n");
-               return rc;
-       }
-
-       priv->node_tbl_root = de;
-
-       de = debugfs_create_file("node_table", S_IFREG | 0444,
-                                priv->node_tbl_root, priv,
-                                &hsr_prp_fops);
-       if (!de) {
-               pr_err("Cannot create hsr-prp node_table directory\n");
-               return rc;
-       }
-       priv->node_tbl_file = de;
-       rc = 0;
-
-       return rc;
-}
-
-/* hsr_prp_debugfs_term - Tear down debugfs intrastructure
- *
- * Description:
- * When Debufs is configured this routine removes debugfs file system
- * elements that are specific to hsr-prp
- */
-void
-hsr_prp_debugfs_term(struct hsr_priv *priv)
-{
-       debugfs_remove(priv->node_tbl_file);
-       priv->node_tbl_file = NULL;
-       debugfs_remove(priv->node_tbl_root);
-       priv->node_tbl_root = NULL;
-}