Complain and exit out if CONFIG_MAC80211=y
authorLuis R. Rodriguez <lrodriguez@atheros.com>
Mon, 10 Nov 2008 22:35:11 +0000 (14:35 -0800)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Mon, 10 Nov 2008 22:35:11 +0000 (14:35 -0800)
Signed-off-by: Luis R. Rodriguez <lrodriguez@atheros.com>
config.mk

index c198ac2c8654cca27ea5df26ca70fce2e3569fd9..f2be5118e6b4f2e8ddf6ba24b37c0fbb04fca9ae 100644 (file)
--- a/config.mk
+++ b/config.mk
@@ -13,6 +13,9 @@ else
 include $(KLIB_BUILD)/.config
 endif
 
+ifeq ($(CONFIG_MAC80211),y)
+$(error "ERROR: you have MAC80211 compiled into the kernel, CONFIG_MAC80211=y, as such you cannot replace its mac80211 driver. You need this set to CONFIG_MAC80211=m. If you are using Fedora upgrade your kernel as later version should this set as modular. For further information on Fedora see https://bugzilla.redhat.com/show_bug.cgi?id=470143. If you are using your own kernel recompile it and make mac80211 modular")
+endif
 # Wireless subsystem stuff
 CONFIG_MAC80211=m