projects
/
openwrt
/
staging
/
stintel.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
2f96b67
)
kernel: modules: add irq support for pca953x
author
Oskari Lemmela
<oskari@lemmela.net>
Thu, 11 Jul 2024 07:47:36 +0000
(10:47 +0300)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Sun, 22 Sep 2024 16:42:34 +0000
(18:42 +0200)
Enable interrupt controller support for PCA953x kernel module
Signed-off-by: Oskari Lemmela <oskari@lemmela.net>
Link:
https://github.com/openwrt/openwrt/pull/15926
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/kernel/linux/modules/gpio.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/gpio.mk
b/package/kernel/linux/modules/gpio.mk
index 511cd3af8ca22166b599e023f1c9af18a5f73173..fc6ab66ba80f5b673b3524397aede0ae97d2c3c7 100644
(file)
--- a/
package/kernel/linux/modules/gpio.mk
+++ b/
package/kernel/linux/modules/gpio.mk
@@
-109,7
+109,8
@@
define KernelPackage/gpio-pca953x
SUBMENU:=$(GPIO_MENU)
DEPENDS:=@GPIO_SUPPORT +kmod-i2c-core +kmod-regmap-i2c
TITLE:=PCA95xx, TCA64xx, and MAX7310 I/O ports
- KCONFIG:=CONFIG_GPIO_PCA953X
+ KCONFIG:=CONFIG_GPIO_PCA953X \
+ CONFIG_GPIO_PCA953X_IRQ=y
FILES:=$(LINUX_DIR)/drivers/gpio/gpio-pca953x.ko
AUTOLOAD:=$(call AutoLoad,55,gpio-pca953x)
endef