projects
/
openwrt
/
staging
/
chunkeey.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
5dadc89
)
include: don't rely on perl for printing prereq errors
author
Jo-Philipp Wich
<jow@openwrt.org>
Thu, 5 Feb 2015 16:57:46 +0000
(16:57 +0000)
committer
Jo-Philipp Wich
<jow@openwrt.org>
Thu, 5 Feb 2015 16:57:46 +0000
(16:57 +0000)
Perl might not be present while checking prereqs, e.g. on a fresh
FreeBSD install.
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 44276
include/prereq.mk
patch
|
blob
|
history
diff --git
a/include/prereq.mk
b/include/prereq.mk
index d3b73663e34a16bef37e17e2ec31b4a3e5ee0e5d..83625e3bf2de08355d32b18d65979601b7ac17c9 100644
(file)
--- a/
include/prereq.mk
+++ b/
include/prereq.mk
@@
-35,7
+35,7
@@
define Require
echo 'ok.'; \
else \
echo 'failed.'; \
- echo -e "$(PKG_NAME): $(strip $(2))"
| perl -ne 's/\\\s*/\n/g,print'
>> $(TMP_DIR)/.prereq-error; \
+ echo -e "$(PKG_NAME): $(strip $(2))" >> $(TMP_DIR)/.prereq-error; \
fi
check-$(1): FORCE