imx-bootlets: Mark as nonshared to build in step 1
authorHauke Mehrtens <hauke@hauke-m.de>
Mon, 29 Jul 2024 22:29:11 +0000 (00:29 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 30 Jul 2024 19:42:33 +0000 (21:42 +0200)
Mark the package as nonshared to build it in the target specific build
step 1 of the build bots instead of the architecture generic build step
2. In the build step 2 it may be left out if we build it using a
different  target.

Fixes: 07043a853a34 ("imx23: rename imx23 to mxs for upcoming imx23/28 support")
Link: https://github.com/openwrt/openwrt/pull/16031
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/boot/imx-bootlets/Makefile

index 742c8a3bd0953c7b7971a12595b848839a50a645..de976c249a63bff51a7747bb11ca392d05b06a91 100644 (file)
@@ -13,6 +13,8 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://trabant.uid0.hu/openwrt/
 PKG_HASH:=09ecd81a64db5166a235932146faf08d0689bfc7ac04ac9fcc3a5bd809fba74a
 
+PKG_FLAGS:=nonshared
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/imx-bootlets