[packages] nginx: update to 0.7.65
authorNicolas Thill <nico@openwrt.org>
Tue, 20 Apr 2010 21:13:33 +0000 (21:13 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 20 Apr 2010 21:13:33 +0000 (21:13 +0000)
SVN-Revision: 21063

net/nginx/Makefile
net/nginx/patches/001-feature_test_fix
net/nginx/patches/002-sizeof_test_fix

index 10bdc2e3b06b3d6c1fcc0c2d2e184d488e225888..ba2a88600598a75313c181c7d9f2823633527192 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,21 +8,21 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nginx
-PKG_VERSION:=0.7.64
+PKG_VERSION:=0.7.65
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://sysoev.ru/nginx/
-PKG_MD5SUM:=cfa97c0f784532820110b5eee57fef6d
+PKG_MD5SUM:=abc4f76af450eedeb063158bd963feaa
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/nginx
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libpcre +libopenssl
   TITLE:=Nginx web server
   URL:=http://nginx.net/
+  DEPENDS:=+libpcre +libopenssl
 endef
 
 define Package/nginx/description
index df49e64e56d24aa637e8915973126af545c40fc1..8efa25eca0034bd432bbe6f581c98bc4a6a7a1ee 100644 (file)
@@ -1,5 +1,3 @@
-diff --git a/auto/cc/conf b/auto/cc/conf
-index 4823900..1e676f4 100644
 --- a/auto/cc/conf
 +++ b/auto/cc/conf
 @@ -135,7 +135,8 @@ if [ "$NGX_PLATFORM" != win32 ]; then
@@ -22,8 +20,6 @@ index 4823900..1e676f4 100644
       fi
  
  
-diff --git a/auto/cc/name b/auto/cc/name
-index d197fc5..28b74b0 100644
 --- a/auto/cc/name
 +++ b/auto/cc/name
 @@ -13,12 +13,12 @@ if [ "$NGX_PLATFORM" != win32 ]; then
@@ -45,11 +41,9 @@ index d197fc5..28b74b0 100644
  
  fi
  
-diff --git a/auto/os/linux b/auto/os/linux
-index 0bd0488..9cb0aa1 100644
 --- a/auto/os/linux
 +++ b/auto/os/linux
-@@ -49,7 +49,8 @@ ngx_feature_test="int efd = 0, fd = 1, n;
+@@ -49,7 +49,8 @@ ngx_feature_test="int efd = 0, fd = 1, n
                    ee.data.ptr = NULL;
                    efd = epoll_create(100);
                    if (efd == -1) return 1;"
@@ -79,7 +73,7 @@ index 0bd0488..9cb0aa1 100644
  
  
  ngx_include="sys/prctl.h"; . auto/include
-@@ -108,7 +111,8 @@ ngx_feature_incs="#include <sys/prctl.h>"
+@@ -108,7 +111,8 @@ ngx_feature_incs="#include <sys/prctl.h>
  ngx_feature_path=
  ngx_feature_libs=
  ngx_feature_test="if (prctl(PR_SET_DUMPABLE, 1, 0, 0, 0) == -1) return 1"
@@ -89,8 +83,6 @@ index 0bd0488..9cb0aa1 100644
  
  
  # sched_setaffinity()
-diff --git a/auto/unix b/auto/unix
-index 687a23a..23e8b78 100755
 --- a/auto/unix
 +++ b/auto/unix
 @@ -117,7 +117,7 @@ ngx_feature_path=
index b85caee93554b921eb2af9d794eafa0e23feeeb8..bea1080c2af358c57b56d16d0428af896c285d0f 100644 (file)
@@ -1,5 +1,3 @@
-diff --git a/auto/types/sizeof b/auto/types/sizeof
-index 4d65dca..2d5da3e 100644
 --- a/auto/types/sizeof
 +++ b/auto/types/sizeof
 @@ -23,8 +23,13 @@ $NGX_INCLUDE_UNISTD_H
@@ -17,7 +15,7 @@ index 4d65dca..2d5da3e 100644
      return 0;
  }
  
-@@ -38,7 +43,7 @@ eval "$ngx_test >> $NGX_AUTOCONF_ERR 2>&1"
+@@ -38,7 +43,7 @@ eval "$ngx_test >> $NGX_AUTOCONF_ERR 2>&
  
  
  if [ -x $NGX_AUTOTEST ]; then