ath79: add support for MikroTik RouterBOARD mAP lite
authorThibaut VARÈNE <hacks@slashdirt.org>
Thu, 10 Mar 2022 11:01:29 +0000 (12:01 +0100)
committerPetr Štetiar <ynezz@true.cz>
Sat, 16 Apr 2022 12:51:57 +0000 (14:51 +0200)
The MikroTik RouterBOARD mAPL-2nd (sold as mAP Lite) is a small
2.4 GHz 802.11b/g/n PoE-capable AP.

See https://mikrotik.com/product/RBmAPL-2nD for more info.

Specifications:
 - SoC: Qualcomm Atheros QCA9533
 - RAM: 64 MB
 - Storage: 16 MB NOR
 - Wireless: Atheros AR9531 (SoC) 802.11b/g/n 2x2:2, 1.5 dBi antenna
 - Ethernet: Atheros AR8229 (SoC), 1x 10/100 port, 802.3af/at PoE in
 - 4 user-controllable LEDs:
   · 1x power (green)
   · 1x user (green)
   · 1x lan (green)
   · 1x wlan (green)

Flashing:
 TFTP boot initramfs image and then perform sysupgrade. Follow common
 MikroTik procedure as in https://openwrt.org/toh/mikrotik/common.

Note: following 781d4bfb397cdd12ee0151eb66c577f470e3377d
 The network setup avoids using the integrated switch and connects the
 single Ethernet port directly. This way, link speed (10/100 Mbps) is
 properly reported by eth0.

Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org>
(cherry picked from commit eb38af788180d624e5b37aa5db1fe3766b138dc8)

target/linux/ath79/dts/qca9533_mikrotik_routerboard-mapl-2nd.dts [new file with mode: 0644]
target/linux/ath79/image/mikrotik.mk
target/linux/ath79/mikrotik/base-files/etc/board.d/01_leds
target/linux/ath79/mikrotik/base-files/etc/board.d/02_network
target/linux/ath79/mikrotik/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom

diff --git a/target/linux/ath79/dts/qca9533_mikrotik_routerboard-mapl-2nd.dts b/target/linux/ath79/dts/qca9533_mikrotik_routerboard-mapl-2nd.dts
new file mode 100644 (file)
index 0000000..e2442f0
--- /dev/null
@@ -0,0 +1,68 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca9533_mikrotik_routerboard-16m.dtsi"
+
+/ {
+       compatible = "mikrotik,routerboard-mapl-2nd", "qca,qca9533";
+       model = "MikroTik RouterBOARD mAPL-2nD (mAP lite)";
+
+       aliases {
+               led-boot = &led_user;
+               led-failsafe = &led_user;
+               led-running = &led_user;
+               led-upgrade = &led_user;
+       };
+
+       leds {
+               compatible = "gpio-leds";
+               pinctrl-names = "default";
+               pinctrl-0 = <&led_power_pin &led_lan_pin>;
+
+               power {
+                       label = "green:power";
+                       gpios = <&gpio 17 GPIO_ACTIVE_HIGH>;
+                       default-state = "on";
+               };
+
+               lan {
+                       label = "green:lan";
+                       gpios = <&gpio 4 GPIO_ACTIVE_HIGH>;
+               };
+
+               wlan {
+                       label = "green:wlan";
+                       gpios = <&gpio 11 GPIO_ACTIVE_HIGH>;
+                       linux,default-trigger = "phy0tpt";
+               };
+
+               led_user: user {
+                       label = "green:user";
+                       gpios = <&gpio 14 GPIO_ACTIVE_HIGH>;
+               };
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       phy-handle = <&swphy0>;
+
+       gmac-config {
+               device = <&gmac>;
+               switch-phy-swap = <1>;
+       };
+};
+
+&eth1 {
+       compatible = "syscon", "simple-mfd";
+};
+
+&pinmux {
+       led_lan_pin: pinmux_led_lan_pin {
+               pinctrl-single,bits = <0x4 0x0 0xff>;
+       };
+
+       led_power_pin: pinmux_led_power_pin {
+               pinctrl-single,bits = <0x10 0x0 0xff00>;
+       };
+};
index 4256f773792b48bda2e4f51e7925b553c0bac9dc..b2c700041937d2a23e247d2e48efc3bebd58eac3 100644 (file)
@@ -45,6 +45,14 @@ define Device/mikrotik_routerboard-lhg-2nd
 endef
 TARGET_DEVICES += mikrotik_routerboard-lhg-2nd
 
+define Device/mikrotik_routerboard-mapl-2nd
+  $(Device/mikrotik_nor)
+  SOC := qca9533
+  DEVICE_MODEL := RouterBOARD mAPL-2nD (mAP lite)
+  IMAGE_SIZE := 16256k
+endef
+TARGET_DEVICES += mikrotik_routerboard-mapl-2nd
+
 define Device/mikrotik_routerboard-sxt-5nd-r2
   $(Device/mikrotik_nand)
   SOC := ar9344
index 0d3209c2e35ea606c974b23a18d2b001f4f4a729..e95c5830e280d546cc890311bfc2b5efc3534e26 100755 (executable)
@@ -7,7 +7,8 @@ board_config_update
 board=$(board_name)
 
 case "$board" in
-mikrotik,routerboard-lhg-2nd)
+mikrotik,routerboard-lhg-2nd|\
+mikrotik,routerboard-mapl-2nd)
        ucidef_set_led_netdev "lan" "lan" "green:lan" "eth0"
        ;;
 mikrotik,routerboard-wapr-2nd)
index bd249e0b86de5705f0c0634c50edf24dac673900..bf8b9bdac2bd31f56cfdc3a731f59e551506f83b 100755 (executable)
@@ -18,6 +18,7 @@ ath79_setup_interfaces()
        mikrotik,routerboard-912uag-2hpnd|\
        mikrotik,routerboard-921gs-5hpacd-15s|\
        mikrotik,routerboard-lhg-2nd|\
+       mikrotik,routerboard-mapl-2nd|\
        mikrotik,routerboard-sxt-5nd-r2|\
        mikrotik,routerboard-wap-g-5hact2hnd|\
        mikrotik,routerboard-wapr-2nd)
@@ -41,6 +42,7 @@ ath79_setup_macs()
        mikrotik,routerboard-912uag-2hpnd|\
        mikrotik,routerboard-921gs-5hpacd-15s|\
        mikrotik,routerboard-lhg-2nd|\
+       mikrotik,routerboard-mapl-2nd|\
        mikrotik,routerboard-sxt-5nd-r2|\
        mikrotik,routerboard-wap-g-5hact2hnd|\
        mikrotik,routerboard-wapr-2nd)
index ae0c94d8ec996527bb0b8658d6b14be9da42e9ea..eca25b69dea35b929eaf55ea110a5e41affe8d79 100644 (file)
@@ -29,6 +29,7 @@ case "$FIRMWARE" in
        mikrotik,routerboard-wapr-2nd)
                caldata_mikrotik_ath9k 0x1000 0x440 $(macaddr_add "$mac_base" +1)
                ;;
+       mikrotik,routerboard-mapl-2nd|\
        mikrotik,routerboard-wap-g-5hact2hnd)
                caldata_mikrotik_ath9k 0x1000 0x440 $(macaddr_add "$mac_base" +2)
                ;;