compat-wireless: fix activesync devices
authorSven-Haegar Koch <haegar@sdinet.de>
Tue, 23 Nov 2010 22:27:35 +0000 (14:27 -0800)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Tue, 23 Nov 2010 22:27:35 +0000 (14:27 -0800)
Compiling support for ActiveSync devices in compat-wireless depends
on USB_NET_CDCETHER to be set in main kernel.

But USB_NET_CDCETHER can also be a module, in which case
CONFIG_USB_NET_CDCETHER will not be defined inside compat_autoconf.h and
the compat-wireless cdc_ether.ko will miss the support for it.

So check also for CONFIG_USB_NET_CDCETHER_MODULE in config.mk to be safe
in both cases.

Signed-off-by: Sven-Haegar Koch <haegar@sdinet.de>
config.mk

index 81cbf3101b28da89836847d65922a11ad3d0628f..ee20543ae650292b0aa711c78a34dcbc3be8c876 100644 (file)
--- a/config.mk
+++ b/config.mk
@@ -397,6 +397,10 @@ ifdef CONFIG_USB_NET_CDCETHER
 CONFIG_USB_NET_COMPAT_RNDIS_HOST=m
 CONFIG_USB_NET_COMPAT_RNDIS_WLAN=m
 endif #CONFIG_USB_NET_CDCETHER
+ifdef CONFIG_USB_NET_CDCETHER_MODULE
+CONFIG_USB_NET_COMPAT_RNDIS_HOST=m
+CONFIG_USB_NET_COMPAT_RNDIS_WLAN=m
+endif #CONFIG_USB_NET_CDCETHER
 CONFIG_USB_NET_COMPAT_CDCETHER=m
 endif #CONFIG_COMPAT_KERNEL_29