Refresh hack patches with make target/linux/refresh.
Signed-off-by: Weijie Gao <hackpascal@gmail.com>
--- a/include/linux/module.h
+++ b/include/linux/module.h
-@@ -163,6 +163,7 @@ extern void cleanup_module(void);
+@@ -164,6 +164,7 @@ extern void cleanup_module(void);
/* Generic info of form tag = "info" */
#define MODULE_INFO(tag, info) __MODULE_INFO(tag, tag, info)
/* For userspace: you can also call me... */
#define MODULE_ALIAS(_alias) MODULE_INFO(alias, _alias)
-@@ -232,12 +233,12 @@ extern void cleanup_module(void);
+@@ -233,12 +234,12 @@ extern void cleanup_module(void);
* Author(s), use "Name <email>" or just "Name", for multiple
* authors use multiple MODULE_AUTHOR() statements/lines.
*/
/* Creates an alias so file2alias.c can find device table. */
#define MODULE_DEVICE_TABLE(type, name) \
extern typeof(name) __mod_##type##__##name##_device_table \
-@@ -264,7 +265,9 @@ extern typeof(name) __mod_##type##__##na
+@@ -265,7 +266,9 @@ extern typeof(name) __mod_##type##__##na
*/
#if defined(MODULE) || !defined(CONFIG_SYSFS)
#else
#define MODULE_VERSION(_version) \
MODULE_INFO(version, _version); \
-@@ -287,7 +290,7 @@ extern typeof(name) __mod_##type##__##na
+@@ -288,7 +291,7 @@ extern typeof(name) __mod_##type##__##na
/* Optional firmware file (or files) needed by the module
* format is simply firmware file name. Multiple firmware
* files require multiple MODULE_FIRMWARE() specifiers */
--- a/kernel/module/Kconfig
+++ b/kernel/module/Kconfig
-@@ -290,4 +290,11 @@ config MODULES_TREE_LOOKUP
+@@ -389,4 +389,11 @@ config MODULES_TREE_LOOKUP
def_bool y
depends on PERF_EVENTS || TRACING || CFI_CLANG
if (err)
--- a/scripts/mod/modpost.c
+++ b/scripts/mod/modpost.c
-@@ -1785,7 +1785,9 @@ static void read_symbols(const char *mod
+@@ -1745,7 +1745,9 @@ static void read_symbols(const char *mod
symname = remove_dot(info.strtab + sym->st_name);
handle_symbol(mod, &info, sym, symname);
}
check_sec_ref(mod, &info);
-@@ -1944,8 +1946,10 @@ static void add_header(struct buffer *b,
+@@ -1918,8 +1920,10 @@ static void add_header(struct buffer *b,
buf_printf(b, "BUILD_SALT;\n");
buf_printf(b, "BUILD_LTO_INFO;\n");
buf_printf(b, "\n");
buf_printf(b, "\n");
buf_printf(b, "__visible struct module __this_module\n");
buf_printf(b, "__section(\".gnu.linkonce.this_module\") = {\n");
-@@ -1963,8 +1967,10 @@ static void add_header(struct buffer *b,
+@@ -1933,8 +1937,10 @@ static void add_header(struct buffer *b,
buf_printf(b, "\t.arch = MODULE_ARCH_INIT,\n");
buf_printf(b, "};\n");
buf_printf(b,
"\n"
-@@ -1972,8 +1978,10 @@ static void add_header(struct buffer *b,
+@@ -1942,8 +1948,10 @@ static void add_header(struct buffer *b,
"MODULE_INFO(retpoline, \"Y\");\n"
"#endif\n");
if (strstarts(mod->name, "tools/testing"))
buf_printf(b, "\nMODULE_INFO(test, \"Y\");\n");
-@@ -2069,11 +2077,13 @@ static void add_depends(struct buffer *b
+@@ -2053,11 +2061,13 @@ static void add_depends(struct buffer *b
static void add_srcversion(struct buffer *b, struct module *mod)
{
}
static void write_buf(struct buffer *b, const char *fname)
-@@ -2159,7 +2169,9 @@ static void write_mod_c_file(struct modu
+@@ -2140,7 +2150,9 @@ static void write_mod_c_file(struct modu
add_exported_symbols(&buf, mod);
add_versions(&buf, mod);
add_depends(&buf, mod);
--- a/scripts/mod/file2alias.c
+++ b/scripts/mod/file2alias.c
-@@ -38,6 +38,9 @@ typedef struct {
+@@ -35,6 +35,9 @@ typedef uint32_t __u32;
typedef uint16_t __u16;
typedef unsigned char __u8;
struct page;
struct kmem_cache;
-@@ -51,7 +55,9 @@ typedef __s8 s8;
+@@ -56,7 +60,9 @@ typedef __s8 s8;
#define __user
#endif
#define __must_check
typedef __u16 __bitwise __be16;
--- a/tools/perf/pmu-events/jevents.py
+++ b/tools/perf/pmu-events/jevents.py
-@@ -684,6 +684,7 @@ def main() -> None:
+@@ -1197,6 +1197,7 @@ such as "arm/cortex-a34".''',
#include "util/header.h"
#include "util/pmu.h"
#include <string.h>
#if defined(__BYTE_ORDER) ? __BYTE_ORDER == __LITTLE_ENDIAN : defined(__LITTLE_ENDIAN)
--- a/tools/arch/x86/include/asm/orc_types.h
+++ b/tools/arch/x86/include/asm/orc_types.h
-@@ -40,7 +40,6 @@
+@@ -46,7 +46,6 @@
#define ORC_TYPE_REGS_PARTIAL 4
#ifndef __ASSEMBLY__
/*
* This struct is more or less a vastly simplified version of the DWARF Call
-@@ -53,12 +52,12 @@
+@@ -59,12 +58,12 @@
struct orc_entry {
s16 sp_offset;
s16 bp_offset;
unsigned long __rb_parent_color;
--- a/tools/objtool/Makefile
+++ b/tools/objtool/Makefile
-@@ -40,7 +40,7 @@ include ../scripts/Makefile.arch
+@@ -40,7 +40,7 @@ elfshdr := $(shell echo '$(pound)include
OBJTOOL_CFLAGS += $(if $(elfshdr),,-DLIBELF_USE_DEPRECATED)
# Always want host compilation.
AWK = awk
MKDIR = mkdir
-@@ -43,6 +43,7 @@ BUILD_ORC := n
+@@ -55,6 +55,7 @@ BUILD_ORC := n
ifeq ($(SRCARCH),x86)
BUILD_ORC := y
export BUILD_ORC
--- a/tools/objtool/check.c
+++ b/tools/objtool/check.c
-@@ -1164,11 +1164,12 @@ static int add_ignore_alternatives(struc
+@@ -1288,11 +1288,12 @@ static int add_ignore_alternatives(struc
return 0;
}
{
return false;
}
-@@ -1177,7 +1178,7 @@ __weak bool arch_is_retpoline(struct sym
+@@ -1301,7 +1302,7 @@ __weak bool arch_is_retpoline(struct sym
* Symbols that replace INSN_RETURN, every (tail) call to such a symbol
* will be added to the .return_sites section.
*/
{
return false;
}
-@@ -1186,10 +1187,11 @@ __weak bool arch_is_rethunk(struct symbo
+@@ -1310,10 +1311,11 @@ __weak bool arch_is_rethunk(struct symbo
* Symbols that are embedded inside other instructions, because sometimes crazy
* code exists. These are mostly ignored for validation purposes.
*/
struct instruction *insn)
--- a/tools/objtool/special.c
+++ b/tools/objtool/special.c
-@@ -54,9 +54,11 @@ struct special_entry entries[] = {
+@@ -54,9 +54,11 @@ static const struct special_entry entrie
{},
};
---
--- a/arch/arm/Kconfig
+++ b/arch/arm/Kconfig
-@@ -124,6 +124,7 @@ config ARM
+@@ -128,6 +128,7 @@ config ARM
select HOTPLUG_CORE_SYNC_DEAD if HOTPLUG_CPU
select IRQ_FORCED_THREADING
select LOCK_MM_AND_FIND_VMA
select OF_EARLY_FLATTREE if OF
--- a/arch/arm/boot/compressed/Makefile
+++ b/arch/arm/boot/compressed/Makefile
-@@ -91,6 +91,7 @@ endif
+@@ -92,6 +92,7 @@ endif
ifeq ($(CONFIG_USE_OF),y)
OBJS += $(libfdt_objs) fdt_check_mem_start.o
endif
--- a/arch/arm/kernel/vmlinux.lds.S
+++ b/arch/arm/kernel/vmlinux.lds.S
-@@ -75,7 +75,7 @@ SECTIONS
+@@ -74,7 +74,7 @@ SECTIONS
. = ALIGN(4);
__ex_table : AT(ADDR(__ex_table) - LOAD_OFFSET) {
__start___ex_table = .;
__stop___ex_table = .;
}
-@@ -100,24 +100,24 @@ SECTIONS
+@@ -99,24 +99,24 @@ SECTIONS
}
.init.arch.info : {
__arch_info_begin = .;
__idmap_text_end = .; \
#define ARM_DISCARD \
-@@ -109,12 +109,12 @@
+@@ -108,12 +108,12 @@
. = ALIGN(8); \
.ARM.unwind_idx : { \
__start_unwind_idx = .; \
__stop_unwind_tab = .; \
}
-@@ -126,7 +126,7 @@
+@@ -125,7 +125,7 @@
__vectors_lma = .; \
OVERLAY 0xffff0000 : NOCROSSREFS AT(__vectors_lma) { \
.vectors { \
} \
.vectors.bhb.loop8 { \
*(.vectors.bhb.loop8) \
-@@ -144,7 +144,7 @@
+@@ -143,7 +143,7 @@
\
__stubs_lma = .; \
.stubs ADDR(.vectors) + 0x1000 : AT(__stubs_lma) { \
/* Align . function alignment. */
#define ALIGN_FUNCTION() . = ALIGN(CONFIG_FUNCTION_ALIGNMENT)
-@@ -511,14 +521,14 @@
+@@ -486,14 +496,14 @@
/* Kernel symbol table: Normal symbols */ \
__ksymtab : AT(ADDR(__ksymtab) - LOAD_OFFSET) { \
__start___ksymtab = .; \
__stop___ksymtab_gpl = .; \
} \
\
-@@ -538,7 +548,7 @@
+@@ -513,7 +523,7 @@
\
/* Kernel symbol table: strings */ \
__ksymtab_strings : AT(ADDR(__ksymtab_strings) - LOAD_OFFSET) { \
} \
\
/* __*init sections */ \
-@@ -1042,6 +1052,8 @@
+@@ -1000,6 +1010,8 @@
#define COMMON_DISCARDS \
SANITIZER_DISCARDS \
PATCHABLE_DISCARDS \
*(.export_symbol) \
--- a/include/linux/export-internal.h
+++ b/include/linux/export-internal.h
-@@ -23,6 +23,12 @@
+@@ -26,6 +26,12 @@
#define __KSYM_REF(sym) ".long " #sym
#endif
/*
* For every exported symbol, do the following:
*
-@@ -35,7 +41,7 @@
+@@ -38,7 +44,7 @@
* former apparently works on all arches according to the binutils source.
*/
#define __KSYMTAB(name, sym, sec, ns) \
"__kstrtabns_" #name ":" "\n" \
--- a/scripts/Makefile.build
+++ b/scripts/Makefile.build
-@@ -388,7 +388,7 @@ targets += $(real-dtb-y) $(lib-y) $(alwa
+@@ -366,7 +366,7 @@ targets += $(real-dtb-y) $(lib-y) $(alwa
# Linker scripts preprocessor (.lds.S -> .lds)
# ---------------------------------------------------------------------------
quiet_cmd_cpp_lds_S = LDS $@
{ {0x02, 0x21}, "lz4", unlz4 },
--- a/scripts/Makefile.lib
+++ b/scripts/Makefile.lib
-@@ -443,10 +443,10 @@ quiet_cmd_bzip2_with_size = BZIP2 $@
+@@ -456,10 +456,10 @@ quiet_cmd_bzip2_with_size = BZIP2 $@
# ---------------------------------------------------------------------------
quiet_cmd_lzma = LZMA $@
--- a/net/netfilter/Kconfig
+++ b/net/netfilter/Kconfig
-@@ -253,7 +253,6 @@ config NF_CONNTRACK_FTP
+@@ -259,7 +259,6 @@ config NF_CONNTRACK_FTP
config NF_CONNTRACK_H323
tristate "H.323 protocol support"
depends on NETFILTER_ADVANCED
help
H.323 is a VoIP signalling protocol from ITU-T. As one of the most
-@@ -1118,7 +1117,6 @@ config NETFILTER_XT_TARGET_SECMARK
+@@ -1120,7 +1119,6 @@ config NETFILTER_XT_TARGET_SECMARK
config NETFILTER_XT_TARGET_TCPMSS
tristate '"TCPMSS" target support'
select CRYPTO_AEAD2
select CRYPTO_ALGAPI
-@@ -75,7 +75,7 @@ config CRYPTO_AEAD2
+@@ -82,7 +82,7 @@ config CRYPTO_SIG2
select CRYPTO_ALGAPI2
config CRYPTO_SKCIPHER
select CRYPTO_SKCIPHER2
select CRYPTO_ALGAPI
-@@ -85,7 +85,7 @@ config CRYPTO_SKCIPHER2
+@@ -91,7 +91,7 @@ config CRYPTO_SKCIPHER2
select CRYPTO_ALGAPI2
config CRYPTO_HASH
select CRYPTO_HASH2
select CRYPTO_ALGAPI
-@@ -94,7 +94,7 @@ config CRYPTO_HASH2
+@@ -100,7 +100,7 @@ config CRYPTO_HASH2
select CRYPTO_ALGAPI2
config CRYPTO_RNG
bool
--- a/lib/Kconfig
+++ b/lib/Kconfig
-@@ -457,16 +457,16 @@ config BCH_CONST_T
+@@ -460,16 +460,16 @@ config BCH_CONST_T
# Textsearch support is select'ed if needed
#
config TEXTSEARCH
config SND_SEQ_DEVICE
tristate
-@@ -27,7 +27,7 @@ config SND_RAWMIDI
+@@ -40,7 +40,7 @@ config SND_UMP_LEGACY_RAWMIDI
The device contains 16 substreams corresponding to UMP groups.
config SND_COMPRESS_OFFLOAD
bool
--- a/net/Kconfig
+++ b/net/Kconfig
-@@ -430,7 +430,7 @@ config NET_DEVLINK
+@@ -467,7 +467,7 @@ config NET_DEVLINK
default n
config PAGE_POOL
--- a/init/Kconfig
+++ b/init/Kconfig
-@@ -2013,7 +2013,7 @@ config PADATA
+@@ -1989,7 +1989,7 @@ config PADATA
bool
config ASN1
that can be interpreted by the ASN.1 stream decoder and used to
--- a/lib/Kconfig
+++ b/lib/Kconfig
-@@ -637,7 +637,7 @@ config LIBFDT
+@@ -647,7 +647,7 @@ config LIBFDT
bool
config OID_REGISTRY
#include <linux/mutex.h>
#include <linux/err.h>
#include <linux/property.h>
-@@ -3513,3 +3514,5 @@ static int __init regmap_initcall(void)
+@@ -3433,3 +3434,5 @@ static int __init regmap_initcall(void)
return 0;
}
postcore_initcall(regmap_initcall);
+MODULE_LICENSE("GPL");
--- a/include/linux/regmap.h
+++ b/include/linux/regmap.h
-@@ -180,7 +180,7 @@ struct reg_sequence {
+@@ -197,7 +197,7 @@ struct reg_sequence {
__ret ?: __tmp; \
})
--- a/lib/crypto/Kconfig
+++ b/lib/crypto/Kconfig
-@@ -9,7 +9,7 @@ config CRYPTO_LIB_AES
+@@ -15,7 +15,7 @@ config CRYPTO_LIB_AESGCM
select CRYPTO_LIB_UTILS
config CRYPTO_LIB_ARC4
unsigned long flags;
--- a/drivers/mtd/mtdcore.c
+++ b/drivers/mtd/mtdcore.c
-@@ -32,6 +32,7 @@
+@@ -33,6 +33,7 @@
#include <linux/mtd/mtd.h>
#include <linux/mtd/partitions.h>
#include "mtdcore.h"
-@@ -1098,6 +1099,8 @@ int mtd_device_parse_register(struct mtd
+@@ -1125,6 +1126,8 @@ int mtd_device_parse_register(struct mtd
register_reboot_notifier(&mtd->reboot_notifier);
}
--- a/drivers/mtd/mtdcore.c
+++ b/drivers/mtd/mtdcore.c
-@@ -773,7 +773,8 @@ int add_mtd_device(struct mtd_info *mtd)
+@@ -801,7 +801,8 @@ int add_mtd_device(struct mtd_info *mtd)
mutex_unlock(&mtd_table_mutex);
--- a/net/netfilter/Kconfig
+++ b/net/netfilter/Kconfig
-@@ -1023,6 +1023,15 @@ config NETFILTER_XT_TARGET_NOTRACK
+@@ -1025,6 +1025,15 @@ config NETFILTER_XT_TARGET_NOTRACK
depends on NETFILTER_ADVANCED
select NETFILTER_XT_TARGET_CT
depends on NETFILTER_ADVANCED
--- a/net/netfilter/Makefile
+++ b/net/netfilter/Makefile
-@@ -154,6 +154,7 @@ obj-$(CONFIG_NETFILTER_XT_TARGET_CLASSIF
+@@ -163,6 +163,7 @@ obj-$(CONFIG_NETFILTER_XT_TARGET_CLASSIF
obj-$(CONFIG_NETFILTER_XT_TARGET_CONNSECMARK) += xt_CONNSECMARK.o
obj-$(CONFIG_NETFILTER_XT_TARGET_CT) += xt_CT.o
obj-$(CONFIG_NETFILTER_XT_TARGET_DSCP) += xt_DSCP.o
#include <net/netfilter/nf_flow_table.h>
#include <net/netfilter/nf_conntrack.h>
#include <net/netfilter/nf_conntrack_core.h>
-@@ -374,8 +373,7 @@ flow_offload_lookup(struct nf_flowtable
+@@ -377,8 +376,7 @@ flow_offload_lookup(struct nf_flowtable
}
EXPORT_SYMBOL_GPL(flow_offload_lookup);
void (*iter)(struct nf_flowtable *flowtable,
struct flow_offload *flow, void *data),
void *data)
-@@ -436,6 +434,7 @@ static void nf_flow_offload_gc_step(stru
+@@ -439,6 +437,7 @@ static void nf_flow_offload_gc_step(stru
nf_flow_offload_stats(flow_table, flow);
}
}
--- a/include/linux/netdevice.h
+++ b/include/linux/netdevice.h
-@@ -149,8 +149,8 @@ static inline bool dev_xmit_complete(int
+@@ -157,8 +157,8 @@ static inline bool dev_xmit_complete(int
#if defined(CONFIG_HYPERV_NET)
# define LL_MAX_HEADER 128
--- a/net/netfilter/nf_conntrack_core.c
+++ b/net/netfilter/nf_conntrack_core.c
-@@ -2705,7 +2705,7 @@ int nf_conntrack_init_start(void)
+@@ -2682,7 +2682,7 @@ int nf_conntrack_init_start(void)
if (!nf_conntrack_htable_size) {
nf_conntrack_htable_size
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -67,6 +67,80 @@ config SFP
+@@ -66,6 +66,80 @@ config SFP
depends on HWMON || HWMON=n
select MDIO_I2C
config AIR_EN8811H_PHY
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
-@@ -24,6 +24,21 @@ libphy-$(CONFIG_LED_TRIGGER_PHY) += phy_
+@@ -26,6 +26,21 @@ libphy-$(CONFIG_LED_TRIGGER_PHY) += phy_
obj-$(CONFIG_PHYLINK) += phylink.o
obj-$(CONFIG_PHYLIB) += libphy.o
--- a/drivers/net/dsa/mv88e6xxx/chip.c
+++ b/drivers/net/dsa/mv88e6xxx/chip.c
-@@ -3488,6 +3488,9 @@ static int mv88e6xxx_setup_port(struct m
+@@ -3305,6 +3305,9 @@ static int mv88e6xxx_setup_port(struct m
else
reg = 1 << port;
--- a/include/linux/netdevice.h
+++ b/include/linux/netdevice.h
-@@ -1707,6 +1707,7 @@ enum netdev_priv_flags {
+@@ -1759,6 +1759,7 @@ enum netdev_priv_flags {
IFF_TX_SKB_NO_LINEAR = BIT_ULL(31),
IFF_CHANGE_PROTO_DOWN = BIT_ULL(32),
IFF_SEE_ALL_HWTSTAMP_REQUESTS = BIT_ULL(33),
};
#define IFF_802_1Q_VLAN IFF_802_1Q_VLAN
-@@ -1763,6 +1764,7 @@ enum netdev_priv_flags {
+@@ -1792,6 +1793,7 @@ enum netdev_priv_flags {
#define IFF_FAILOVER_SLAVE IFF_FAILOVER_SLAVE
#define IFF_L3MDEV_RX_HANDLER IFF_L3MDEV_RX_HANDLER
#define IFF_TX_SKB_NO_LINEAR IFF_TX_SKB_NO_LINEAR
/* Specifies the type of the struct net_device::ml_priv pointer */
enum netdev_ml_priv_type {
-@@ -2131,6 +2133,11 @@ struct net_device {
+@@ -2184,6 +2186,11 @@ struct net_device {
const struct tlsdev_ops *tlsdev_ops;
#endif
const struct header_ops *header_ops;
unsigned char operstate;
-@@ -2206,6 +2213,10 @@ struct net_device {
+@@ -2259,6 +2266,10 @@ struct net_device {
struct mctp_dev __rcu *mctp_ptr;
#endif
*/
--- a/include/linux/skbuff.h
+++ b/include/linux/skbuff.h
-@@ -3040,6 +3040,10 @@ static inline int pskb_trim(struct sk_bu
+@@ -3075,6 +3075,10 @@ static inline int pskb_trim(struct sk_bu
return (len < skb->len) ? __pskb_trim(skb, len) : 0;
}
/**
* pskb_trim_unique - remove end from a paged unique (not cloned) buffer
* @skb: buffer to alter
-@@ -3189,16 +3193,6 @@ static inline struct sk_buff *dev_alloc_
+@@ -3240,16 +3244,6 @@ static inline struct sk_buff *dev_alloc_
}
help
--- a/net/core/dev.c
+++ b/net/core/dev.c
-@@ -3607,6 +3607,11 @@ static int xmit_one(struct sk_buff *skb,
+@@ -3571,6 +3571,11 @@ static int xmit_one(struct sk_buff *skb,
if (dev_nit_active(dev))
dev_queue_xmit_nit(skb, dev);
rc = netdev_start_xmit(skb, dev, txq, more);
--- a/net/core/skbuff.c
+++ b/net/core/skbuff.c
-@@ -61,6 +61,7 @@
+@@ -62,6 +62,7 @@
#include <linux/if_vlan.h>
#include <linux/mpls.h>
#include <linux/kcov.h>
#include <net/protocol.h>
#include <net/dst.h>
-@@ -709,6 +710,22 @@ skb_fail:
+@@ -844,6 +845,22 @@ skb_fail:
}
EXPORT_SYMBOL(__napi_alloc_skb);
#define MDIO_PHYXS_VEND_IF_STATUS 0xe812
#define MDIO_PHYXS_VEND_IF_STATUS_TYPE_MASK GENMASK(7, 3)
-@@ -898,6 +900,30 @@ static struct phy_driver aqr_driver[] =
+@@ -972,6 +974,30 @@ static struct phy_driver aqr_driver[] =
.get_stats = aqr107_get_stats,
.link_change_notify = aqr107_link_change_notify,
},
};
module_phy_driver(aqr_driver);
-@@ -917,6 +943,8 @@ static struct mdio_device_id __maybe_unu
+@@ -991,6 +1017,8 @@ static struct mdio_device_id __maybe_unu
{ PHY_ID_MATCH_MODEL(PHY_ID_AQR113) },
{ PHY_ID_MATCH_MODEL(PHY_ID_AQR113C) },
{ PHY_ID_MATCH_MODEL(PHY_ID_AQR813) },
--- a/drivers/net/pcs/pcs-mtk-lynxi.c
+++ b/drivers/net/pcs/pcs-mtk-lynxi.c
-@@ -92,14 +92,23 @@ static void mtk_pcs_lynxi_get_state(struct
+@@ -114,14 +114,23 @@ static void mtk_pcs_lynxi_get_state(stru
struct phylink_link_state *state)
{
struct mtk_pcs_lynxi *mpcs = pcs_to_mtk_pcs_lynxi(pcs);
}
static void mtk_sgmii_reset(struct mtk_pcs_lynxi *mpcs)
-@@ -109,7 +118,7 @@ static int mtk_pcs_lynxi_config(struct p
+@@ -142,7 +151,7 @@ static int mtk_pcs_lynxi_config(struct p
{
struct mtk_pcs_lynxi *mpcs = pcs_to_mtk_pcs_lynxi(pcs);
bool mode_changed = false, changed;
int advertise, link_timer;
advertise = phylink_mii_c22_pcs_encode_advertisement(interface,
-@@ -132,9 +141,8 @@ static int mtk_pcs_lynxi_config(struct p
+@@ -165,9 +174,8 @@ static int mtk_pcs_lynxi_config(struct p
if (neg_mode == PHYLINK_PCS_NEG_INBAND_ENABLED) {
if (interface == PHY_INTERFACE_MODE_SGMII)
sgm_mode |= SGMII_SPEED_DUPLEX_AN;
#include <linux/crc32.h>
#include <linux/if_vlan.h>
#include <linux/uaccess.h>
-@@ -7034,6 +7035,22 @@ static void rtl_tally_reset(struct r8152
+@@ -7035,6 +7036,22 @@ static void rtl_tally_reset(struct r8152
ocp_write_word(tp, MCU_TYPE_PLA, PLA_RSTTALLY, ocp_data);
}
static void r8152b_init(struct r8152 *tp)
{
u32 ocp_data;
-@@ -7075,6 +7092,8 @@ static void r8152b_init(struct r8152 *tp
+@@ -7076,6 +7093,8 @@ static void r8152b_init(struct r8152 *tp
ocp_data = ocp_read_word(tp, MCU_TYPE_USB, USB_USB_CTRL);
ocp_data &= ~(RX_AGG_DISABLE | RX_ZERO_EN);
ocp_write_word(tp, MCU_TYPE_USB, USB_USB_CTRL, ocp_data);
}
static void r8153_init(struct r8152 *tp)
-@@ -7215,6 +7234,8 @@ static void r8153_init(struct r8152 *tp)
+@@ -7216,6 +7235,8 @@ static void r8153_init(struct r8152 *tp)
tp->coalesce = COALESCE_SLOW;
break;
}
}
static void r8153b_init(struct r8152 *tp)
-@@ -7297,6 +7318,8 @@ static void r8153b_init(struct r8152 *tp
+@@ -7298,6 +7319,8 @@ static void r8153b_init(struct r8152 *tp
rtl_tally_reset(tp);
tp->coalesce = 15000; /* 15 us */
#include <linux/phy.h>
#include <linux/polynomial.h>
#include <linux/property.h>
-@@ -33,6 +34,7 @@
+@@ -38,6 +39,7 @@
#define PHY_MIISTAT 0x18 /* MII state */
#define PHY_IMASK 0x19 /* interrupt mask */
#define PHY_ISTAT 0x1A /* interrupt status */
#define PHY_FWV 0x1E /* firmware version */
#define PHY_MIISTAT_SPD_MASK GENMASK(2, 0)
-@@ -56,10 +58,15 @@
+@@ -61,10 +63,15 @@
PHY_IMASK_ADSC | \
PHY_IMASK_ANC)
#define PHY_PMA_MGBT_POLARITY 0x82
#define PHY_MDI_MDI_X_MASK GENMASK(1, 0)
#define PHY_MDI_MDI_X_NORMAL 0x3
-@@ -241,6 +248,35 @@ out:
+@@ -260,6 +267,35 @@ out:
return ret;
}
static int gpy_config_init(struct phy_device *phydev)
{
int ret;
-@@ -252,7 +288,10 @@ static int gpy_config_init(struct phy_de
+@@ -271,7 +307,10 @@ static int gpy_config_init(struct phy_de
/* Clear all pending interrupts */
ret = phy_read(phydev, PHY_ISTAT);
--- a/drivers/net/usb/qmi_wwan.c
+++ b/drivers/net/usb/qmi_wwan.c
-@@ -1082,12 +1082,18 @@ static const struct usb_device_id produc
+@@ -1083,12 +1083,18 @@ static const struct usb_device_id produc
USB_DEVICE_AND_INTERFACE_INFO(0x03f0, 0x581d, USB_CLASS_VENDOR_SPEC, 1, 7),
.driver_info = (unsigned long)&qmi_wwan_info,
},
--- a/drivers/net/phy/sfp.c
+++ b/drivers/net/phy/sfp.c
-@@ -409,6 +409,9 @@ static const struct sfp_quirk sfp_quirks
+@@ -471,6 +471,9 @@ static const struct sfp_quirk sfp_quirks
// FS 2.5G Base-T
SFP_QUIRK_M("FS", "SFP-2.5G-T", sfp_quirk_oem_2_5g),
// Lantech 8330-262D-E can operate at 2500base-X, but incorrectly report
// 2500MBd NRZ in their EEPROM
SFP_QUIRK_M("Lantech", "8330-262D-E", sfp_quirk_2500basex),
-@@ -2344,7 +2347,8 @@ static void sfp_sm_main(struct sfp *sfp,
+@@ -2587,7 +2590,8 @@ static void sfp_sm_main(struct sfp *sfp,
* or t_start_up, so assume there is a fault.
*/
sfp_sm_fault(sfp, SFP_S_INIT_TX_FAULT,
} else if (event == SFP_E_TIMEOUT || event == SFP_E_TX_CLEAR) {
init_done:
/* Create mdiobus and start trying for PHY */
-@@ -2578,10 +2582,12 @@ static void sfp_check_state(struct sfp *
+@@ -2841,10 +2845,12 @@ static void sfp_check_state(struct sfp *
mutex_lock(&sfp->st_mutex);
state = sfp_get_state(sfp);
changed = state ^ sfp->state;
int gpiod_export_link(struct device *dev, const char *name,
struct gpio_desc *desc);
void gpiod_unexport(struct gpio_desc *desc);
-@@ -653,12 +656,26 @@ void gpiod_unexport(struct gpio_desc *de
+@@ -653,11 +656,25 @@ void gpiod_unexport(struct gpio_desc *de
#include <asm/errno.h>
{
return -ENOSYS;
}
-
++
+static inline int gpio_export_with_name(struct gpio_desc *desc,
+ bool direction_may_change,
+ const char *name)
+{
+ return -ENOSYS;
+}
-+
+
static inline int gpiod_export_link(struct device *dev, const char *name,
struct gpio_desc *desc)
- {
--- a/drivers/gpio/gpiolib-sysfs.c
+++ b/drivers/gpio/gpiolib-sysfs.c
@@ -557,7 +557,7 @@ static struct class gpio_class = {
dev = device_create_with_groups(&gpio_class, &gdev->dev,
MKDEV(0, 0), data, gpio_groups,
-@@ -640,8 +642,21 @@ int gpiod_export(struct gpio_desc *desc,
+@@ -640,8 +642,21 @@ err_unlock:
gpiod_dbg(desc, "%s: status %d\n", __func__, status);
return status;
}
--- a/drivers/bcma/main.c
+++ b/drivers/bcma/main.c
-@@ -668,6 +668,14 @@ static int __init bcma_modinit(void)
+@@ -671,6 +671,14 @@ static int __init bcma_modinit(void)
{
int err;
--- a/net/Kconfig
+++ b/net/Kconfig
-@@ -104,6 +104,9 @@ source "net/mptcp/Kconfig"
+@@ -129,6 +129,9 @@ source "net/mptcp/Kconfig"
endif # if INET
obj-$(CONFIG_PROC_FS) += net-procfs.o
--- a/net/core/sock.c
+++ b/net/core/sock.c
-@@ -117,6 +117,7 @@
+@@ -118,6 +118,7 @@
#include <linux/mroute.h>
#include <linux/mroute6.h>
#include <linux/icmpv6.h>
#include <linux/uaccess.h>
-@@ -149,6 +150,7 @@
+@@ -150,6 +151,7 @@
static DEFINE_MUTEX(proto_list_mutex);
static LIST_HEAD(proto_list);
static void sock_def_write_space_wfree(struct sock *sk);
static void sock_def_write_space(struct sock *sk);
-@@ -588,6 +590,21 @@ int __sk_receive_skb(struct sock *sk, str
+@@ -589,6 +591,21 @@ discard_and_relse:
}
EXPORT_SYMBOL(__sk_receive_skb);
INDIRECT_CALLABLE_DECLARE(struct dst_entry *ip6_dst_check(struct dst_entry *,
u32));
INDIRECT_CALLABLE_DECLARE(struct dst_entry *ipv4_dst_check(struct dst_entry *,
-@@ -2238,9 +2255,11 @@ static void __sk_free(struct sock *sk)
+@@ -2246,9 +2263,11 @@ static void __sk_free(struct sock *sk)
if (likely(sk->sk_net_refcnt))
sock_inuse_add(sock_net(sk), -1);
Support for PF_PACKET sockets monitoring interface used by the ss tool.
--- a/net/unix/Kconfig
+++ b/net/unix/Kconfig
-@@ -33,6 +33,7 @@ config AF_UNIX_OOB
+@@ -29,6 +29,7 @@ config AF_UNIX_OOB
config UNIX_DIAG
tristate "UNIX: socket monitoring interface"
depends on UNIX
--- a/fs/locks.c
+++ b/fs/locks.c
-@@ -2909,6 +2909,8 @@ static const struct seq_operations locks
+@@ -2897,6 +2897,8 @@ static const struct seq_operations locks
static int __init proc_locks_init(void)
{
depends on PROC_FS
--- a/fs/proc/consoles.c
+++ b/fs/proc/consoles.c
-@@ -92,6 +92,9 @@ static const struct seq_operations conso
+@@ -107,6 +107,9 @@ static const struct seq_operations conso
static int __init proc_consoles_init(void)
{
if (!pe)
--- a/mm/vmalloc.c
+++ b/mm/vmalloc.c
-@@ -4205,6 +4205,8 @@ static const struct seq_operations vmall
+@@ -4439,6 +4439,8 @@ static const struct seq_operations vmall
static int __init proc_vmalloc_init(void)
{
&vmalloc_op,
--- a/mm/vmstat.c
+++ b/mm/vmstat.c
-@@ -2109,10 +2109,12 @@ void __init init_mm_internals(void)
+@@ -2135,10 +2135,12 @@ void __init init_mm_internals(void)
start_shepherd_timer();
#endif
#ifdef CONFIG_PROC_FS
goto err;
--- a/net/core/net-procfs.c
+++ b/net/core/net-procfs.c
-@@ -319,10 +319,12 @@ static int __net_init dev_proc_net_init(
+@@ -327,10 +327,12 @@ static int __net_init dev_proc_net_init(
if (!proc_create_net("dev", 0444, net->proc_net, &dev_seq_ops,
sizeof(struct seq_net_private)))
goto out;
sizeof(struct seq_net_private)))
goto out_softnet;
-@@ -332,9 +334,11 @@ static int __net_init dev_proc_net_init(
+@@ -340,9 +342,11 @@ static int __net_init dev_proc_net_init(
out:
return rc;
out_ptype:
out_dev:
remove_proc_entry("dev", net->proc_net);
goto out;
-@@ -344,8 +348,10 @@ static void __net_exit dev_proc_net_exit
+@@ -352,8 +356,10 @@ static void __net_exit dev_proc_net_exit
{
wext_proc_exit(net);
--- a/net/core/sock.c
+++ b/net/core/sock.c
-@@ -4114,6 +4114,8 @@ static __net_initdata struct pernet_oper
+@@ -4144,6 +4144,8 @@ static __net_initdata struct pernet_oper
static int __init proto_init(void)
{
--- a/net/ipv4/proc.c
+++ b/net/ipv4/proc.c
-@@ -553,5 +553,8 @@ static __net_initdata struct pernet_oper
+@@ -556,5 +556,8 @@ static __net_initdata struct pernet_oper
int __init ip_misc_proc_init(void)
{
--- a/net/ipv4/inet_timewait_sock.c
+++ b/net/ipv4/inet_timewait_sock.c
-@@ -269,7 +269,7 @@ void __inet_twsk_schedule(struct inet_ti
+@@ -266,7 +266,7 @@ void __inet_twsk_schedule(struct inet_ti
*/
if (!rearm) {
+dma-shared-buffer-objs := $(dma-buf-objs-y)
--- a/drivers/dma-buf/dma-buf.c
+++ b/drivers/dma-buf/dma-buf.c
-@@ -1636,4 +1636,5 @@ static void __exit dma_buf_deinit(void)
+@@ -1731,4 +1731,5 @@ static void __exit dma_buf_deinit(void)
kern_unmount(dma_buf_mnt);
dma_buf_uninit_sysfs_statistics();
}
+MODULE_LICENSE("GPL");
--- a/kernel/sched/core.c
+++ b/kernel/sched/core.c
-@@ -4367,6 +4367,7 @@ int wake_up_state(struct task_struct *p,
+@@ -4487,6 +4487,7 @@ int wake_up_state(struct task_struct *p,
{
return try_to_wake_up(p, state, 0);
}
* Perform scheduler related setup for a newly forked process p.
--- a/fs/d_path.c
+++ b/fs/d_path.c
-@@ -313,6 +313,7 @@ char *dynamic_dname(char *buffer, int bu
+@@ -314,6 +314,7 @@ char *dynamic_dname(char *buffer, int bu
buffer += buflen - sz;
return memcpy(buffer, temp, sz);
}
#ifdef CONFIG_UEVENT_HELPER
/* path to the userspace helper executed on an event */
extern char uevent_helper[];
-@@ -224,4 +226,7 @@ int kobject_synth_uevent(struct kobject
+@@ -219,4 +221,7 @@ int kobject_synth_uevent(struct kobject
__printf(2, 3)
int add_uevent_var(struct kobj_uevent_env *env, const char *format, ...);
--- a/drivers/of/fdt.c
+++ b/drivers/of/fdt.c
-@@ -1183,6 +1183,9 @@ int __init early_init_dt_scan_chosen(cha
+@@ -1185,6 +1185,9 @@ int __init early_init_dt_scan_chosen(cha
p = of_get_flat_dt_prop(node, "bootargs", &l);
if (p != NULL && l > 0)
strscpy(cmdline, p, min(l, COMMAND_LINE_SIZE));
--- a/drivers/base/core.c
+++ b/drivers/base/core.c
-@@ -1702,7 +1702,7 @@ static void device_links_purge(struct de
+@@ -1642,7 +1642,7 @@ static void device_links_purge(struct de
#define FW_DEVLINK_FLAGS_RPM (FW_DEVLINK_FLAGS_ON | \
DL_FLAG_PM_RUNTIME)