projects
/
openwrt
/
staging
/
noltari.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
e9f86c6
)
e2fsprogs: Honor the global verbose flag
author
Florian Fainelli
<f.fainelli@gmail.com>
Wed, 7 Sep 2016 17:25:33 +0000
(10:25 -0700)
committer
John Crispin
<john@phrozen.org>
Thu, 8 Sep 2016 11:40:03 +0000
(13:40 +0200)
Look for OPENWRT_VERBOSE and pass it down to the e2fsprogs entry-point
Makefile.
Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
package/utils/e2fsprogs/Makefile
patch
|
blob
|
history
diff --git
a/package/utils/e2fsprogs/Makefile
b/package/utils/e2fsprogs/Makefile
index 247b5ed4a479863b22a723c893831812da806ed4..4e25ab0dc6f414639c451b5d519ecc258a2ed6a6 100644
(file)
--- a/
package/utils/e2fsprogs/Makefile
+++ b/
package/utils/e2fsprogs/Makefile
@@
-131,12
+131,14
@@
define Build/Compile
CFLAGS="" \
CPPFLAGS="" \
LDFLAGS="" \
+ V=$(if $(findstring c,$(OPENWRT_VERBOSE)),1,) \
subst
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
LDFLAGS=-Wl,--gc-sections \
BUILDCC="$(HOSTCC)" \
DESTDIR="$(PKG_INSTALL_DIR)" \
LIBBLKID="$(PKG_BUILD_DIR)/lib/libblkid.a -luuid" \
+ V=$(if $(findstring c,$(OPENWRT_VERBOSE)),1,) \
all
endef