bcm47xx: Remove profiles for broadcom-wl
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 9 Jun 2024 15:00:45 +0000 (17:00 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 14 Jun 2024 12:54:16 +0000 (14:54 +0200)
The broadcom-wl driver was removed from OpenWrt, remove also the
profiles using it.

Fixes: e772b75d5d50 ("broadcom-wl: remove package")
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/bcm47xx/generic/profiles/101-Broadcom-wl.mk [deleted file]
target/linux/bcm47xx/generic/profiles/201-Broadcom-b44-wl.mk [deleted file]
target/linux/bcm47xx/generic/profiles/211-Broadcom-tg3-wl.mk [deleted file]
target/linux/bcm47xx/generic/profiles/221-Broadcom-bgmac-wl.mk [deleted file]
target/linux/bcm47xx/legacy/profiles/101-Broadcom-wl.mk [deleted file]
target/linux/bcm47xx/mips74k/profiles/102-Broadcom-wl.mk [deleted file]

diff --git a/target/linux/bcm47xx/generic/profiles/101-Broadcom-wl.mk b/target/linux/bcm47xx/generic/profiles/101-Broadcom-wl.mk
deleted file mode 100644 (file)
index 5bd3cd5..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-# SPDX-License-Identifier: GPL-2.0-only
-#
-# Copyright (C) 2010-2013 OpenWrt.org
-
-define Profile/Broadcom-wl
-  NAME:=Broadcom SoC, all Ethernet, BCM43xx WiFi (wl, proprietary)
-  PACKAGES:=-wpad-basic-mbedtls kmod-b44 kmod-tg3 kmod-bgmac kmod-brcm-wl wlc nas
-endef
-
-define Profile/Broadcom-wl/Description
-       Package set compatible with hardware any Broadcom BCM47xx or BCM535x
-       SoC with Broadcom BCM43xx Wifi cards using the proprietary Broadcom
-       wireless "wl" driver and b44, tg3 or bgmac Ethernet driver.
-endef
-
-$(eval $(call Profile,Broadcom-wl))
-
diff --git a/target/linux/bcm47xx/generic/profiles/201-Broadcom-b44-wl.mk b/target/linux/bcm47xx/generic/profiles/201-Broadcom-b44-wl.mk
deleted file mode 100644 (file)
index 8ae8e15..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-# SPDX-License-Identifier: GPL-2.0-only
-#
-# Copyright (C) 2010-2013 OpenWrt.org
-
-define Profile/Broadcom-b44-wl
-  NAME:=Broadcom SoC, b44 Ethernet, BCM43xx WiFi (wl, proprietary)
-  PACKAGES:=-wpad-basic-mbedtls kmod-b44 kmod-brcm-wl wlc nas
-endef
-
-define Profile/Broadcom-b44-wl/Description
-       Package set compatible with hardware older Broadcom BCM47xx or BCM535x
-       SoC with Broadcom BCM43xx Wifi cards using the proprietary Broadcom
-       wireless "wl" driver and b44 Ethernet driver.
-endef
-
-$(eval $(call Profile,Broadcom-b44-wl))
-
diff --git a/target/linux/bcm47xx/generic/profiles/211-Broadcom-tg3-wl.mk b/target/linux/bcm47xx/generic/profiles/211-Broadcom-tg3-wl.mk
deleted file mode 100644 (file)
index 605c295..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-# SPDX-License-Identifier: GPL-2.0-only
-#
-# Copyright (C) 2010-2013 OpenWrt.org
-
-define Profile/Broadcom-tg3-wl
-  NAME:=Broadcom SoC, tg3 Ethernet, BCM43xx WiFi (wl, proprietary)
-  PACKAGES:=-wpad-basic-mbedtls kmod-brcm-wl wlc nas kmod-tg3
-endef
-
-define Profile/Broadcom-tg3-wl/Description
-       Package set compatible with hardware Broadcom BCM4705/BCM4785
-       SoC with Broadcom BCM43xx Wifi cards using the proprietary Broadcom
-       wireless "wl" driver and tg3 Ethernet driver.
-endef
-
-$(eval $(call Profile,Broadcom-tg3-wl))
-
diff --git a/target/linux/bcm47xx/generic/profiles/221-Broadcom-bgmac-wl.mk b/target/linux/bcm47xx/generic/profiles/221-Broadcom-bgmac-wl.mk
deleted file mode 100644 (file)
index 264fed8..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-# SPDX-License-Identifier: GPL-2.0-only
-#
-# Copyright (C) 2010-2013 OpenWrt.org
-
-define Profile/Broadcom-bgmac-wl
-  NAME:=Broadcom SoC, bgmac Ethernet, BCM43xx WiFi (wl, proprietary)
-  PACKAGES:=-wpad-basic-mbedtls kmod-bgmac kmod-brcm-wl wlc nas
-endef
-
-define Profile/Broadcom-bgmac-wl/Description
-       Package set compatible with hardware newer Broadcom BCM47xx or BCM535x
-       SoC with Broadcom BCM43xx Wifi cards using the proprietary Broadcom
-       wireless "wl" driver and bgmac Ethernet driver.
-endef
-
-$(eval $(call Profile,Broadcom-bgmac-wl))
-
diff --git a/target/linux/bcm47xx/legacy/profiles/101-Broadcom-wl.mk b/target/linux/bcm47xx/legacy/profiles/101-Broadcom-wl.mk
deleted file mode 100644 (file)
index 0d98981..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-# SPDX-License-Identifier: GPL-2.0-only
-#
-# Copyright (C) 2010-2013 OpenWrt.org
-
-define Profile/Broadcom-wl
-  NAME:=Broadcom SoC, all Ethernet, BCM43xx WiFi (wl, proprietary)
-  PACKAGES:=-wpad-basic-mbedtls kmod-brcm-wl-mini wlc nas
-endef
-
-define Profile/Broadcom-wl/Description
-       Package set compatible with hardware any Broadcom BCM47xx or BCM535x
-       SoC with Broadcom BCM43xx Wifi cards using the proprietary Broadcom
-       wireless "wl" driver and b44, tg3 or bgmac Ethernet driver.
-endef
-
-$(eval $(call Profile,Broadcom-wl))
-
diff --git a/target/linux/bcm47xx/mips74k/profiles/102-Broadcom-wl.mk b/target/linux/bcm47xx/mips74k/profiles/102-Broadcom-wl.mk
deleted file mode 100644 (file)
index 0b0e706..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-# SPDX-License-Identifier: GPL-2.0-only
-#
-# Copyright (C) 2014 OpenWrt.org
-
-define Profile/Broadcom-mips74k-wl
-  NAME:=Broadcom SoC, BCM43xx WiFi (proprietary wl)
-  PACKAGES:=-wpad-basic-mbedtls kmod-brcm-wl wlc nas
-endef
-
-define Profile/Broadcom-mips74k-wl/Description
-       Package set for devices with BCM43xx WiFi including proprietary (and
-       closed source) driver "wl".
-endef
-
-$(eval $(call Profile,Broadcom-mips74k-wl))
-