rsync: don't use internal zlib library
authorLuka Perkov <luka@openwrt.org>
Mon, 24 Mar 2014 05:22:46 +0000 (05:22 +0000)
committerLuka Perkov <luka@openwrt.org>
Mon, 24 Mar 2014 05:22:46 +0000 (05:22 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 40014

net/rsync/Makefile

index 69679f6867a6e243dd4f89db17933f4b8f390eb7..f66c694f144b92409e4d90eb82c383148bc4d82b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rsync
 PKG_VERSION:=3.1.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://rsync.samba.org/ftp/rsync/src
@@ -25,7 +25,7 @@ define Package/rsync
   CATEGORY:=Network
   SUBMENU:=File Transfer
   TITLE:=Fast remote file copy program (like rcp)
-  DEPENDS:=+libpopt
+  DEPENDS:=+libpopt +zlib
   URL:=http://rsync.samba.org/
 endef
 
@@ -50,6 +50,7 @@ endef
 
 CONFIGURE_ARGS += \
        --with-included-popt=no \
+       --with-included-zlib=no \
        --disable-debug \
        --disable-locale \
        --disable-xattr-support \