build system: handle int Kconfig options in autoconf header
authorJohannes Berg <johannes.berg@intel.com>
Fri, 5 Apr 2013 08:21:21 +0000 (10:21 +0200)
committerJohannes Berg <johannes.berg@intel.com>
Fri, 5 Apr 2013 08:21:21 +0000 (10:21 +0200)
Add a line of shell script code to handle int Kconfig
options when creating the autoconf header.

Signed-off-by: Johannes Berg <johannes.berg@intel.com>
backport/Makefile.real

index 07eb8fc45573b20dca3a8b84550e85562c6df762..954fc8691d987156c602ad7e8d010824544860dd 100644 (file)
@@ -65,6 +65,7 @@ include/linux/compat_autoconf.h: .config
                                y) echo "#define $$n 1" ;;              \
                                m) echo "#define $${n}_MODULE 1" ;;     \
                                \"*) echo "#define $$n $$v" ;;          \
+                               [0-9]*) echo "#define $$n $$v" ;;       \
                                *) echo "#warning unknown value for $$n";;\
                        esac                                            ;\
                done                                                    ;\