kernel: catch up rxrpc
authorNathaniel Wesley Filardo <nwfilardo@gmail.com>
Thu, 20 Jun 2024 14:15:41 +0000 (15:15 +0100)
committerRobert Marko <robimarko@gmail.com>
Sun, 23 Jun 2024 12:07:17 +0000 (14:07 +0200)
New dependencies required for the module to be useful, and correct IPv6 support

Signed-off-by: Nathaniel Wesley Filardo <nwfilardo@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/15761
Signed-off-by: Robert Marko <robimarko@gmail.com>
package/kernel/linux/modules/netsupport.mk

index 0ee58fada47bb84243ea4e48467c872a51bae922..e56defad38cc7fd35cc793043ca1a15dee4304e1 100644 (file)
@@ -1297,13 +1297,20 @@ define KernelPackage/rxrpc
   HIDDEN:=1
   KCONFIG:= \
        CONFIG_AF_RXRPC \
-       CONFIG_RXKAD=m \
+       CONFIG_AF_RXRPC_IPV6=y \
+       CONFIG_RXKAD \
        CONFIG_AF_RXRPC_DEBUG=n
   FILES:= \
        $(LINUX_DIR)/net/rxrpc/rxrpc.ko
-  AUTOLOAD:=$(call AutoLoad,30,rxrpc.ko)
-  DEPENDS:= +kmod-crypto-manager +kmod-crypto-pcbc +kmod-crypto-fcrypt \
-    +kmod-udptunnel4 +kmod-udptunnel6
+  AUTOLOAD:=$(call AutoLoad,30,rxrpc)
+  DEPENDS:= \
+       +kmod-crypto-fcrypt \
+       +kmod-crypto-hmac \
+       +kmod-crypto-manager \
+       +kmod-crypto-md5 \
+       +kmod-crypto-pcbc \
+       +kmod-udptunnel4 \
+       +IPV6:kmod-udptunnel6
 endef
 
 define KernelPackage/rxrpc/description