newer versions of sdcc dropped support for xa51, compiles fine without so change...
authorTravis Kemen <thepeople@openwrt.org>
Mon, 4 Apr 2011 19:42:27 +0000 (19:42 +0000)
committerTravis Kemen <thepeople@openwrt.org>
Mon, 4 Apr 2011 19:42:27 +0000 (19:42 +0000)
SVN-Revision: 26473

utils/firmwarehotplug/Makefile

index 17bc11f63ebeb532fe55f410abb5aa1b858472a1..d30cc2241418c067eedcfd56226bc1b1e9783a1c 100644 (file)
@@ -48,7 +48,7 @@ define Package/firmwarehotplug/install
 endef
 
 define Require/working-sdcc
-       sdcc -v 2>&1 | awk '($$$$1 == "SDCC") && ($$$$3 == "mcs51/gbz80/z80/avr/ds390/pic16/pic14/TININative/xa51/ds400/hc08") { print "ok" }' | grep ok > /dev/null
+       sdcc -v 2>&1 | awk '($$$$1 == "SDCC") && ($$$$3 ~ "mcs51/gbz80/z80/ds390/pic16/pic14/TININative/") { print "ok" }' | grep ok > /dev/null
 endef
 
 $(eval $(call RequireCommand,sdcc, \