openrrcp: allow passing our CFLAGS and LDFLAGS
authorFlorian Fainelli <florian@openwrt.org>
Sat, 8 Mar 2014 00:57:14 +0000 (00:57 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 8 Mar 2014 00:57:14 +0000 (00:57 +0000)
Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 39815

net/openrrcp/Makefile

index dad1f1f9de2fc2a5b7e7ea80efdcdfa1f71f5ba6..9e89887943c7146fdea22bd1b6a37b3bef65879c 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openrrcp
 PKG_VERSION:=0.2.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://nording.ru/projects/download/openrrcp/stable
@@ -28,11 +28,9 @@ define Package/openrrcp/description
        OpenRRCP toolset for managing RRCP-capable Ethernet switches
 endef
 
-define Build/Compile
-       $(call Build/Compile/Default, \
-               PREFIX="/usr" \
-       )
-endef
+MAKE_VARS += \
+       PREFIX="/usr" \
+       $(TARGET_CONFIGURE_OPTS)
 
 define Package/openrrcp/install
        $(MAKE) -C $(PKG_BUILD_DIR) \