projects
/
openwrt
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
17cfcaa
)
kernel: usb: simplify usb-net kconfig
author
Rui Salvaterra
<rsalvaterra@gmail.com>
Sat, 1 Feb 2025 18:48:29 +0000
(18:48 +0000)
committer
Rui Salvaterra
<rsalvaterra@gmail.com>
Mon, 10 Mar 2025 12:39:42 +0000
(12:39 +0000)
Now that CONFIG_USB_NET_DRIVERS is unconditionally enabled, remove it from the
usb-net kconfig symbol list.
Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
package/kernel/linux/modules/usb.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/usb.mk
b/package/kernel/linux/modules/usb.mk
index 481d2be59a201ee14f2c99cbfe7a3c7ab8e38363..84a6354183a0a8ae1b1f91272a9c7df46078df05 100644
(file)
--- a/
package/kernel/linux/modules/usb.mk
+++ b/
package/kernel/linux/modules/usb.mk
@@
-1178,8
+1178,7
@@
$(eval $(call KernelPackage,usb-atm-cxacru))
define KernelPackage/usb-net
TITLE:=Kernel modules for USB-to-Ethernet convertors
DEPENDS:=+kmod-mii
- KCONFIG:=CONFIG_USB_USBNET \
- CONFIG_USB_NET_DRIVERS
+ KCONFIG:=CONFIG_USB_USBNET
AUTOLOAD:=$(call AutoProbe,usbnet)
FILES:=$(LINUX_DIR)/drivers/$(USBNET_DIR)/usbnet.ko
$(call AddDepends/usb)